mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
removed community/bluegriffon
This commit is contained in:
parent
5797eea962
commit
da00f03e79
7 changed files with 0 additions and 2037 deletions
|
@ -1,132 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Muflone http://www.muflone.com/contacts/english/
|
||||
# Contributor: Balló György <ballogyor+arch at gmail dot com>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - mozconfig changes
|
||||
# - upstream patch for https://bugzilla.mozilla.org/show_bug.cgi?id=1257019
|
||||
|
||||
highmem=1
|
||||
|
||||
pkgname=bluegriffon
|
||||
pkgver=2.3.1
|
||||
_mozilla_ver=f14898695ee0
|
||||
pkgrel=3
|
||||
pkgdesc="The next-generation Web Editor based on the rendering engine of Firefox"
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://bluegriffon.org/"
|
||||
license=('MPL' 'GPL' 'LGPL')
|
||||
depends=('alsa-lib' 'desktop-file-utils' 'dbus-glib' 'gtk2' 'gtk3' 'hunspell' 'mozilla-common'
|
||||
'nss' 'libevent' 'libvpx' 'libxt' 'python2' 'startup-notification')
|
||||
makedepends=('autoconf2.13' 'libpulse' 'unzip' 'zip' 'yasm')
|
||||
options=('!emptydirs')
|
||||
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/therealglazou/${pkgname}/archive/${pkgver}.tar.gz"
|
||||
"mozilla-central-${_mozilla_ver}.tar.bz2"::"https://hg.mozilla.org/mozilla-central/archive/${_mozilla_ver}.tar.bz2"
|
||||
"bug_1329272_icu.patch"::"https://hg.mozilla.org/releases/mozilla-esr45/raw-diff/571b48abf054/build/autoconf/icu.m4"
|
||||
"bug_1290037_update_keybits_in_h2.patch"::"https://hg.mozilla.org/mozilla-central/raw-rev/361ac226da2a"
|
||||
"bug_1269171_mozalloc_in_stl_wrappers.patch"::"https://hg.mozilla.org/mozilla-central/raw-rev/68da139d0866"
|
||||
"bug_1371991_no_lib_nss_crmf.patch"
|
||||
"${pkgname}_gtk3.patch"
|
||||
"bug_1234158_firefox-gtk3-20.patch"
|
||||
"event__sizeof.patch"
|
||||
"mozconfig"
|
||||
"${pkgname}.desktop"
|
||||
"bug_1257019.patch"::"https://hg.mozilla.org/mozilla-central/raw-rev/d5e77c8d64c9")
|
||||
sha256sums=('1fb0ba05a024be3029fe800ef0297e9e5ff3dcb631d04a95ca30e33e5aa261d7'
|
||||
'0b13213b5f9b3819b56872f7fb4fa7a1170ade06f8797dc11114e5f7c8eabca2'
|
||||
'93de8102de543bad38dc49d9ffcf7a8a2d9246594a8e7b92c38736ed6c6050cd'
|
||||
'87fb92e45f161d47b9e3ca31bcce60555bc33d633116dab4baa3bfba6ad965c4'
|
||||
'9d4849338dad39b978f7c15a93c3c255d72d7bfdffa897900a0bdddd771d2e17'
|
||||
'08e40f75395d26359ce9bcce42789961900b4dc8fbab8555baba6a2895f7798d'
|
||||
'3868f39181a258823c45e7ad62bba8e7b6e8b07c41535dd584c2dc71431f5deb'
|
||||
'd5e1b9a702dc693184494899fc4cd57ac206e1fd5415a8e5520b8ff3b822e734'
|
||||
'f4440c9d3826f4cda18b9d00129347fe6a22de61e11d593b1a522fa46d685ca0'
|
||||
'3c162de2bae884a573b2c1260500352e6b9c7803758cc73975109482503b9eb0'
|
||||
'882133b77840356985a81e496b4ddc443f8f33c068cfb7ef0858497820adcfff'
|
||||
'd0229aa67aa68dd50755fd022cf34af2a2a36faef2cf2ce06a336ebef7a08974')
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
|
||||
# Fix build with GTK+3
|
||||
patch -Np1 -i "${srcdir}/${pkgname}_gtk3.patch"
|
||||
|
||||
cd "${srcdir}/mozilla-central-${_mozilla_ver}"
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1329272
|
||||
patch -Np1 -i "${srcdir}/bug_1329272_icu.patch"
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1290037
|
||||
patch -Np1 -i "${srcdir}/bug_1290037_update_keybits_in_h2.patch"
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1269171
|
||||
patch -Np1 -i "${srcdir}/bug_1269171_mozalloc_in_stl_wrappers.patch"
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
|
||||
# https://bugs.archlinux.org/task/54395
|
||||
patch -Np1 -i "${srcdir}/bug_1371991_no_lib_nss_crmf.patch"
|
||||
|
||||
# Fix for libevent 2.1
|
||||
# Change _EVENT_SIZEOF to EVENT__SIZEOF
|
||||
patch -Np1 -i "${srcdir}/event__sizeof.patch"
|
||||
|
||||
# Move files to their correct location
|
||||
cp -r "${srcdir}/${pkgname}-${pkgver}" bluegriffon
|
||||
cp "${srcdir}/mozconfig" .mozconfig
|
||||
|
||||
# https://bugzilla.mozilla.org/show_bug.cgi?id=1234158
|
||||
patch -Np1 -i "${srcdir}/bug_1234158_firefox-gtk3-20.patch"
|
||||
|
||||
# Apply BlueGriffon's upstream customizations
|
||||
patch -Np1 -i "bluegriffon/config/content.patch"
|
||||
|
||||
# ALARM
|
||||
patch -p1 -i ../bug_1257019.patch
|
||||
|
||||
# python2 fix
|
||||
find . -name \*.py -exec sed -i 's@^#.*python$@#!/usr/bin/python2@' '{}' \;
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/mozilla-central-${_mozilla_ver}"
|
||||
|
||||
# configure script misdetects the preprocessor without an optimization level
|
||||
# https://bugs.archlinux.org/task/34644
|
||||
export CPPFLAGS+=' -O2'
|
||||
export PYTHON=python2
|
||||
|
||||
# Fix linking with gtk3
|
||||
export LDFLAGS+=" $(pkg-config --libs gtk+-3.0)"
|
||||
|
||||
# Build the package
|
||||
./mach build
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/mozilla-central-${_mozilla_ver}"
|
||||
|
||||
# Install files
|
||||
install -m 755 -d "${pkgdir}/usr/lib/${pkgname}"
|
||||
cp -LR bg/dist/bin/* "${pkgdir}/usr/lib/${pkgname}"
|
||||
|
||||
# Install executable file
|
||||
install -m 755 -d "${pkgdir}/usr/bin"
|
||||
ln -sf /usr/lib/${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
|
||||
|
||||
# Install icons
|
||||
cp bluegriffon/branding/mozicon128.png bluegriffon/branding/default128.png
|
||||
for _icon in 16 32 48 128 256; do
|
||||
install -Dm644 bluegriffon/branding/default${_icon}.png \
|
||||
"${pkgdir}/usr/share/icons/hicolor/${_icon}x${_icon}/apps/${pkgname}.png"
|
||||
done
|
||||
|
||||
# Install desktop file
|
||||
install -Dm644 ../${pkgname}.desktop \
|
||||
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
|
||||
|
||||
# Use system-provided dictionaries
|
||||
rm -rf "${pkgdir}/usr/lib/${pkgname}/dictionaries"
|
||||
ln -sf /usr/share/hunspell "${pkgdir}/usr/lib/${pkgname}/dictionaries"
|
||||
rm -rf "${pkgdir}/usr/lib/${pkgname}hyphenation"
|
||||
ln -sf /usr/share/hyphen "${pkgdir}/usr/lib/${pkgname}/hyphenation"
|
||||
}
|
|
@ -1,16 +0,0 @@
|
|||
[Desktop Entry]
|
||||
Name=BlueGriffon
|
||||
GenericName=Web Editor
|
||||
GenericName[hu]=Webszerkesztő
|
||||
X-GNOME-FullName=BlueGriffon Web Editor
|
||||
X-GNOME-FullName[hu]=BlueGriffon webszerkesztő
|
||||
Comment=Create Web Pages
|
||||
Comment[es]=Crea páginas web
|
||||
Comment[hu]=Weboldalak készítése
|
||||
Comment[it]=Creare pagine Web
|
||||
Categories=Development;WebDevelopment;
|
||||
Exec=bluegriffon
|
||||
Icon=bluegriffon
|
||||
Terminal=false
|
||||
MimeType=text/html;application/xhtml+xml;
|
||||
Type=Application
|
|
@ -1,46 +0,0 @@
|
|||
diff -Naur bluegriffon-2.1.1.orig/config/content.patch bluegriffon-2.1.1/config/content.patch
|
||||
--- bluegriffon-2.1.1.orig/config/content.patch 2016-07-23 21:54:18.367575963 +0000
|
||||
+++ bluegriffon-2.1.1/config/content.patch 2016-07-24 00:36:03.891186550 +0000
|
||||
@@ -4714,14 +4714,8 @@
|
||||
diff --git a/widget/gtk/nsColorPicker.cpp b/widget/gtk/nsColorPicker.cpp
|
||||
--- a/widget/gtk/nsColorPicker.cpp
|
||||
+++ b/widget/gtk/nsColorPicker.cpp
|
||||
-@@ -1,21 +1,24 @@
|
||||
- /* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
|
||||
- /* This Source Code Form is subject to the terms of the Mozilla Public
|
||||
- * License, v. 2.0. If a copy of the MPL was not distributed with this
|
||||
- * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
|
||||
-
|
||||
+@@ -6,16 +6,18 @@
|
||||
#include <gtk/gtk.h>
|
||||
-+#include <gtk/gtkcolorsel.h>
|
||||
|
||||
#include "nsColor.h"
|
||||
#include "nsColorPicker.h"
|
||||
@@ -4739,7 +4733,7 @@
|
||||
return color_component * 255 + 0.5;
|
||||
}
|
||||
|
||||
-@@ -54,38 +57,39 @@ GtkColorSelection* nsColorPicker::Widget
|
||||
+@@ -54,38 +56,39 @@ GtkColorSelection* nsColorPicker::Widget
|
||||
{
|
||||
return GTK_COLOR_SELECTION(gtk_color_selection_dialog_get_color_selection(
|
||||
GTK_COLOR_SELECTION_DIALOG(widget)));
|
||||
@@ -4785,7 +4779,7 @@
|
||||
NS_WARNING("mCallback is already set. Open called twice?");
|
||||
return NS_ERROR_FAILURE;
|
||||
}
|
||||
-@@ -113,16 +117,18 @@ NS_IMETHODIMP nsColorPicker::Open(nsICol
|
||||
+@@ -113,16 +116,18 @@ NS_IMETHODIMP nsColorPicker::Open(nsICol
|
||||
GtkWidget *color_chooser = gtk_color_selection_dialog_new(title);
|
||||
|
||||
if (parent_window) {
|
||||
@@ -4804,7 +4798,7 @@
|
||||
G_CALLBACK(OnColorChanged), this);
|
||||
#endif
|
||||
|
||||
-@@ -176,20 +182,38 @@ nsColorPicker::Update(GtkColorSelection*
|
||||
+@@ -176,20 +181,38 @@ nsColorPicker::Update(GtkColorSelection*
|
||||
}
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load diff
|
@ -1,23 +0,0 @@
|
|||
diff -Naur mozilla-central-f14898695ee0.orig/config/external/nss/crmf/moz.build mozilla-central-f14898695ee0/config/external/nss/crmf/moz.build
|
||||
--- mozilla-central-f14898695ee0.orig/config/external/nss/crmf/moz.build 2016-03-20 05:25:17.000000000 +0100
|
||||
+++ mozilla-central-f14898695ee0/config/external/nss/crmf/moz.build 2017-06-11 21:50:40.989355686 +0200
|
||||
@@ -8,7 +8,6 @@
|
||||
|
||||
if CONFIG['MOZ_SYSTEM_NSS']:
|
||||
OS_LIBS += [l for l in CONFIG['NSS_LIBS'] if l.startswith('-L')]
|
||||
- OS_LIBS += ['-lcrmf']
|
||||
else:
|
||||
USE_LIBS += [
|
||||
# The dependency on nss is not real, but is required to force the
|
||||
diff -Naur mozilla-central-f14898695ee0.orig/old-configure.in mozilla-central-f14898695ee0/old-configure.in
|
||||
--- mozilla-central-f14898695ee0.orig/old-configure.in 2016-03-20 05:25:17.000000000 +0100
|
||||
+++ mozilla-central-f14898695ee0/old-configure.in 2017-06-11 21:48:28.725284205 +0200
|
||||
@@ -2601,7 +2601,7 @@
|
||||
fi
|
||||
|
||||
if test -n "$MOZ_SYSTEM_NSS"; then
|
||||
- NSS_LIBS="$NSS_LIBS -lcrmf"
|
||||
+ NSS_LIBS="$NSS_LIBS"
|
||||
else
|
||||
NSS_CFLAGS="-I${DIST}/include/nss"
|
||||
fi
|
|
@ -1,18 +0,0 @@
|
|||
diff -Naur mozilla-central-f14898695ee0.orig/ipc/chromium/src/base/message_pump_libevent.cc mozilla-central-f14898695ee0/ipc/chromium/src/base/message_pump_libevent.cc
|
||||
--- mozilla-central-f14898695ee0.orig/ipc/chromium/src/base/message_pump_libevent.cc 2016-03-20 05:25:17.000000000 +0100
|
||||
+++ mozilla-central-f14898695ee0/ipc/chromium/src/base/message_pump_libevent.cc 2017-06-11 19:44:51.294979917 +0200
|
||||
@@ -18,11 +18,11 @@
|
||||
#include "event.h"
|
||||
#include "mozilla/UniquePtr.h"
|
||||
|
||||
-// This macro checks that the _EVENT_SIZEOF_* constants defined in
|
||||
+// This macro checks that the EVENT__SIZEOF_* constants defined in
|
||||
// ipc/chromiume/src/third_party/<platform>/event2/event-config.h are correct.
|
||||
#define CHECK_EVENT_SIZEOF(TYPE, type) \
|
||||
- static_assert(_EVENT_SIZEOF_##TYPE == sizeof(type), \
|
||||
- "bad _EVENT_SIZEOF_"#TYPE);
|
||||
+ static_assert(EVENT__SIZEOF_##TYPE == sizeof(type), \
|
||||
+ "bad EVENT__SIZEOF_"#TYPE);
|
||||
|
||||
CHECK_EVENT_SIZEOF(LONG, long);
|
||||
CHECK_EVENT_SIZEOF(LONG_LONG, long long);
|
|
@ -1,66 +0,0 @@
|
|||
# sh
|
||||
# Build configuration script for Arch Linux
|
||||
#
|
||||
# See http://www.mozilla.org/build/unix.html for build instructions.
|
||||
#
|
||||
|
||||
# ALARM options
|
||||
ac_add_options --disable-elf-hack
|
||||
|
||||
##############################
|
||||
# tweak the following according to your wishes
|
||||
##############################
|
||||
ac_add_options --disable-debug
|
||||
ac_add_options --enable-optimize
|
||||
ac_add_options --enable-strip
|
||||
#ac_add_options --enable-debug
|
||||
#ac_add_options --disable-optimize
|
||||
|
||||
##############################
|
||||
# I build on a 4-cpu machine ; comment out or adapt to your own case
|
||||
##############################
|
||||
mk_add_options MOZ_MAKE_FLAGS="-s -j4"
|
||||
|
||||
##############################
|
||||
# DO NOT MODIFY BELOW THIS LINE
|
||||
##############################
|
||||
ac_add_options --enable-application=bluegriffon
|
||||
# System directories
|
||||
mk_add_options MOZ_TOOLKIT_SEARCH=
|
||||
ac_add_options --prefix=/usr
|
||||
|
||||
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/bg
|
||||
mk_add_options MOZ_MEDIA_NAVIGATOR=1
|
||||
|
||||
# System libraries
|
||||
ac_add_options --with-system-nspr
|
||||
ac_add_options --with-system-nss
|
||||
ac_add_options --with-system-libevent
|
||||
ac_add_options --with-system-libvpx
|
||||
ac_add_options --enable-system-hunspell
|
||||
ac_add_options --enable-system-sqlite
|
||||
#ac_add_options --enable-system-ffi
|
||||
#ac_add_options --enable-system-cairo
|
||||
ac_add_options --enable-system-pixman
|
||||
ac_add_options --with-system-jpeg
|
||||
ac_add_options --with-system-png
|
||||
ac_add_options --with-system-zlib
|
||||
ac_add_options --with-system-bz2
|
||||
ac_add_options --with-pthreads
|
||||
|
||||
# Features
|
||||
ac_add_options --disable-necko-wifi
|
||||
ac_add_options --disable-tests
|
||||
ac_add_options --enable-default-toolkit=cairo-gtk3
|
||||
ac_add_options --disable-crashreporter
|
||||
ac_add_options --enable-safe-browsing
|
||||
ac_add_options --enable-gio
|
||||
ac_add_options --disable-gconf
|
||||
ac_add_options --disable-updater
|
||||
ac_add_options --disable-update-packaging
|
||||
ac_add_options --disable-webrtc
|
||||
ac_add_options --enable-startup-notification
|
||||
ac_add_options --enable-pulseaudio
|
||||
ac_add_options --disable-debug-symbols
|
||||
ac_add_options --enable-media-navigator
|
||||
|
Loading…
Reference in a new issue