mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/opendht to 2.1.10-2
This commit is contained in:
parent
66b98bb024
commit
da03fab473
2 changed files with 21 additions and 3 deletions
|
@ -8,7 +8,7 @@
|
|||
pkgname=opendht
|
||||
epoch=1
|
||||
pkgver=2.1.10
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc="C++14 Distributed Hash Table (DHT) implementation"
|
||||
arch=(x86_64)
|
||||
url="https://github.com/savoirfairelinux/opendht"
|
||||
|
@ -16,8 +16,14 @@ license=(GPL3)
|
|||
depends=(openssl gnutls nettle argon2 readline fmt http-parser jsoncpp libjsoncpp.so)
|
||||
makedepends=(msgpack-c cmake cython python-setuptools cppunit restinio)
|
||||
optdepends=('python: to use the Python bindings')
|
||||
source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
|
||||
sha256sums=('917e5f691199349d6884a68c26645840914c18e72b2e21d97817618ddc55fb81')
|
||||
source=(${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
|
||||
opendht-gcc11.patch)
|
||||
sha256sums=('917e5f691199349d6884a68c26645840914c18e72b2e21d97817618ddc55fb81'
|
||||
'4cd9ee51b3da01f00b0eb4367c48fb3a00df0840d5cf7beafaabcd149c8bd0fc')
|
||||
|
||||
prepare() {
|
||||
patch -d $pkgname-$pkgver -p1 < opendht-gcc11.patch # Fix build with GCC 11
|
||||
}
|
||||
|
||||
build() {
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && echo "target_link_libraries(opendht PRIVATE atomic)" >> ${pkgname}-${pkgver}/CMakeLists.txt
|
||||
|
|
12
community/opendht/opendht-gcc11.patch
Normal file
12
community/opendht/opendht-gcc11.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff --git a/tests/threadpooltester.cpp b/tests/threadpooltester.cpp
|
||||
index be948f9..4a5199f 100644
|
||||
--- a/tests/threadpooltester.cpp
|
||||
+++ b/tests/threadpooltester.cpp
|
||||
@@ -21,6 +21,7 @@
|
||||
|
||||
#include "opendht/thread_pool.h"
|
||||
#include <atomic>
|
||||
+#include <thread>
|
||||
|
||||
namespace test {
|
||||
CPPUNIT_TEST_SUITE_REGISTRATION(ThreadPoolTester);
|
Loading…
Reference in a new issue