community/python-debugpy to 1.6.1-1

This commit is contained in:
Kevin Mihelich 2022-07-06 23:02:12 +00:00
parent b00c8d2113
commit da354654ce
2 changed files with 19 additions and 3 deletions

View file

@ -6,7 +6,7 @@
_pipname=debugpy
pkgname=python-$_pipname
pkgver=1.6.0
pkgver=1.6.1
pkgrel=1
pkgdesc='An implementation of the Debug Adapter Protocol for Python'
arch=(x86_64)
@ -14,13 +14,17 @@ url='https://aka.ms/debugpy'
license=(EPL MIT)
depends=(python)
makedepends=(python-setuptools)
source=(https://github.com/microsoft/debugpy/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
sha256sums=('2312bda693be2e5581585349a4a1202d0071bc20cce9ac008cd84716e97f7a55')
source=(https://github.com/microsoft/debugpy/archive/v$pkgver/$pkgname-$pkgver.tar.gz
fix-build.patch)
sha256sums=('1c8cea3de71ff3cce5887a8d459579d6b6c4d455b3dbb70e02c7f2e463bf869e'
'a86e1e1a5a4d7a585c8185721863f563233b680c36fa35d65bfbff11abd519bc')
prepare() {
cd $_pipname-$pkgver
# remove precompiled libs
rm src/debugpy/_vendored/pydevd/pydevd_attach_to_process/*.{so,dll,dylib,exe,pdb}
patch -p1 -i ../fix-build.patch
}
build() {

View file

@ -0,0 +1,12 @@
diff --git a/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h b/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
index 6d39865e..04790698 100644
--- a/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
+++ b/src/debugpy/_vendored/pydevd/pydevd_attach_to_process/common/python.h
@@ -18,6 +18,7 @@
#define __PYTHON_H__
#include "../common/py_version.hpp"
+#include <cstdint>
#ifndef _WIN32
typedef unsigned int DWORD;