mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
Add core/linux-utilite-dt
This commit is contained in:
parent
a3e8c4e039
commit
da4966f2fc
5 changed files with 52226 additions and 0 deletions
|
@ -0,0 +1,74 @@
|
||||||
|
From 5d77ba2d26110c678b40fd723866a17d4036de12 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||||
|
Date: Tue, 18 Feb 2014 02:19:26 -0300
|
||||||
|
Subject: [PATCH 1/6] Bluetooth: allocate static minor for vhci
|
||||||
|
|
||||||
|
Commit bfacbb9 (Bluetooth: Use devname:vhci module alias for virtual HCI
|
||||||
|
driver) added the module alias to hci_vhci module so it's possible to
|
||||||
|
create the /dev/vhci node. However creating an alias without
|
||||||
|
specifying the minor doesn't allow us to create the node ahead,
|
||||||
|
triggerring module auto-load when it's first accessed.
|
||||||
|
|
||||||
|
Starting with depmod from kmod 16 we started to warn if there's a
|
||||||
|
devname alias without specifying the major and minor.
|
||||||
|
|
||||||
|
Let's do the same done for uhid, kvm, fuse and others, specifying a
|
||||||
|
fixed minor. In systems with systemd as the init the following will
|
||||||
|
happen: on early boot systemd will call "kmod static-nodes" to read
|
||||||
|
/lib/modules/$(uname -r)/modules.devname and then create the nodes. When
|
||||||
|
first accessed these "dead" nodes will trigger the module loading.
|
||||||
|
|
||||||
|
Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||||
|
Acked-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
||||||
|
Signed-off-by: Marcel Holtmann <marcel@holtmann.org>
|
||||||
|
---
|
||||||
|
Documentation/devices.txt | 1 +
|
||||||
|
drivers/bluetooth/hci_vhci.c | 3 ++-
|
||||||
|
include/linux/miscdevice.h | 1 +
|
||||||
|
3 files changed, 4 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Documentation/devices.txt b/Documentation/devices.txt
|
||||||
|
index 10378cc..04356f5 100644
|
||||||
|
--- a/Documentation/devices.txt
|
||||||
|
+++ b/Documentation/devices.txt
|
||||||
|
@@ -353,6 +353,7 @@ Your cooperation is appreciated.
|
||||||
|
133 = /dev/exttrp External device trap
|
||||||
|
134 = /dev/apm_bios Advanced Power Management BIOS
|
||||||
|
135 = /dev/rtc Real Time Clock
|
||||||
|
+ 137 = /dev/vhci Bluetooth virtual HCI driver
|
||||||
|
139 = /dev/openprom SPARC OpenBoot PROM
|
||||||
|
140 = /dev/relay8 Berkshire Products Octal relay card
|
||||||
|
141 = /dev/relay16 Berkshire Products ISO-16 relay card
|
||||||
|
diff --git a/drivers/bluetooth/hci_vhci.c b/drivers/bluetooth/hci_vhci.c
|
||||||
|
index 1ef6990..add1c6a 100644
|
||||||
|
--- a/drivers/bluetooth/hci_vhci.c
|
||||||
|
+++ b/drivers/bluetooth/hci_vhci.c
|
||||||
|
@@ -359,7 +359,7 @@ static const struct file_operations vhci_fops = {
|
||||||
|
static struct miscdevice vhci_miscdev= {
|
||||||
|
.name = "vhci",
|
||||||
|
.fops = &vhci_fops,
|
||||||
|
- .minor = MISC_DYNAMIC_MINOR,
|
||||||
|
+ .minor = VHCI_MINOR,
|
||||||
|
};
|
||||||
|
|
||||||
|
static int __init vhci_init(void)
|
||||||
|
@@ -385,3 +385,4 @@ MODULE_DESCRIPTION("Bluetooth virtual HCI driver ver " VERSION);
|
||||||
|
MODULE_VERSION(VERSION);
|
||||||
|
MODULE_LICENSE("GPL");
|
||||||
|
MODULE_ALIAS("devname:vhci");
|
||||||
|
+MODULE_ALIAS_MISCDEV(VHCI_MINOR);
|
||||||
|
diff --git a/include/linux/miscdevice.h b/include/linux/miscdevice.h
|
||||||
|
index 3737f72..7bb6148 100644
|
||||||
|
--- a/include/linux/miscdevice.h
|
||||||
|
+++ b/include/linux/miscdevice.h
|
||||||
|
@@ -23,6 +23,7 @@
|
||||||
|
#define TEMP_MINOR 131 /* Temperature Sensor */
|
||||||
|
#define RTC_MINOR 135
|
||||||
|
#define EFI_RTC_MINOR 136 /* EFI Time services */
|
||||||
|
+#define VHCI_MINOR 137
|
||||||
|
#define SUN_OPENPROM_MINOR 139
|
||||||
|
#define DMAPI_MINOR 140 /* DMAPI */
|
||||||
|
#define NVRAM_MINOR 144
|
||||||
|
--
|
||||||
|
1.9.1
|
||||||
|
|
271
core/linux-utilite-dt/PKGBUILD
Normal file
271
core/linux-utilite-dt/PKGBUILD
Normal file
|
@ -0,0 +1,271 @@
|
||||||
|
# Maintainer1: Dave Higham <pepedog@archlinuxarm.org>
|
||||||
|
# Maintainer2: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||||
|
|
||||||
|
# Cubox i.MX6 kernel and headers
|
||||||
|
# - note: any other kernel packages should include headers for that march
|
||||||
|
# - there will be no v7 kernel26 package, each march will be tagged individually
|
||||||
|
|
||||||
|
buildarch=4
|
||||||
|
|
||||||
|
pkgbase=linux-utilite-dt
|
||||||
|
pkgname=('linux-utilite-dt' 'linux-headers-utilite-dt')
|
||||||
|
# pkgname=linux-custom # Build kernel with a different name
|
||||||
|
_commit=9109d913ef44141f97e1237ed908fba4f43a4010
|
||||||
|
_srcname=linux-kernel-${_commit}
|
||||||
|
_kernelname=${pkgname#linux}
|
||||||
|
_basekernel=3.10
|
||||||
|
pkgver=${_basekernel}.70
|
||||||
|
pkgrel=1
|
||||||
|
arch=('armv7h')
|
||||||
|
url="http://www.kernel.org/"
|
||||||
|
license=('GPL2')
|
||||||
|
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'uboot-mkimage' 'git' 'lzop')
|
||||||
|
options=('!strip')
|
||||||
|
source=("https://github.com/pepedog/linux-kernel/archive/${_commit}.tar.gz"
|
||||||
|
'0001-Bluetooth-allocate-static-minor-for-vhci.patch'
|
||||||
|
'update-igb-eth.patch'
|
||||||
|
"config")
|
||||||
|
|
||||||
|
md5sums=('ed652cdd468428a122d73c6388714e44'
|
||||||
|
'1b276abe16d14e133f3f28d9c9e6bd68'
|
||||||
|
'2bbb1ada1dfd161ac4a7d43107e0732d'
|
||||||
|
'6cd72dbf43d2431a77177da04287b94f')
|
||||||
|
|
||||||
|
prepare() {
|
||||||
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
|
msg2 "Fix hci_vhci no minor warning"
|
||||||
|
patch -Np1 -i ${srcdir}/0001-Bluetooth-allocate-static-minor-for-vhci.patch
|
||||||
|
|
||||||
|
msg2 "Update Intel igb ethernet"
|
||||||
|
patch -Np1 -i ${srcdir}/update-igb-eth.patch
|
||||||
|
|
||||||
|
cat "${srcdir}/config" > ./.config
|
||||||
|
|
||||||
|
# add pkgrel to extraversion
|
||||||
|
sed -ri "s|^(EXTRAVERSION =)(.*)|\1 \2-${pkgrel}|" Makefile
|
||||||
|
|
||||||
|
# don't run depmod on 'make install'. We'll do this ourselves in packaging
|
||||||
|
sed -i '2iexit 0' scripts/depmod.sh
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "${srcdir}/${_srcname}"
|
||||||
|
LDFLAGS=""
|
||||||
|
|
||||||
|
# get kernel version
|
||||||
|
make prepare
|
||||||
|
|
||||||
|
# load configuration
|
||||||
|
# Configure the kernel. Replace the line below with one of your choice.
|
||||||
|
#make menuconfig # CLI menu for configuration
|
||||||
|
#make nconfig # new CLI menu for configuration
|
||||||
|
#make xconfig # X-based configuration
|
||||||
|
#make oldconfig # using old config from previous kernel version
|
||||||
|
# ... or manually edit .config
|
||||||
|
|
||||||
|
# Copy back our configuration (use with new kernel version)
|
||||||
|
#cp ./.config ../${_basekernel}.config
|
||||||
|
|
||||||
|
####################
|
||||||
|
# stop here
|
||||||
|
# this is useful to configure the kernel
|
||||||
|
#msg "Stopping build"
|
||||||
|
#return 1
|
||||||
|
####################
|
||||||
|
|
||||||
|
#yes "" | make config
|
||||||
|
|
||||||
|
# build!
|
||||||
|
make ${MAKEFLAGS} zImage modules imx6q-sbc-fx6m.dtb
|
||||||
|
|
||||||
|
}
|
||||||
|
|
||||||
|
package_linux-utilite-dt() {
|
||||||
|
pkgdesc="The Linux Kernel and modules - i.MX6 processors for all utilite-i"
|
||||||
|
depends=('coreutils' 'linux-firmware' 'module-init-tools>=3.16' 'mkinitcpio>=0.7')
|
||||||
|
optdepends=('crda: to set the correct wireless channels of your country')
|
||||||
|
provides=('kernel26' "linux=${pkgver}")
|
||||||
|
conflicts=('linux-trimslice' 'linux-omap' 'linux-utilite' 'linux-imx6-cubox-dt' 'linux-imx6-cubox')
|
||||||
|
backup=("etc/mkinitcpio.d/${pkgname}.preset")
|
||||||
|
install=${pkgname}.install
|
||||||
|
|
||||||
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
|
KARCH=arm
|
||||||
|
|
||||||
|
# get kernel version
|
||||||
|
_kernver="$(make kernelrelease)"
|
||||||
|
|
||||||
|
mkdir -p "${pkgdir}"/{lib/modules,lib/firmware,boot}
|
||||||
|
make INSTALL_MOD_PATH="${pkgdir}" modules_install
|
||||||
|
cp arch/$KARCH/boot/zImage "${pkgdir}/boot/zImage"
|
||||||
|
cp arch/$KARCH/boot/dts/*.dtb "${pkgdir}/boot"
|
||||||
|
|
||||||
|
# set correct depmod command for install
|
||||||
|
sed \
|
||||||
|
-e "s/KERNEL_NAME=.*/KERNEL_NAME=${_kernelname}/g" \
|
||||||
|
-e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/g" \
|
||||||
|
-i "${startdir}/${pkgname}.install"
|
||||||
|
|
||||||
|
# remove build and source links
|
||||||
|
rm -f "${pkgdir}"/lib/modules/${_kernver}/{source,build}
|
||||||
|
# remove the firmware
|
||||||
|
rm -rf "${pkgdir}/lib/firmware"
|
||||||
|
# gzip -9 all modules to save 100MB of space
|
||||||
|
find "${pkgdir}" -name '*.ko' |xargs -P 2 -n 1 gzip -9
|
||||||
|
# make room for external modules
|
||||||
|
ln -s "../extramodules-${_basekernel}-${_kernelname:-ARCH}" "${pkgdir}/lib/modules/${_kernver}/extramodules"
|
||||||
|
# add real version for building modules and running depmod from post_install/upgrade
|
||||||
|
mkdir -p "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}"
|
||||||
|
echo "${_kernver}" > "${pkgdir}/lib/modules/extramodules-${_basekernel}-${_kernelname:-ARCH}/version"
|
||||||
|
|
||||||
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
|
# Now we call depmod...
|
||||||
|
depmod -b "$pkgdir" -F System.map "$_kernver"
|
||||||
|
|
||||||
|
# move module tree /lib -> /usr/lib
|
||||||
|
mkdir -p "${pkgdir}/usr"
|
||||||
|
mv "$pkgdir/lib" "$pkgdir/usr"
|
||||||
|
}
|
||||||
|
|
||||||
|
package_linux-headers-utilite-dt() {
|
||||||
|
pkgdesc="Header files and scripts for building modules for linux kernel - i.MX6 utilite-i"
|
||||||
|
provides=("linux-headers=${pkgver}" "linux-headers-imx6-fsl=${pkgver}")
|
||||||
|
conflicts=('linux-headers-omap' 'linux-headers-trimslice')
|
||||||
|
|
||||||
|
install -dm755 "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||||
|
|
||||||
|
cd "${pkgdir}/usr/lib/modules/${_kernver}"
|
||||||
|
ln -sf ../../../src/linux-${_kernver} build
|
||||||
|
|
||||||
|
cd "${srcdir}/${_srcname}"
|
||||||
|
|
||||||
|
install -D -m644 Makefile \
|
||||||
|
"${pkgdir}/usr/src/linux-${_kernver}/Makefile"
|
||||||
|
install -D -m644 kernel/Makefile \
|
||||||
|
"${pkgdir}/usr/src/linux-${_kernver}/kernel/Makefile"
|
||||||
|
install -D -m644 .config \
|
||||||
|
"${pkgdir}/usr/src/linux-${_kernver}/.config"
|
||||||
|
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include"
|
||||||
|
|
||||||
|
for i in acpi asm-generic config crypto drm generated linux math-emu \
|
||||||
|
media net pcmcia scsi sound trace uapi video xen; do
|
||||||
|
cp -a include/${i} "${pkgdir}/usr/src/linux-${_kernver}/include/"
|
||||||
|
done
|
||||||
|
|
||||||
|
# copy arch includes for external modules
|
||||||
|
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH
|
||||||
|
cp -a arch/$KARCH/include ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/
|
||||||
|
mkdir -p ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-imx
|
||||||
|
cp -a arch/$KARCH/mach-imx/*.h ${pkgdir}/usr/src/linux-${_kernver}/arch/$KARCH/mach-imx/
|
||||||
|
|
||||||
|
# copy files necessary for later builds, like nvidia and vmware
|
||||||
|
cp Module.symvers "${pkgdir}/usr/src/linux-${_kernver}"
|
||||||
|
cp -a scripts "${pkgdir}/usr/src/linux-${_kernver}"
|
||||||
|
|
||||||
|
# fix permissions on scripts dir
|
||||||
|
chmod og-w -R "${pkgdir}/usr/src/linux-${_kernver}/scripts"
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/.tmp_versions"
|
||||||
|
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel"
|
||||||
|
|
||||||
|
cp arch/${KARCH}/Makefile "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/"
|
||||||
|
|
||||||
|
if [ "${CARCH}" = "i686" ]; then
|
||||||
|
cp arch/${KARCH}/Makefile_32.cpu "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/"
|
||||||
|
fi
|
||||||
|
|
||||||
|
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/src/linux-${_kernver}/arch/${KARCH}/kernel/"
|
||||||
|
|
||||||
|
# add headers for lirc package
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/video"
|
||||||
|
|
||||||
|
cp drivers/video/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/video/"
|
||||||
|
|
||||||
|
for i in cpia2 pwc; do
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
||||||
|
cp -a drivers/media/usb/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/${i}"
|
||||||
|
done
|
||||||
|
|
||||||
|
# add docbook makefile
|
||||||
|
install -D -m644 Documentation/DocBook/Makefile \
|
||||||
|
"${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"
|
||||||
|
|
||||||
|
# add dm headers
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
||||||
|
cp drivers/md/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/md"
|
||||||
|
|
||||||
|
# add inotify.h
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/linux"
|
||||||
|
cp include/linux/inotify.h "${pkgdir}/usr/src/linux-${_kernver}/include/linux/"
|
||||||
|
|
||||||
|
# add wireless headers
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
||||||
|
cp net/mac80211/*.h "${pkgdir}/usr/src/linux-${_kernver}/net/mac80211/"
|
||||||
|
|
||||||
|
# add dvb headers for external modules
|
||||||
|
# in reference to:
|
||||||
|
# http://bugs.archlinux.org/task/9912
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core"
|
||||||
|
cp drivers/media/dvb-core/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-core/"
|
||||||
|
# and...
|
||||||
|
# http://bugs.archlinux.org/task/11194
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
||||||
|
cp include/config/dvb/*.h "${pkgdir}/usr/src/linux-${_kernver}/include/config/dvb/"
|
||||||
|
|
||||||
|
# add dvb headers
|
||||||
|
# in reference to:
|
||||||
|
# http://bugs.archlinux.org/task/20402
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb"
|
||||||
|
cp drivers/media/usb/dvb-usb/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/usb/dvb-usb/"
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends"
|
||||||
|
cp drivers/media/dvb-frontends/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/dvb-frontends/"
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners"
|
||||||
|
cp drivers/media/tuners/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/tuners/"
|
||||||
|
|
||||||
|
# add xfs and shmem for aufs building
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs"
|
||||||
|
mkdir -p "${pkgdir}/usr/src/linux-${_kernver}/mm"
|
||||||
|
cp fs/xfs/xfs_sb.h "${pkgdir}/usr/src/linux-${_kernver}/fs/xfs/xfs_sb.h"
|
||||||
|
|
||||||
|
#make uapi headers, some of them are needed for vpu/ipu usage
|
||||||
|
mkdir -p "${srcdir}/headers"
|
||||||
|
make headers_install ARCH=$KARCH INSTALL_HDR_PATH="${srcdir}/headers"
|
||||||
|
|
||||||
|
|
||||||
|
# copy freescale specific headers to /usr/include/linux
|
||||||
|
mkdir -p "${pkgdir}/usr/include/linux"
|
||||||
|
for f in "$srcdir/headers/include/linux"/mxc*.h "$srcdir/headers/include/linux/ipu.h"; do
|
||||||
|
cp "$f" "${pkgdir}/usr/include/linux"
|
||||||
|
done
|
||||||
|
|
||||||
|
# copy in Kconfig files
|
||||||
|
for i in `find . -name "Kconfig*"`; do
|
||||||
|
mkdir -p "${pkgdir}"/usr/src/linux-${_kernver}/`echo ${i} | sed 's|/Kconfig.*||'`
|
||||||
|
cp ${i} "${pkgdir}/usr/src/linux-${_kernver}/${i}"
|
||||||
|
done
|
||||||
|
|
||||||
|
chown -R root.root "${pkgdir}/usr/src/linux-${_kernver}"
|
||||||
|
find "${pkgdir}/usr/src/linux-${_kernver}" -type d -exec chmod 755 {} \;
|
||||||
|
|
||||||
|
# strip scripts directory
|
||||||
|
find "${pkgdir}/usr/src/linux-${_kernver}/scripts" -type f -perm -u+w 2>/dev/null | while read binary ; do
|
||||||
|
case "$(file -bi "${binary}")" in
|
||||||
|
*application/x-sharedlib*) # Libraries (.so)
|
||||||
|
/usr/bin/strip ${STRIP_SHARED} "${binary}";;
|
||||||
|
*application/x-archive*) # Libraries (.a)
|
||||||
|
/usr/bin/strip ${STRIP_STATIC} "${binary}";;
|
||||||
|
*application/x-executable*) # Binaries
|
||||||
|
/usr/bin/strip ${STRIP_BINARIES} "${binary}";;
|
||||||
|
esac
|
||||||
|
done
|
||||||
|
|
||||||
|
# remove unneeded architectures
|
||||||
|
rm -rf "${pkgdir}"/usr/src/linux-${_kernver}/arch/{alpha,arm26,avr32,blackfin,cris,frv,h8300,ia64,m32r,m68k,m68knommu,mips,microblaze,mn10300,parisc,powerpc,ppc,s390,sh,sh64,sparc,sparc64,um,v850,x86,xtensa}
|
||||||
|
|
||||||
|
}
|
||||||
|
|
5806
core/linux-utilite-dt/config
Normal file
5806
core/linux-utilite-dt/config
Normal file
File diff suppressed because it is too large
Load diff
37
core/linux-utilite-dt/linux-utilite-dt.install
Normal file
37
core/linux-utilite-dt/linux-utilite-dt.install
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
# arg 1: the new package version
|
||||||
|
# arg 2: the old package version
|
||||||
|
|
||||||
|
KERNEL_NAME=-utilite-dt
|
||||||
|
KERNEL_VERSION=3.10.70-1-ARCH
|
||||||
|
|
||||||
|
post_install () {
|
||||||
|
# updating module dependencies
|
||||||
|
echo ">>> Updating module dependencies. Please wait ..."
|
||||||
|
depmod ${KERNEL_VERSION}
|
||||||
|
|
||||||
|
echo "NOTE: You may need to copy /boot/zImage to the first partition"
|
||||||
|
echo " of your SD card."
|
||||||
|
echo "NOTE: You will need latest u-boot reset to default env"
|
||||||
|
echo " and correct zImage/dtb point to. See-"
|
||||||
|
echo "http://www.compulab.co.il/utilite-computer/wiki/index.php/Utilite_U-Boot_Update"
|
||||||
|
}
|
||||||
|
|
||||||
|
post_upgrade() {
|
||||||
|
if grep "^[^#]*[[:space:]]/boot" etc/fstab 2>&1 >/dev/null; then
|
||||||
|
if ! grep "[[:space:]]/boot" etc/mtab 2>&1 >/dev/null; then
|
||||||
|
echo "WARNING: /boot appears to be a seperate partition but is not mounted"
|
||||||
|
echo " This is most likely not what you want. Please mount your /boot"
|
||||||
|
echo " partition and reinstall the kernel unless you are sure this is OK"
|
||||||
|
fi
|
||||||
|
fi
|
||||||
|
|
||||||
|
# updating module dependencies
|
||||||
|
echo ">>> Updating module dependencies. Please wait ..."
|
||||||
|
depmod ${KERNEL_VERSION}
|
||||||
|
|
||||||
|
echo "NOTE: You may need to copy /boot/zImage to the first partition"
|
||||||
|
echo " of your SD card."
|
||||||
|
echo "NOTE: You will need latest u-boot reset to default env"
|
||||||
|
echo " and correct zImage/dtb point to. See-"
|
||||||
|
echo "http://www.compulab.co.il/utilite-computer/wiki/index.php/Utilite_U-Boot_Update"
|
||||||
|
}
|
46038
core/linux-utilite-dt/update-igb-eth.patch
Normal file
46038
core/linux-utilite-dt/update-igb-eth.patch
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue