extra/x265 to 1.5-1

This commit is contained in:
Kevin Mihelich 2015-02-12 13:26:25 +00:00
parent aab8b46ebc
commit da5b2310b2
2 changed files with 10 additions and 10 deletions

View file

@ -6,7 +6,7 @@
# - patch to attempt fixing ARM hackery by bandwagoning developers
pkgname=x265
pkgver=1.4
pkgver=1.5
pkgrel=1
pkgdesc='Open Source H265/HEVC video encoder'
arch=('i686' 'x86_64')
@ -16,8 +16,8 @@ makedepends=('yasm' 'cmake')
url='https://bitbucket.org/multicoreware/x265'
source=($url/get/$pkgver.tar.bz2
arm.patch)
md5sums=('b37bf7bd05b198c9dd9155d60e1f7100'
'db9fa24ac05001aa88d0b1284ec3b53a')
md5sums=('fcb81f5ff12669ff0c0657568cee36b9'
'9c773543b7a1f2b54f02f588725a8201')
prepare() {
cd multicoreware-x265-*

View file

@ -1,7 +1,7 @@
diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
--- a/source/CMakeLists.txt 2014-08-21 15:49:02.000000000 -0600
+++ b/source/CMakeLists.txt 2014-09-10 06:11:00.901101403 -0600
@@ -44,10 +44,18 @@
--- a/source/CMakeLists.txt 2015-02-10 14:15:13.000000000 -0700
+++ b/source/CMakeLists.txt 2015-02-12 06:25:01.334927114 -0700
@@ -46,10 +46,18 @@
set(X64 1)
add_definitions(-DX86_64=1)
endif()
@ -23,7 +23,7 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
else()
message(STATUS "CMAKE_SYSTEM_PROCESSOR value `${CMAKE_SYSTEM_PROCESSOR}` is unknown")
message(STATUS "Please add this value near ${CMAKE_CURRENT_LIST_FILE}:${CMAKE_CURRENT_LIST_LINE}")
@@ -124,8 +132,8 @@
@@ -133,8 +141,8 @@
if(X86 AND NOT X64)
add_definitions(-march=i686)
endif()
@ -33,10 +33,10 @@ diff -urN a/source/CMakeLists.txt b/source/CMakeLists.txt
+ add_definitions(-fPIC)
endif()
check_cxx_compiler_flag(-Wno-narrowing CC_HAS_NO_NARROWING)
check_cxx_compiler_flag(-ffast-math CC_HAS_FAST_MATH)
check_cxx_compiler_flag(-Wno-array-bounds CC_HAS_NO_ARRAY_BOUNDS)
diff -urN a/source/common/cpu.cpp b/source/common/cpu.cpp
--- a/source/common/cpu.cpp 2014-08-21 15:49:02.000000000 -0600
+++ b/source/common/cpu.cpp 2014-09-10 06:07:46.881719234 -0600
--- a/source/common/cpu.cpp 2015-02-10 14:15:13.000000000 -0700
+++ b/source/common/cpu.cpp 2015-02-12 06:25:01.334927114 -0700
@@ -37,7 +37,7 @@
#include <machine/cpu.h>
#endif