core/linux-armv7 to 5.10.14-1

This commit is contained in:
Kevin Mihelich 2021-02-07 20:27:04 +00:00
parent 90dc5258d0
commit da646d4e5b
12 changed files with 77 additions and 143 deletions

View file

@ -1,4 +1,4 @@
From 3e52f35e1ff20c01bd090fa895f1d00bfcb6249b Mon Sep 17 00:00:00 2001
From 4f3c60e09108eed4a2b25255b94b76261d21d68a Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/10] ARM: atags: add support for Marvell's u-boot

View file

@ -1,4 +1,4 @@
From fe1c9c38b42c93474a311a30e3fbb33e82e00d44 Mon Sep 17 00:00:00 2001
From 7a39882a2608e6fb9892ef88a31219d9d6e7886f Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/10] ARM: atags/fdt: retrieve MAC addresses from Marvell
@ -17,10 +17,10 @@ Signed-off-by: Willy Tarreau <w@xxxxxx>
1 file changed, 6 insertions(+)
diff --git a/arch/arm/boot/compressed/atags_to_fdt.c b/arch/arm/boot/compressed/atags_to_fdt.c
index 8452753efebe..3393a10741bb 100644
index 31927d2fe297..2bbe846708ea 100644
--- a/arch/arm/boot/compressed/atags_to_fdt.c
+++ b/arch/arm/boot/compressed/atags_to_fdt.c
@@ -204,6 +204,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
@@ -205,6 +205,12 @@ int atags_to_fdt(void *atag_list, void *fdt, int total_space)
hex_str(serno, atag->u.serialnr.high);
hex_str(serno+8, atag->u.serialnr.low);
setprop_string(fdt, "/", "serial-number", serno);

View file

@ -1,4 +1,4 @@
From 089af68bc9341fb76f24f3c8f407899d03a0e7e0 Mon Sep 17 00:00:00 2001
From 0012a712d33f79100e155ceb5e985afac264a85c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/10] SMILE Plug device tree file

View file

@ -1,4 +1,4 @@
From abc10a9d289c94ea0748a4bd1b5e279530b11c51 Mon Sep 17 00:00:00 2001
From 68fb4615599903edff61d1e81a6502c6d164c876 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/10] fix mvsdio eMMC timing

View file

@ -1,4 +1,4 @@
From 16895c788ef24cd1446858a67f5633a133725d17 Mon Sep 17 00:00:00 2001
From 5162a5156a75be1d5d91d4ba095cea10af528d76 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/10] net/smsc95xx: Allow mac address to be set as a

View file

@ -1,4 +1,4 @@
From b27760899bb2e398ad7e22b11356bebee7a9c75b Mon Sep 17 00:00:00 2001
From af5148212b0ce866dd19b08ba90b2de1626f5558 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/10] set default cubietruck led triggers

View file

@ -1,4 +1,4 @@
From 9657970d18ff079ea99ad875fb47539dbc187cbe Mon Sep 17 00:00:00 2001
From 2326eea823a657ffc3d43a87b592422583bad325 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/10] exynos4412-odroid: set higher minimum buck2 regulator

View file

@ -1,4 +1,4 @@
From 8f63830a3f3324486e32772f970d5ba7ce764b15 Mon Sep 17 00:00:00 2001
From 5a05d83571952d83abccb076a9aef94f4e620811 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/10] ARM: dove: enable ethernet on D3Plug

View file

@ -1,4 +1,4 @@
From d46a89436f0f2985fe2b4dbf3bb99c8c0bfc3b86 Mon Sep 17 00:00:00 2001
From d147ebeae31141427142b333626424666a300084 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 11 Aug 2019 12:34:17 -0600
Subject: [PATCH 09/10] USB Armory MkII support

View file

@ -1,118 +0,0 @@
From 202f8d822b383aca1c33f62f0b91e3e1c8167dec Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 1 Feb 2021 17:09:18 -0700
Subject: [PATCH 10/10] Revert "SUNRPC: Handle TCP socket sends with
kernel_sendpage() again"
This reverts commit 00ee972739fb2526d3936f1e7ccfc8c91d250c60.
---
net/sunrpc/svcsock.c | 86 +-------------------------------------------
1 file changed, 1 insertion(+), 85 deletions(-)
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
index 4404c491eb38..c2752e2b9ce3 100644
--- a/net/sunrpc/svcsock.c
+++ b/net/sunrpc/svcsock.c
@@ -1062,90 +1062,6 @@ static int svc_tcp_recvfrom(struct svc_rqst *rqstp)
return 0; /* record not complete */
}
-static int svc_tcp_send_kvec(struct socket *sock, const struct kvec *vec,
- int flags)
-{
- return kernel_sendpage(sock, virt_to_page(vec->iov_base),
- offset_in_page(vec->iov_base),
- vec->iov_len, flags);
-}
-
-/*
- * kernel_sendpage() is used exclusively to reduce the number of
- * copy operations in this path. Therefore the caller must ensure
- * that the pages backing @xdr are unchanging.
- *
- * In addition, the logic assumes that * .bv_len is never larger
- * than PAGE_SIZE.
- */
-static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
- struct xdr_buf *xdr, rpc_fraghdr marker,
- unsigned int *sentp)
-{
- const struct kvec *head = xdr->head;
- const struct kvec *tail = xdr->tail;
- struct kvec rm = {
- .iov_base = &marker,
- .iov_len = sizeof(marker),
- };
- int flags, ret;
-
- *sentp = 0;
- xdr_alloc_bvec(xdr, GFP_KERNEL);
-
- msg->msg_flags = MSG_MORE;
- ret = kernel_sendmsg(sock, msg, &rm, 1, rm.iov_len);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != rm.iov_len)
- return -EAGAIN;
-
- flags = head->iov_len < xdr->len ? MSG_MORE | MSG_SENDPAGE_NOTLAST : 0;
- ret = svc_tcp_send_kvec(sock, head, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != head->iov_len)
- goto out;
-
- if (xdr->page_len) {
- unsigned int offset, len, remaining;
- struct bio_vec *bvec;
-
- bvec = xdr->bvec;
- offset = xdr->page_base;
- remaining = xdr->page_len;
- flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
- while (remaining > 0) {
- if (remaining <= PAGE_SIZE && tail->iov_len == 0)
- flags = 0;
- len = min(remaining, bvec->bv_len);
- ret = kernel_sendpage(sock, bvec->bv_page,
- bvec->bv_offset + offset,
- len, flags);
- if (ret < 0)
- return ret;
- *sentp += ret;
- if (ret != len)
- goto out;
- remaining -= len;
- offset = 0;
- bvec++;
- }
- }
-
- if (tail->iov_len) {
- ret = svc_tcp_send_kvec(sock, tail, 0);
- if (ret < 0)
- return ret;
- *sentp += ret;
- }
-
-out:
- return 0;
-}
-
/**
* svc_tcp_sendto - Send out a reply on a TCP socket
* @rqstp: completed svc_rqst
@@ -1173,7 +1089,7 @@ static int svc_tcp_sendto(struct svc_rqst *rqstp)
mutex_lock(&xprt->xpt_mutex);
if (svc_xprt_is_dead(xprt))
goto out_notconn;
- err = svc_tcp_sendmsg(svsk->sk_sock, &msg, xdr, marker, &sent);
+ err = xprt_sock_sendmsg(svsk->sk_sock, &msg, xdr, 0, marker, &sent);
xdr_free_bvec(xdr);
trace_svcsock_tcp_send(xprt, err < 0 ? err : sent);
if (err < 0 || sent != (xdr->len + sizeof(marker)))
--
2.30.0

View file

@ -0,0 +1,52 @@
From 1fb064aedc2dc74e55e30b0737196f28b19d50ce Mon Sep 17 00:00:00 2001
From: Chuck Lever <chuck.lever@oracle.com>
Date: Sun, 31 Jan 2021 16:16:23 -0500
Subject: [PATCH 10/10] SUNRPC: Fix NFS READs that start at non-page-aligned
offsets
Anj Duvnjak reports that the Kodi.tv NFS client is not able to read
video files from a v5.10.11 Linux NFS server.
The new sendpage-based TCP sendto logic was not attentive to non-
zero page_base values. nfsd_splice_read() sets that field when a
READ payload starts in the middle of a page.
The Linux NFS client rarely emits an NFS READ that is not page-
aligned. All of my testing so far has been with Linux clients, so I
missed this one.
Reported-by: A. Duvnjak <avian@extremenerds.net>
BugLink: https://bugzilla.kernel.org/show_bug.cgi?id=211471
Fixes: 4a85a6a3320b ("SUNRPC: Handle TCP socket sends with kernel_sendpage() again")
Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Tested-by: A. Duvnjak <avian@extremenerds.net>
---
net/sunrpc/svcsock.c | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/net/sunrpc/svcsock.c b/net/sunrpc/svcsock.c
index 4404c491eb38..fa7b7ae2c2c5 100644
--- a/net/sunrpc/svcsock.c
+++ b/net/sunrpc/svcsock.c
@@ -1113,14 +1113,15 @@ static int svc_tcp_sendmsg(struct socket *sock, struct msghdr *msg,
unsigned int offset, len, remaining;
struct bio_vec *bvec;
- bvec = xdr->bvec;
- offset = xdr->page_base;
+ bvec = xdr->bvec + (xdr->page_base >> PAGE_SHIFT);
+ offset = offset_in_page(xdr->page_base);
remaining = xdr->page_len;
flags = MSG_MORE | MSG_SENDPAGE_NOTLAST;
while (remaining > 0) {
if (remaining <= PAGE_SIZE && tail->iov_len == 0)
flags = 0;
- len = min(remaining, bvec->bv_len);
+
+ len = min(remaining, bvec->bv_len - offset);
ret = kernel_sendpage(sock, bvec->bv_page,
bvec->bv_offset + offset,
len, flags);
--
2.30.0

View file

@ -7,7 +7,7 @@ pkgbase=linux-armv7
_srcname=linux-5.10
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=5.10.13
pkgver=5.10.14
pkgrel=1
rcnver=5.10.8
rcnrel=armv7-x20
@ -28,7 +28,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0008-ARM-dove-enable-ethernet-on-D3Plug.patch'
'0009-USB-Armory-MkII-support.patch'
'0010-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch'
'0010-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -37,18 +37,18 @@ source=("http://www.kernel.org/pub/linux/kernel/v5.x/${_srcname}.tar.xz"
'60-linux.hook'
'90-linux.hook')
md5sums=('753adc474bf799d569dec4f165ed92c3'
'4a34221501c7ee90ba275743bc552488'
'd928049c6149ed507afbb72c90cb2dc2'
'1d57de70e483defb128592d86073153f'
'c5748330f9ad0ec87b1a8bbf52ae28f9'
'19864ac14c43183010d098c702457e9e'
'ef5cda4fb5682c9f70f77bea745faf68'
'f46210ac2c620ae8c398101727fe86e2'
'70f2dbc3164cd32c4542b3ad9e248ae4'
'7e5b639ee99b2d5c38a5c88b3d27aac9'
'34931d6f44e3e2e02819bf9e31f05da9'
'f2c4495e51cac4d311e7e1831b7b0bf8'
'a96ac3be6fc056449e128704b0083064'
'3acea91020294c611a303039608fafeb'
'e2981280bf9cbaba21f9d4ed0d097216'
'0029b87e303c57a92262b1e3b5950bc0'
'6ae17755c0240fd0a8fcd51dec18b441'
'228eaad2fe43ff44a26b4520f5588357'
'048e3b317b6c8d11af9204719abe9def'
'e7b91008b5a797848d5fef8e26be63f4'
'4d33accb3c07ecab87a3e40de233d2e9'
'9c1635f7d38f468b29c3df606800d716'
'2e98803f460936e8abc38ad97054e312'
'8cb99f1f47234e5438fb5fc7fa772618'
'f3d97cf32174dc0da2bd5830883a809b'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -76,7 +76,7 @@ prepare() {
git apply ../0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0008-ARM-dove-enable-ethernet-on-D3Plug.patch
git apply ../0009-USB-Armory-MkII-support.patch
git apply ../0010-Revert-SUNRPC-Handle-TCP-socket-sends-with-kernel_se.patch
git apply ../0010-SUNRPC-Fix-NFS-READs-that-start-at-non-page-aligned-.patch
cat "${srcdir}/config" > ./.config