mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/nodejs: fix
This commit is contained in:
parent
3bc0f73a37
commit
da9bdec549
2 changed files with 20 additions and 23 deletions
|
@ -26,7 +26,7 @@ optdepends=('npm: nodejs package manager')
|
|||
source=("nodejs-$pkgver.tar.gz::https://github.com/nodejs/node/archive/v$pkgver.tar.gz"
|
||||
'atomic.patch')
|
||||
sha512sums=('75504a775848e03a795e162c38315289eada16bfc8fbaa4cddccbc9e3c83b2dfd5227bce29348279b00982ee566c4e0cb1a828add8a6cea3c571e93aaa162f1f'
|
||||
'b1dd60c8f594fc07d66c0c77ea682555064cfd66a778e02d94b39be471ffc39ed9e57059e2f9e4dfc8434f0bd4cb958bce2e186e249aeeb179b854add5b4d9d6')
|
||||
'a547a4c9db4ab7609d759bf1d0f1c1809389ce3d3288234470e427438db71551e246791eafab5456f57682989c360d0c78407003ceb1f2f073613ab8c37646d3')
|
||||
|
||||
prepare() {
|
||||
cd node-$pkgver
|
||||
|
@ -41,9 +41,9 @@ prepare() {
|
|||
-e "s_'python'_'python2'_" -i {} \;
|
||||
find test/ -type f -exec sed 's_python _python2 _' -i {} \;
|
||||
|
||||
# if [[ $CARCH == "armv6h" ]]; then
|
||||
# patch -p0 -i ../atomic.patch
|
||||
# fi
|
||||
if [[ $CARCH == "armv6h" ]]; then
|
||||
patch -p0 -i ../atomic.patch
|
||||
fi
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
--- node.gyp.orig 2018-08-16 12:34:32.110341767 -0600
|
||||
+++ node.gyp 2018-08-16 12:35:47.914941800 -0600
|
||||
@@ -320,6 +320,12 @@
|
||||
'<(SHARED_INTERMEDIATE_DIR)' # for node_natives.h
|
||||
--- node.gyp.orig 2019-08-24 10:05:57.160565594 -0600
|
||||
+++ node.gyp 2019-08-24 10:07:00.240470669 -0600
|
||||
@@ -311,6 +311,12 @@
|
||||
'deps/v8/include'
|
||||
],
|
||||
|
||||
+ 'link_settings': {
|
||||
|
@ -11,19 +11,16 @@
|
|||
+ },
|
||||
+
|
||||
'sources': [
|
||||
'src/async_wrap.cc',
|
||||
'src/bootstrapper.cc',
|
||||
--- deps/v8/gypfiles/v8.gyp.orig 2018-10-29 07:54:38.292831964 -0600
|
||||
+++ deps/v8/gypfiles/v8.gyp 2018-10-29 07:56:38.192570653 -0600
|
||||
@@ -483,6 +483,11 @@
|
||||
'<(DEPTH)',
|
||||
'<(SHARED_INTERMEDIATE_DIR)'
|
||||
'src/node_main.cc'
|
||||
],
|
||||
+ 'link_settings': {
|
||||
+ 'libraries': [
|
||||
+ '-latomic',
|
||||
+ ],
|
||||
+ },
|
||||
'sources': [
|
||||
'<@(inspector_all_sources)',
|
||||
'../include//v8-inspector-protocol.h',
|
||||
--- tools/v8_gypfiles/v8.gyp.orig 2019-08-24 12:42:33.041596717 -0600
|
||||
+++ tools/v8_gypfiles/v8.gyp 2019-08-24 13:02:49.504187934 -0600
|
||||
@@ -858,7 +858,7 @@
|
||||
}],
|
||||
# Platforms that don't have Compare-And-Swap (CAS) support need to link atomic library
|
||||
# to implement atomic memory access
|
||||
- ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "ppc64", "s390x"]', {
|
||||
+ ['v8_current_cpu in ["mips", "mipsel", "mips64", "mips64el", "ppc", "ppc64", "s390x", "arm"]', {
|
||||
'link_settings': {
|
||||
'libraries': ['-latomic', ],
|
||||
},
|
||||
|
|
Loading…
Reference in a new issue