mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/webkit2gtk-4.1 to 2.40.1-2
This commit is contained in:
parent
f1b6a3ae81
commit
daa9f3fcc3
2 changed files with 47 additions and 5 deletions
36
extra/webkit2gtk-4.1/0001-Fix-build-of-SourceBrush.cpp.patch
Normal file
36
extra/webkit2gtk-4.1/0001-Fix-build-of-SourceBrush.cpp.patch
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Michael Catanzaro <mcatanzaro@redhat.com>
|
||||||
|
Date: Fri, 31 Mar 2023 12:24:09 -0700
|
||||||
|
Subject: [PATCH] Fix build of SourceBrush.cpp
|
||||||
|
https://bugs.webkit.org/show_bug.cgi?id=254821
|
||||||
|
|
||||||
|
Unreviewed build fix.
|
||||||
|
|
||||||
|
* Source/WebCore/platform/graphics/SourceBrush.cpp:
|
||||||
|
(WebCore::SourceBrush::setGradient):
|
||||||
|
(WebCore::SourceBrush::setPattern):
|
||||||
|
|
||||||
|
Canonical link: https://commits.webkit.org/262434@main
|
||||||
|
---
|
||||||
|
Source/WebCore/platform/graphics/SourceBrush.cpp | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Source/WebCore/platform/graphics/SourceBrush.cpp b/Source/WebCore/platform/graphics/SourceBrush.cpp
|
||||||
|
index f4d299be82f1..4bf4d6842aea 100644
|
||||||
|
--- a/Source/WebCore/platform/graphics/SourceBrush.cpp
|
||||||
|
+++ b/Source/WebCore/platform/graphics/SourceBrush.cpp
|
||||||
|
@@ -65,12 +65,12 @@ Pattern* SourceBrush::pattern() const
|
||||||
|
|
||||||
|
void SourceBrush::setGradient(Ref<Gradient>&& gradient, const AffineTransform& spaceTransform)
|
||||||
|
{
|
||||||
|
- m_brush = { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
|
||||||
|
+ m_brush = Brush { Brush::LogicalGradient { WTFMove(gradient), spaceTransform } };
|
||||||
|
}
|
||||||
|
|
||||||
|
void SourceBrush::setPattern(Ref<Pattern>&& pattern)
|
||||||
|
{
|
||||||
|
- m_brush = { Brush::Variant { std::in_place_type<Ref<Pattern>>, WTFMove(pattern) } };
|
||||||
|
+ m_brush = Brush { Brush::Variant { std::in_place_type<Ref<Pattern>>, WTFMove(pattern) } };
|
||||||
|
}
|
||||||
|
|
||||||
|
WTF::TextStream& operator<<(TextStream& ts, const SourceBrush& brush)
|
|
@ -12,7 +12,7 @@ pkgname=(
|
||||||
webkit2gtk-4.1-docs
|
webkit2gtk-4.1-docs
|
||||||
)
|
)
|
||||||
pkgver=2.40.1
|
pkgver=2.40.1
|
||||||
pkgrel=1
|
pkgrel=2
|
||||||
pkgdesc="Web content engine for GTK"
|
pkgdesc="Web content engine for GTK"
|
||||||
url="https://webkitgtk.org"
|
url="https://webkitgtk.org"
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
|
@ -41,10 +41,8 @@ depends=(
|
||||||
libgcrypt
|
libgcrypt
|
||||||
libgl
|
libgl
|
||||||
libgles
|
libgles
|
||||||
libice
|
|
||||||
libjpeg
|
libjpeg
|
||||||
libmanette
|
libmanette
|
||||||
libnotify
|
|
||||||
libpng
|
libpng
|
||||||
libseccomp
|
libseccomp
|
||||||
libsecret
|
libsecret
|
||||||
|
@ -55,7 +53,6 @@ depends=(
|
||||||
libwpe
|
libwpe
|
||||||
libx11
|
libx11
|
||||||
libxcomposite
|
libxcomposite
|
||||||
libxext
|
|
||||||
libxml2
|
libxml2
|
||||||
libxslt
|
libxslt
|
||||||
libxt
|
libxt
|
||||||
|
@ -83,9 +80,14 @@ makedepends=(
|
||||||
)
|
)
|
||||||
source=(
|
source=(
|
||||||
$url/releases/webkitgtk-$pkgver.tar.xz{,.asc}
|
$url/releases/webkitgtk-$pkgver.tar.xz{,.asc}
|
||||||
|
0001-Fix-build-of-SourceBrush.cpp.patch
|
||||||
)
|
)
|
||||||
sha256sums=('64e526984f8cd2161ef03ae949af99c002ff333d615e6386b460164a3c1b7ef6'
|
sha256sums=('64e526984f8cd2161ef03ae949af99c002ff333d615e6386b460164a3c1b7ef6'
|
||||||
'SKIP')
|
'SKIP'
|
||||||
|
'ad3191d494647a33f48fa2b0eb2f0ed9035571a01909d009764960029cac4092')
|
||||||
|
b2sums=('b50c983eafdb215e62e1509873691bc3f932c8b5daf0ceeaefc041d3bc6c5ff804f25af5f761837a3f37df07c1c598f5984e40b116e70a3523d508d13594dc4d'
|
||||||
|
'SKIP'
|
||||||
|
'aa01aacc2f58f0634370472a001ddf01f84ce2d603ed5352138e63b786ec4e6a99429eb0d00d7fd893ac9c46b90fd5f0ed49c916cd124cc7d78e6dbb6a1a9386')
|
||||||
validpgpkeys=(
|
validpgpkeys=(
|
||||||
'D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
|
'D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
|
||||||
'5AA3BC334FD7E3369E7C77B291C559DBE4C9123B' # Adrián Pérez de Castro <aperez@igalia.com>
|
'5AA3BC334FD7E3369E7C77B291C559DBE4C9123B' # Adrián Pérez de Castro <aperez@igalia.com>
|
||||||
|
@ -93,6 +95,10 @@ validpgpkeys=(
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd webkitgtk-$pkgver
|
cd webkitgtk-$pkgver
|
||||||
|
|
||||||
|
# Fix build with GCC 13
|
||||||
|
# Backport of https://github.com/WebKit/WebKit/commit/93920b55f52ff8b883296f4845269e2ed746acb3
|
||||||
|
patch -Np1 -i ../0001-Fix-build-of-SourceBrush.cpp.patch
|
||||||
}
|
}
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
|
|
Loading…
Reference in a new issue