core/linux-armv7 to 3.19.1-4

This commit is contained in:
Kevin Mihelich 2015-03-18 16:39:40 +00:00
parent 3c48cfd85c
commit daaf5fa82a
9 changed files with 83 additions and 31 deletions

View file

@ -1,7 +1,7 @@
From 452aada034637ea0829eab5b1bb1a00ea477c9ce Mon Sep 17 00:00:00 2001
From 52ed801f4424f62bca855e69db4f8a81f36795fd Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/6] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/7] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 979ff40..d1d0c19 100644
};
--
2.3.1
2.3.3

View file

@ -1,7 +1,7 @@
From 66194a57f0a746b701c019b3a232e01eccf1044a Mon Sep 17 00:00:00 2001
From c1d23a74b0d522109d9a4563a80b40ea6028856e Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/6] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/7] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 9448aa0..ac7b6ae 100644
}
--
2.3.1
2.3.3

View file

@ -1,7 +1,7 @@
From 376956621e1e1dcb506e88120b5dc660a20c1731 Mon Sep 17 00:00:00 2001
From 64c2e16c0fafb400500d4288127d79445eb3ec3d Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/6] SMILE Plug device tree file
Subject: [PATCH 3/7] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -205,5 +205,5 @@ index 0000000..d01308a
+ };
+};
--
2.3.1
2.3.3

View file

@ -1,7 +1,7 @@
From 4842967cb917e86247f9e8e356aa6ed31eb936fe Mon Sep 17 00:00:00 2001
From 35ea29a715cd232916e2f33d7122124cc9a67d96 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/6] fix mvsdio eMMC timing
Subject: [PATCH 4/7] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index 4f8618f..ab95bb7 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.3.1
2.3.3

View file

@ -1,7 +1,7 @@
From b713e58287bab6af8420ab25da220f416f6c998e Mon Sep 17 00:00:00 2001
From 08da1d012d2140f1166b8891f86adc1f9030f382 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/6] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/7] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
@ -91,5 +91,5 @@ index 26423ad..e29a323 100644
if (smsc95xx_read_eeprom(dev, EEPROM_MAC_OFFSET, ETH_ALEN,
dev->net->dev_addr) == 0) {
--
2.3.1
2.3.3

View file

@ -1,7 +1,7 @@
From f44751f3a56d34d317e15d400527c8e92329b24f Mon Sep 17 00:00:00 2001
From 749ce3ae8c90a2b13a8e61eef8a1183853e8b360 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 7 Mar 2015 16:51:15 -0700
Subject: [PATCH 6/6] USB armory support
Subject: [PATCH 6/7] USB armory support
---
arch/arm/boot/dts/Makefile | 1 +
@ -225,5 +225,5 @@ index 0000000..ff411be
+ };
+};
--
2.3.1
2.3.3

View file

@ -0,0 +1,49 @@
From 26fdf88e26e329d4b38eb51dbee598333a1dff23 Mon Sep 17 00:00:00 2001
From: dobatog <dobatog@gmail.com>
Date: Thu, 26 Feb 2015 12:32:27 +0100
Subject: [PATCH 7/7] ARM: TLV320AIC23 SoC Audio Codec: Fix errors reported
related to input routing signals.
The following patch, based on stable v3.19, corrects the errors that are reported in the boot trace in reference to the Input Signals of the audio codec TLV320AIC23:
tlv320aic23-codec 1-001a: Control not supported for path LLINEIN -> [NULL] -> Line Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for LLINEIN --> NULL --> Line Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route LLINEIN -> NULL -> Line Input
tlv320aic23-codec 1-001a: Control not supported for path RLINEIN -> [NULL] -> Line Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for RLINEIN --> NULL --> Line Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route RLINEIN -> NULL -> Line Input
tlv320aic23-codec 1-001a: Control not supported for path MICIN -> [NULL] -> Mic Input
tlv320aic23-codec 1-001a: ASoC: no dapm match for MICIN --> NULL --> Mic Input
tlv320aic23-codec 1-001a: ASoC: Failed to add route MICIN -> NULL -> Mic Input
I am trying to set the sound system in a CM-510 (Compulab - SoM) based board with DT, using Simple-Card-Audio and the TLV320AIC23 audio codec included in the SoM . I faced this problem and thanks to the help of Sebastian Hesselbarth who noticed the possible error located in the structure snd_soc_dapm_route tlv320aic23_intercon[] , now errors are not reported.
Tested on CM-510 (Compulab SoM Board).
Signed-off-by: dobatog <dobatog@gmail.com>
Tested-by: Max Filippov <jcmvbkbc@gmail.com>
---
sound/soc/codecs/tlv320aic23.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/sound/soc/codecs/tlv320aic23.c b/sound/soc/codecs/tlv320aic23.c
index cc17e7e..891f3aa 100644
--- a/sound/soc/codecs/tlv320aic23.c
+++ b/sound/soc/codecs/tlv320aic23.c
@@ -174,10 +174,10 @@ static const struct snd_soc_dapm_route tlv320aic23_intercon[] = {
{"ROUT", NULL, "Output Mixer"},
/* Inputs */
- {"Line Input", "NULL", "LLINEIN"},
- {"Line Input", "NULL", "RLINEIN"},
+ {"Line Input", NULL, "LLINEIN"},
+ {"Line Input", NULL, "RLINEIN"},
- {"Mic Input", "NULL", "MICIN"},
+ {"Mic Input", NULL, "MICIN"},
/* input mux */
{"Capture Source", "Line", "Line Input"},
--
2.3.3

View file

@ -8,7 +8,7 @@ _srcname=linux-3.19
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=3.19.1
pkgrel=3
pkgrel=4
rcnrel=armv7-x3
arch=('armv7h')
url="http://www.kernel.org/"
@ -26,18 +26,20 @@ source=("http://www.kernel.org/pub/linux/kernel/v3.x/${_srcname}.tar.xz"
'0004-fix-mvsdio-eMMC-timing.patch'
'0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
'0006-USB-armory-support.patch'
'0007-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch'
'config')
md5sums=('d3fc8316d4d4d04b65cbc2d70799e763'
'2f2822cf2d84a8ec3a8b044e732cf45b'
'0f085618a0d85d406320e8bbba7fbec1'
'SKIP'
'4e3bed0d1833836968ebf0d7947980a2'
'b9a9593d6724ff6a1aed7e0536939b26'
'fe82fa383a4295182182e9247f1298aa'
'2d1065176c31853f2238718f97bf2b80'
'377debc0c9f280d10e4c4f092b9c9bfc'
'8497959df9de7032e46fe68d207feaac'
'ae3dc19260a86e04658a5b6c2a71d76a')
'616f5072a75f10d0472593526f8ff638'
'7eabe6c4c26ec7a338a57381501a2aaa'
'4022216b4700cad92f5a6b3a31986bac'
'ab7f27a5502e82a70e1e0f5b2529d2cd'
'12e6b2c717989fba8501265a55039e30'
'c7c3bb2e9db362fd46563c8ef857846e'
'cfc14490dc23d41322dc67a5583ff15d'
'886eeadf9cbdc27e85608cc3b472987d')
prepare() {
cd "${srcdir}/${_srcname}"
@ -55,6 +57,7 @@ prepare() {
git apply ../0004-fix-mvsdio-eMMC-timing.patch
git apply ../0005-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
git apply ../0006-USB-armory-support.patch
git apply ../0007-ARM-TLV320AIC23-SoC-Audio-Codec-Fix-errors-reported-.patch
# AUFS patches
cp -ru "${srcdir}/aufs3-standalone/Documentation" .

View file

@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
# Linux/arm 3.19.0-1 Kernel Configuration
# Linux/arm 3.19.1-4 Kernel Configuration
#
CONFIG_ARM=y
CONFIG_ARM_HAS_SG_CHAIN=y
@ -1565,7 +1565,7 @@ CONFIG_NL80211_TESTMODE=y
# CONFIG_CFG80211_CERTIFICATION_ONUS is not set
CONFIG_CFG80211_DEFAULT_PS=y
# CONFIG_CFG80211_DEBUGFS is not set
CONFIG_CFG80211_INTERNAL_REGDB=y
# CONFIG_CFG80211_INTERNAL_REGDB is not set
# CONFIG_CFG80211_WEXT is not set
CONFIG_LIB80211=m
CONFIG_LIB80211_CRYPT_WEP=m
@ -3983,7 +3983,7 @@ CONFIG_DVB_TTUSB_DEC=m
CONFIG_SMS_USB_DRV=m
CONFIG_DVB_B2C2_FLEXCOP_USB=m
# CONFIG_DVB_B2C2_FLEXCOP_USB_DEBUG is not set
# CONFIG_DVB_AS102 is not set
CONFIG_DVB_AS102=m
#
# Webcam, TV (analog/digital) USB devices
@ -4244,7 +4244,7 @@ CONFIG_DVB_RTL2830=m
CONFIG_DVB_RTL2832=m
CONFIG_DVB_RTL2832_SDR=m
CONFIG_DVB_SI2168=m
# CONFIG_DVB_AS102_FE is not set
CONFIG_DVB_AS102_FE=m
#
# DVB-C (cable) frontends
@ -5435,7 +5435,7 @@ CONFIG_RTC_DRV_S35390A=y
CONFIG_RTC_DRV_FM3130=m
CONFIG_RTC_DRV_RX8581=m
CONFIG_RTC_DRV_RX8025=m
CONFIG_RTC_DRV_EM3027=m
CONFIG_RTC_DRV_EM3027=y
CONFIG_RTC_DRV_RV3029C2=m
CONFIG_RTC_DRV_S5M=y