mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/powerdns-recursor to 5.1.1-2
This commit is contained in:
parent
1e67d58a00
commit
dae871bb00
3 changed files with 45 additions and 4 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = powerdns-recursor
|
||||
pkgdesc = Resolving DNS server
|
||||
pkgver = 5.1.1
|
||||
pkgrel = 1
|
||||
pkgrel = 2
|
||||
url = https://www.powerdns.com/
|
||||
arch = x86_64
|
||||
license = GPL-2.0-only
|
||||
|
@ -28,10 +28,12 @@ pkgbase = powerdns-recursor
|
|||
source = https://downloads.powerdns.com/releases/pdns-recursor-5.1.1.tar.bz2
|
||||
source = https://downloads.powerdns.com/releases/pdns-recursor-5.1.1.tar.bz2.asc
|
||||
source = sysusers.conf
|
||||
source = powerdns-5_1_1-2_fix-build-with-boost-1_86_0.patch
|
||||
validpgpkeys = FBAE0323821C7706A5CA151BDCF513FA7EED19F3
|
||||
validpgpkeys = 16E12866B7738C73976A57436FFC33439B0D04DF
|
||||
sha512sums = 59129312e79bb48ce5af4de0c90f36765084708fd7b728655b07ca0cf68ba618a4bf517a9e695caaecc57e5edef4f6fa373719aa0b3e82e25d17a077883784d0
|
||||
sha512sums = SKIP
|
||||
sha512sums = 63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72
|
||||
sha512sums = 6714f61fb768393aa5123aa84be624ea6ab41a6aca6e38b41caebb8f2d935356323cb30bcdd56b21994ac1d4b399f3160cf61651817329702f4dcf387e81ae15
|
||||
|
||||
pkgname = powerdns-recursor
|
||||
|
|
|
@ -9,7 +9,7 @@
|
|||
|
||||
pkgname=powerdns-recursor
|
||||
pkgver=5.1.1
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
pkgdesc='Resolving DNS server'
|
||||
url='https://www.powerdns.com/'
|
||||
arch=('x86_64')
|
||||
|
@ -22,15 +22,20 @@ provides=('pdns-recursor')
|
|||
conflicts=('pdns-recursor')
|
||||
backup=('etc/powerdns/recursor.conf')
|
||||
source=(https://downloads.powerdns.com/releases/pdns-recursor-${pkgver}.tar.bz2{,.asc}
|
||||
sysusers.conf)
|
||||
sysusers.conf
|
||||
powerdns-5_1_1-2_fix-build-with-boost-1_86_0.patch)
|
||||
sha512sums=('59129312e79bb48ce5af4de0c90f36765084708fd7b728655b07ca0cf68ba618a4bf517a9e695caaecc57e5edef4f6fa373719aa0b3e82e25d17a077883784d0'
|
||||
'SKIP'
|
||||
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72')
|
||||
'63b3f0664d38fbbcb6b1c914cee050a27eca0a15550962973743580dd5d3ace2e68272ca2d856d53cc74001fe9246d61207ebbc74524c096736777ed08c88e72'
|
||||
'6714f61fb768393aa5123aa84be624ea6ab41a6aca6e38b41caebb8f2d935356323cb30bcdd56b21994ac1d4b399f3160cf61651817329702f4dcf387e81ae15')
|
||||
validpgpkeys=('FBAE0323821C7706A5CA151BDCF513FA7EED19F3' # Peter van Dijk <peter.van.dijk@powerdns.com>
|
||||
'16E12866B7738C73976A57436FFC33439B0D04DF') # Winkels, Erik <erik.winkels@open-xchange.com>
|
||||
|
||||
prepare() {
|
||||
cd pdns-recursor-${pkgver}
|
||||
|
||||
patch -Np2 < ../powerdns-5_1_1-2_fix-build-with-boost-1_86_0.patch
|
||||
|
||||
autoreconf -i
|
||||
}
|
||||
|
||||
|
|
|
@ -0,0 +1,34 @@
|
|||
From 2c64bff84abde12139cb3b6bf779cf566daeaddc Mon Sep 17 00:00:00 2001
|
||||
From: Michael Cho <michael@michaelcho.dev>
|
||||
Date: Thu, 15 Aug 2024 22:49:17 -0400
|
||||
Subject: [PATCH] Fix build with boost 1.86.0
|
||||
|
||||
Boost 1.86.0 changes seem to no longer indirectly include header which
|
||||
causes build to fail with:
|
||||
```
|
||||
uuid-utils.cc:38:58:
|
||||
error: 'random' is not a class, namespace, or enumeration
|
||||
```
|
||||
|
||||
boost/random/mersenne_twister.hpp has been available since Boost 1.21.2
|
||||
|
||||
(cherry picked from commit eed56000b1d68ac083b8e8bea4ff0ea30a1579c4)
|
||||
---
|
||||
pdns/uuid-utils.cc | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/pdns/uuid-utils.cc b/pdns/uuid-utils.cc
|
||||
index c59e0a0d0..301daff0b 100644
|
||||
--- a/pdns/uuid-utils.cc
|
||||
+++ b/pdns/uuid-utils.cc
|
||||
@@ -30,6 +30,7 @@
|
||||
#endif /* BOOST_PENDING_INTEGER_LOG2_HPP */
|
||||
#endif /* BOOST_VERSION */
|
||||
|
||||
+#include <boost/random/mersenne_twister.hpp>
|
||||
#include <boost/uuid/uuid_generators.hpp>
|
||||
|
||||
// The default of:
|
||||
--
|
||||
2.46.0
|
||||
|
Loading…
Reference in a new issue