mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/qt5-webengine to 5.13.1-3
This commit is contained in:
parent
5a5bffad45
commit
db3c7f73ad
2 changed files with 11 additions and 18 deletions
|
@ -11,32 +11,36 @@ highmem=1
|
|||
pkgname=qt5-webengine
|
||||
_qtver=5.13.1
|
||||
pkgver=${_qtver/-/}
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
license=('LGPL3' 'LGPL2.1' 'BSD')
|
||||
pkgdesc='Provides support for web applications using the Chromium browser project'
|
||||
depends=('qt5-webchannel' 'qt5-location' 'libxcomposite' 'libxrandr' 'pciutils' 'libxss'
|
||||
'libevent' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg' 're2' 'libvpx' 'libpulse')
|
||||
'libevent' 'snappy' 'nss' 'protobuf' 'libxslt' 'minizip' 'ffmpeg' 're2' 'libvpx')
|
||||
makedepends=('python2' 'gperf' 'jsoncpp' 'ninja' 'qt5-tools' 'poppler')
|
||||
groups=('qt' 'qt5')
|
||||
_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
|
||||
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
|
||||
qtbug-77037-workaround.patch
|
||||
qtbug-77209.patch::"https://code.qt.io/cgit/qt/qtwebengine.git/patch/?id=1c33a4a6"
|
||||
qtwebengine-pulseaudio-13.patch::"https://code.qt.io/cgit/qt/qtwebengine-chromium.git/patch/?id=0b57f159"
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch)
|
||||
sha256sums=('7f12e710b76ff2be4497bf368fc01ecd2419e2e962fb90599b0ece00ae2eb7d0'
|
||||
'3e3bb8ecf292e7f249d001db4a4a072ca4ba38f713f496122bd7c73d93d5def9'
|
||||
'9773e1fed9b8998dd800ea89315b4ea70ed81b568b0a740945ac76577c62e6f1'
|
||||
'7ed06cc2d0e3cc86df33bb80468a5f0422ed2cc5985db86444949ef3b9a12f02'
|
||||
'f03455dd16275f8abb432278abb908ebdd5f8cf83db73ae63de7a105bbf47109'
|
||||
'2a363b44b8291512bb2bcbce1370b8abfb8a57961e0e5e34150da6e337155a05')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
||||
cd ${_pkgfqn}
|
||||
patch -p1 -i "$srcdir"/qtbug-77037-workaround.patch # Fix build with pulseaudio 13
|
||||
|
||||
cd $_pkgfqn
|
||||
patch -p1 -i ../qtbug-77209.patch # Fix QWebEnginePage visibility state
|
||||
cd src/3rdparty
|
||||
patch -p1 -i "$srcdir"/qtwebengine-pulseaudio-13.patch # Fix build with pulseaudio 13
|
||||
|
||||
#cd src/3rdparty
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
|
||||
}
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- qtwebengine-everywhere-src-5.13.0/src/core/config/linux.pri.orig 2019-08-06 08:23:45.385072740 +0300
|
||||
+++ qtwebengine-everywhere-src-5.13.0/src/core/config/linux.pri 2019-08-06 08:23:51.085237082 +0300
|
||||
@@ -162,7 +162,7 @@ host_build {
|
||||
qtConfig(webengine-system-harfbuzz): gn_args += use_system_harfbuzz=true
|
||||
!qtConfig(webengine-system-glib): gn_args += use_glib=false
|
||||
qtConfig(webengine-pulseaudio) {
|
||||
- gn_args += use_pulseaudio=true
|
||||
+ gn_args += use_pulseaudio=true link_pulseaudio=true
|
||||
} else {
|
||||
gn_args += use_pulseaudio=false
|
||||
}
|
Loading…
Reference in a new issue