removed community/texmaker

This commit is contained in:
Kevin Mihelich 2013-10-13 02:29:09 +00:00
parent 70f5e6d6cd
commit db668a9170
3 changed files with 0 additions and 119 deletions

View file

@ -1,34 +0,0 @@
# $Id$
#Maintainer: Federico Cinelli <cinelli@aur.archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - ARM patch to fix qreal issue
pkgname=texmaker
pkgver=4.0.4
pkgrel=1
pkgdesc='Free cross-platform LaTeX editor'
arch=('i686' 'x86_64')
url="http://www.xm1math.net/texmaker/index.html"
license=('GPL')
depends=('poppler-qt' 'qtwebkit')
optdepends=('ghostscript: LaTeX to HTML conversion command'
'ibus-qt: accented characters support'bu
'poppler: PDF rendering support')
install="$pkgname.install"
source=("http://www.xm1math.net/$pkgname/$pkgname-$pkgver.tar.bz2" arm.patch)
md5sums=('5abe8618367bd7923f792378751648f7'
'1457390a811e66ca0587828666122b9d')
build() {
cd "$pkgname-$pkgver"
patch -p0 -i "$srcdir"/arm.patch
qmake-qt4 PREFIX=/usr texmaker.pro
make
}
package() {
cd "$srcdir/$pkgname-$pkgver"
install -dm755 "$pkgdir/usr/share"
make INSTALL_PATH="$pkgdir" INSTALL_ROOT="$pkgdir" PREFIX="/usr" install
}

View file

@ -1,78 +0,0 @@
--- documentview.cpp 2012-10-30 14:17:33.000000000 +0000
+++ documentview.cpp 2012-11-22 23:15:58.901398313 +0000
@@ -673,12 +673,12 @@
{
PageItem* page = m_pages.at(m_currentPage - 1);
- setScaleFactor(qMin(page->scaleFactor() + 0.1, s_maximumScaleFactor));
+ setScaleFactor(qMin(qreal(page->scaleFactor() + 0.1), s_maximumScaleFactor));
setScaleMode(ScaleFactor);
}
else
{
- setScaleFactor(qMin(scaleFactor() + 0.1, s_maximumScaleFactor));
+ setScaleFactor(qMin(qreal(scaleFactor() + 0.1), s_maximumScaleFactor));
}
}
@@ -689,12 +689,12 @@
{
PageItem* page = m_pages.at(m_currentPage - 1);
- setScaleFactor(qMax(page->scaleFactor() - 0.1, s_minimumScaleFactor));
+ setScaleFactor(qMax(qreal(page->scaleFactor() - 0.1), s_minimumScaleFactor));
setScaleMode(ScaleFactor);
}
else
{
- setScaleFactor(qMax(scaleFactor() - 0.1, s_minimumScaleFactor));
+ setScaleFactor(qMax(qreal(scaleFactor() - 0.1), s_minimumScaleFactor));
}
}
@@ -1342,7 +1342,7 @@
pageHeight = boundingRect.height();
- left = qMin(left, -boundingRect.width() - 1.5 * s_pageSpacing);
+ left = qMin(left, qreal(-boundingRect.width() - 1.5 * s_pageSpacing));
}
else
{
@@ -1350,7 +1350,7 @@
pageHeight = qMax(pageHeight, boundingRect.height());
- right = qMax(right, boundingRect.width() + 1.5 * s_pageSpacing);
+ right = qMax(right, qreal(boundingRect.width() + 1.5 * s_pageSpacing));
height += pageHeight + s_pageSpacing;
}
}
@@ -1362,15 +1362,15 @@
pageHeight = boundingRect.height();
- left = qMin(left, -0.5 * boundingRect.width() - s_pageSpacing);
- right = qMax(right, 0.5 * boundingRect.width() + s_pageSpacing);
+ left = qMin(left, qreal(-0.5 * boundingRect.width() - s_pageSpacing));
+ right = qMax(right, qreal(0.5 * boundingRect.width() + s_pageSpacing));
height += pageHeight + s_pageSpacing;
}
}
if(m_twoPagesMode && m_numberOfPages % 2 != 0)
{
- right = qMax(right, 0.5 * s_pageSpacing);
+ right = qMax(right, qreal(0.5 * s_pageSpacing));
height += pageHeight + s_pageSpacing;
}
@@ -1424,7 +1424,7 @@
QRectF boundingRect = page->boundingRect().translated(page->pos());
top = qMin(top, boundingRect.top() - s_pageSpacing);
- height = qMax(height, boundingRect.height() + 2.0 * s_pageSpacing);
+ height = qMax(height, qreal(boundingRect.height() + 2.0 * s_pageSpacing));
}
else
{

View file

@ -1,7 +0,0 @@
post_install() {
update-desktop-database -q
}
post_remove() {
update-desktop-database -q
}