extra/pyqt5 to 5.7.1-3

This commit is contained in:
Kevin Mihelich 2017-01-29 00:25:13 +00:00
parent 6db0e9c389
commit db676f716f
2 changed files with 28 additions and 5 deletions

View file

@ -12,7 +12,7 @@ pkgbase=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
pkgver=5.7.1
_pkgver=$pkgver
pkgrel=2
pkgrel=3
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
@ -22,7 +22,7 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.8.patch pyqt5-fix-check-license.patch)
md5sums=('b3171b67c74aa63a3cd2f386660c898b'
'5edc113edf71e42baa37e34cf0d64ec2'
'524f184f0e63aea952ba77702dff1356'
'1f57fb76747c5723dc4747fbbb376145')
prepare() {

View file

@ -1,5 +1,29 @@
--- PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:39:12.725734296 +0000
+++ PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:40:17.502273973 +0000
diff -ru a/sip/QtCore/qnamespace.sip b/sip/QtCore/qnamespace.sip
--- a/sip/QtCore/qnamespace.sip 2016-12-25 18:56:11.000000000 +0100
+++ b/sip/QtCore/qnamespace.sip 2017-01-24 12:22:19.025652899 +0100
@@ -209,8 +209,6 @@
WindowContextHelpButtonHint,
WindowShadeButtonHint,
WindowStaysOnTopHint,
- WindowOkButtonHint,
- WindowCancelButtonHint,
WindowStaysOnBottomHint,
WindowCloseButtonHint,
MacWindowToolBarButtonHint,
@@ -232,6 +230,10 @@
%If (Qt_5_5_0 -)
MaximizeUsingFullscreenGeometryHint,
%End
+%If (- Qt_5_8_0)
+ WindowOkButtonHint,
+ WindowCancelButtonHint,
+%End
};
typedef QFlags<Qt::WindowType> WindowFlags;
diff -ru a/sip/QtCore/QtCoremod.sip b/sip/QtCore/QtCoremod.sip
--- a/sip/QtCore/QtCoremod.sip 2016-12-25 18:56:11.000000000 +0100
+++ b/sip/QtCore/QtCoremod.sip 2017-01-24 12:03:50.707514377 +0100
@@ -22,7 +22,7 @@
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
@ -9,4 +33,3 @@
%Platforms {WS_X11 WS_WIN WS_MACX}