mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
removed community/gdal1
This commit is contained in:
parent
8eea05e115
commit
dbdfea4571
5 changed files with 0 additions and 180 deletions
|
@ -1,87 +0,0 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: Ray Rashif <schiv@archlinux.org>
|
|
||||||
# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
|
|
||||||
# Contributor: William Rea <sillywilly@gmail.com>
|
|
||||||
|
|
||||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
||||||
# - drop poppler, currently breaks build
|
|
||||||
# - use uname in path in removing rpath in packaging
|
|
||||||
|
|
||||||
pkgname=gdal1
|
|
||||||
_pkgname=gdal
|
|
||||||
pkgver=1.11.2
|
|
||||||
pkgrel=3
|
|
||||||
pkgdesc="A translator library for raster geospatial data formats"
|
|
||||||
arch=('i686' 'x86_64')
|
|
||||||
url="http://www.gdal.org/"
|
|
||||||
license=('custom')
|
|
||||||
depends=('curl' 'geos' 'giflib' 'hdf5' 'libgeotiff' 'libjpeg' 'libpng' 'libspatialite' 'libtiff' 'netcdf' 'python2' 'python2-numpy' 'cfitsio' 'sqlite' 'libmariadbclient' 'postgresql-libs')
|
|
||||||
makedepends=('perl' 'swig' 'chrpath' 'doxygen')
|
|
||||||
optdepends=('postgresql: postgresql database support'
|
|
||||||
'mariadb: mariadb database support'
|
|
||||||
'perl: perl binding support')
|
|
||||||
conflicts=('gdal')
|
|
||||||
changelog=$pkgname.changelog
|
|
||||||
source=(http://download.osgeo.org/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz
|
|
||||||
gdal-1.5.1-python-install.patch
|
|
||||||
poppler-0.31.patch
|
|
||||||
glibc.patch)
|
|
||||||
sha256sums=('66bc8192d24e314a66ed69285186d46e6999beb44fc97eeb9c76d82a117c0845'
|
|
||||||
'55a0a961b2d1caddf80f18b6763a96690b0b6443fbd5a0c89e29503ded3bcea6'
|
|
||||||
'4fc42bdb729cec92920236ef9f3302fab497069dbb7d41d81222e7e48a36e7a6'
|
|
||||||
'f0096bfbd9219a000d173a97ee10e30d8939c3fff40ef44e2dfb1a494b617a9f')
|
|
||||||
|
|
||||||
prepare() {
|
|
||||||
cd "${srcdir}"/$_pkgname-$pkgver
|
|
||||||
patch -Np0 -i "${srcdir}"/gdal-1.5.1-python-install.patch
|
|
||||||
patch -Np1 -i "${srcdir}"/poppler-0.31.patch
|
|
||||||
patch -Np3 -i "${srcdir}"/glibc.patch
|
|
||||||
|
|
||||||
# python2 fixes
|
|
||||||
sed -i 's_python python1.5_python2 python python1.5_' configure
|
|
||||||
for file in swig/python/{,osgeo/,samples/,scripts/}*.py; do
|
|
||||||
sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
|
|
||||||
done
|
|
||||||
|
|
||||||
# Fix mandir
|
|
||||||
sed -i "s|^mandir=.*|mandir='\${prefix}/share/man'|" configure
|
|
||||||
}
|
|
||||||
|
|
||||||
build() {
|
|
||||||
cd "${srcdir}"/$_pkgname-$pkgver
|
|
||||||
export CFLAGS="$CFLAGS -fno-strict-aliasing"
|
|
||||||
|
|
||||||
# bug #23654
|
|
||||||
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
|
|
||||||
|
|
||||||
./configure --prefix=/usr --with-netcdf --with-libtiff --with-sqlite3 \
|
|
||||||
--with-geotiff --with-mysql --with-python --with-curl \
|
|
||||||
--with-hdf5 --with-perl --with-geos --with-png --with-spatialite
|
|
||||||
|
|
||||||
# workaround for bug #13646
|
|
||||||
sed -i 's/PY_HAVE_SETUPTOOLS=1/PY_HAVE_SETUPTOOLS=/g' ./GDALmake.opt
|
|
||||||
sed -i 's/EXE_DEP_LIBS/KILL_EXE_DEP_LIBS/' apps/GNUmakefile
|
|
||||||
|
|
||||||
make
|
|
||||||
make man
|
|
||||||
}
|
|
||||||
|
|
||||||
package () {
|
|
||||||
cd "${srcdir}"/$_pkgname-$pkgver
|
|
||||||
make DESTDIR="${pkgdir}" install
|
|
||||||
make DESTDIR="${pkgdir}" install-man
|
|
||||||
|
|
||||||
# install license
|
|
||||||
install -D -m644 LICENSE.TXT "${pkgdir}"/usr/share/licenses/${_pkgname}/LICENSE
|
|
||||||
|
|
||||||
#FS15477 clean up junks
|
|
||||||
rm -f "${pkgdir}"/usr/bin/*.dox
|
|
||||||
rm -f "${pkgdir}"/usr/share/man/man1/_build_gdal_src_gdal-${pkgver}_apps_.1
|
|
||||||
|
|
||||||
# Remove RPATH
|
|
||||||
chrpath --delete "${pkgdir}"/usr/lib/perl5/$(uname -m)-linux-thread-multi/auto/Geo/OSR/OSR.so
|
|
||||||
chrpath --delete "${pkgdir}"/usr/lib/perl5/$(uname -m)-linux-thread-multi/auto/Geo/OGR/OGR.so
|
|
||||||
chrpath --delete "${pkgdir}"/usr/lib/perl5/$(uname -m)-linux-thread-multi/auto/Geo/GDAL/GDAL.so
|
|
||||||
chrpath --delete "${pkgdir}"/usr/lib/perl5/$(uname -m)-linux-thread-multi/auto/Geo/GDAL/Const/Const.so
|
|
||||||
}
|
|
|
@ -1,10 +0,0 @@
|
||||||
--- swig/python/GNUmakefile.orig 2010-04-24 01:22:07.000000000 +0200
|
|
||||||
+++ swig/python/GNUmakefile 2010-05-05 19:14:58.000000000 +0200
|
|
||||||
@@ -72,5 +72,5 @@
|
|
||||||
ifeq ($(PY_HAVE_SETUPTOOLS),1)
|
|
||||||
- $(PYTHON) setup.py install
|
|
||||||
+ $(PYTHON) setup.py install --root=$(DESTDIR)
|
|
||||||
else
|
|
||||||
- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
|
|
||||||
+ $(PYTHON) setup.py install --root=$(DESTDIR) --prefix=$(prefix)
|
|
||||||
endif
|
|
|
@ -1,57 +0,0 @@
|
||||||
2015-09-24 Ray Rashif <schiv@archlinux.org>
|
|
||||||
* gdal1 1.11.2-2 remove wrong provision for gdal
|
|
||||||
|
|
||||||
users must tentatively choose between vtk and other
|
|
||||||
packages depending on gdal; this is only a short-term
|
|
||||||
workaround as the gdal2 rebuild had to move on.
|
|
||||||
|
|
||||||
2015-09-23 Ray Rashif <schiv@archlinux.org>
|
|
||||||
* gdal1 1.11.2-1 for VTK (FS#46346)
|
|
||||||
|
|
||||||
2015-02-23 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.2-1
|
|
||||||
|
|
||||||
2015-01-29 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.1-6 poppler 0.30.0 rebuild
|
|
||||||
|
|
||||||
2014-12-22 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.1-5 FS#43193 fix
|
|
||||||
|
|
||||||
2014-12-20 Evangelos Foutras <evangelos@foutrelis.com>
|
|
||||||
* gdal 1.11.1-4 poppler 0.29.0 rebuild
|
|
||||||
|
|
||||||
2014-11-25 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.1-3 hdf5 1.8.14 rebuild
|
|
||||||
|
|
||||||
2014-10-03 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.1-1
|
|
||||||
|
|
||||||
2014-07-28 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.0-4 libspatialite soname rebuild
|
|
||||||
|
|
||||||
2014-05-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.0-2 giflib soname rebuild
|
|
||||||
|
|
||||||
2014-04-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.11.0-1
|
|
||||||
|
|
||||||
2013-11-11 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.10.1-1
|
|
||||||
|
|
||||||
2013-09-29 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.10.0-4 FS#36328 fix
|
|
||||||
|
|
||||||
2013-05-18 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.10.0-1
|
|
||||||
|
|
||||||
2011-02-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* gdal 1.8.0-1
|
|
||||||
|
|
||||||
2010-11-20 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* Update to major release 1.7.3
|
|
||||||
|
|
||||||
2010-06-26 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* FS#19946 fixed in 1.7.2-2
|
|
||||||
|
|
||||||
2010-05-05 Jaroslav Lichtblau <svetlemodry@archlinux.org>
|
|
||||||
* Update to major release 1.7.2
|
|
|
@ -1,14 +0,0 @@
|
||||||
Index: trunk/gdal/apps/gdalserver.c
|
|
||||||
===================================================================
|
|
||||||
--- a/trunk/gdal/apps/gdalserver.c
|
|
||||||
+++ b/trunk/gdal/apps/gdalserver.c
|
|
||||||
@@ -28,7 +28,6 @@
|
|
||||||
****************************************************************************/
|
|
||||||
|
|
||||||
-#if defined(__STDC_VERSION__)
|
|
||||||
-#define _XOPEN_SOURCE
|
|
||||||
-#endif
|
|
||||||
+// So that __USE_XOPEN2K is defined to have getaddrinfo
|
|
||||||
+#define _XOPEN_SOURCE 600
|
|
||||||
|
|
||||||
#include "cpl_port.h"
|
|
|
@ -1,12 +0,0 @@
|
||||||
diff -Nur gdal-1.11.2/frmts/pdf/pdfdataset.cpp gdal-1.11.2a/frmts/pdf/pdfdataset.cpp
|
|
||||||
--- gdal-1.11.2/frmts/pdf/pdfdataset.cpp 2015-02-10 13:11:19.000000000 +0100
|
|
||||||
+++ gdal-1.11.2a/frmts/pdf/pdfdataset.cpp 2015-03-02 18:38:25.170155277 +0100
|
|
||||||
@@ -113,7 +113,7 @@
|
|
||||||
GBool allowAntialiasA = gTrue) :
|
|
||||||
SplashOutputDev(colorModeA, bitmapRowPadA,
|
|
||||||
reverseVideoA, paperColorA,
|
|
||||||
- bitmapTopDownA, allowAntialiasA),
|
|
||||||
+ bitmapTopDownA),
|
|
||||||
bEnableVector(TRUE),
|
|
||||||
bEnableText(TRUE),
|
|
||||||
bEnableBitmap(TRUE) {}
|
|
Loading…
Reference in a new issue