mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
extra/qt5-webengine: fix
This commit is contained in:
parent
79735cf6d2
commit
dbf835dfee
4 changed files with 40 additions and 11 deletions
|
@ -1,7 +1,7 @@
|
|||
From e3857998449fabedad2d5c7077a97ff7efa509ed Mon Sep 17 00:00:00 2001
|
||||
From e4f423721668ce05961348cdaa34dccdbb524b2a Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
||||
Subject: [PATCH 1/2] ARM toolchain fixes
|
||||
Subject: [PATCH 1/3] ARM toolchain fixes
|
||||
|
||||
---
|
||||
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
||||
|
@ -54,5 +54,5 @@ index fa8b17e9db3..7398b7556ec 100644
|
|||
toolchain_args = {
|
||||
current_cpu = "arm"
|
||||
--
|
||||
2.24.0
|
||||
2.30.1
|
||||
|
||||
|
|
|
@ -1,17 +1,17 @@
|
|||
From 5fee35c4b2aa7e717b5f136a68245b78acf01020 Mon Sep 17 00:00:00 2001
|
||||
From 6782907d020d4c4f279f3d516b5180c10a640d56 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 1 Jul 2019 07:10:36 -0600
|
||||
Subject: [PATCH 2/2] Fix ARM skia ICE
|
||||
Subject: [PATCH 2/3] Fix ARM skia ICE
|
||||
|
||||
---
|
||||
chromium/third_party/skia/third_party/skcms/src/Transform_inl.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
index 54fbdd25b32..b25877e7cfc 100644
|
||||
index 2dcf717f3b7..8e1acb01fee 100644
|
||||
--- a/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
+++ b/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h
|
||||
@@ -611,7 +611,7 @@ SI void sample_clut_16(const skcms_A2B* a2b, I32 ix, F* r, F* g, F* b) {
|
||||
@@ -687,7 +687,7 @@ SI void sample_clut_16(const skcms_A2B* a2b, I32 ix, F* r, F* g, F* b) {
|
||||
// GCC 7.2.0 hits an internal compiler error with -finline-functions (or -O3)
|
||||
// when targeting MIPS 64, i386, or s390x, I think attempting to inline clut() into exec_ops().
|
||||
#if 1 && defined(__GNUC__) && !defined(__clang__) \
|
||||
|
@ -21,5 +21,5 @@ index 54fbdd25b32..b25877e7cfc 100644
|
|||
#else
|
||||
#define MAYBE_NOINLINE
|
||||
--
|
||||
2.24.0
|
||||
2.30.1
|
||||
|
||||
|
|
|
@ -0,0 +1,25 @@
|
|||
From bf530f78deaf4361d46de5060572c9656a174405 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Tue, 2 Feb 2021 13:58:59 -0700
|
||||
Subject: [PATCH 3/3] Run blink bindings generation single threaded
|
||||
|
||||
When not single threaded this process will eat all the RAM.
|
||||
---
|
||||
chromium/third_party/blink/renderer/bindings/BUILD.gn | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/chromium/third_party/blink/renderer/bindings/BUILD.gn b/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
index 6a457ced15a..09f1250d173 100644
|
||||
--- a/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
+++ b/chromium/third_party/blink/renderer/bindings/BUILD.gn
|
||||
@@ -181,6 +181,7 @@ template("generate_bindings") {
|
||||
outputs = invoker.outputs
|
||||
|
||||
args = [
|
||||
+ "--single_process",
|
||||
"--web_idl_database",
|
||||
rebase_path(web_idl_database, root_build_dir),
|
||||
"--root_src_dir",
|
||||
--
|
||||
2.30.1
|
||||
|
|
@ -4,6 +4,7 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch for chromium GN
|
||||
# - patch for chromium skia
|
||||
# - patch for chromium to run blink bindings generation single threaded
|
||||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
|
@ -28,12 +29,14 @@ source=(git+https://code.qt.io/qt/qtwebengine.git#commit=$_commit
|
|||
git+https://code.qt.io/qt/qtwebengine-chromium.git
|
||||
qt5-webengine-glibc-2.33.patch
|
||||
0001-ARM-toolchain-fixes.patch
|
||||
0002-Fix-ARM-skia-ICE.patch)
|
||||
0002-Fix-ARM-skia-ICE.patch
|
||||
0003-Run-blink-bindings-generation-single-threaded.patch)
|
||||
sha256sums=('SKIP'
|
||||
'SKIP'
|
||||
'2294e5390c869963fc58f7bf1ee0a254a3f7fce3ed00c04e34a5f03e2b31b624'
|
||||
'6cd3f4877e239c83df5ede59c74db2b2e84b4adce66ef83d30b3b4a3f04677e8'
|
||||
'f389de929c6d27217a1c7e3e7118b06e4d15e17123c96ace2c7a791ecad6bcc7')
|
||||
'2f9574cad9f26e9efaebdbebec92a7725f83c1f518fd1d61196f283d9b052274'
|
||||
'99e3bb37bd3c3d3c103eeb8301ee9bcc7b2c1a049c2c1936a2c35bfcc0524ed7'
|
||||
'10fd6dd0a27adcd244207c8a56ed1ecd6b7644376ea3e5362b086d587eae2d70')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -49,6 +52,7 @@ prepare() {
|
|||
cd "$srcdir/$_pkgfqn/src/3rdparty"
|
||||
patch -p1 -i ${srcdir}/0001-ARM-toolchain-fixes.patch
|
||||
patch -p1 -i ${srcdir}/0002-Fix-ARM-skia-ICE.patch
|
||||
patch -p1 -i ${srcdir}/0003-Run-blink-bindings-generation-single-threaded.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue