mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
alarm/uboot-beagleboard to 2016.09-1
This commit is contained in:
parent
6edbf1007c
commit
dc12ea6ff8
2 changed files with 36 additions and 18 deletions
|
@ -1,16 +1,17 @@
|
|||
From 99865c96edab6abba923bd6084309085712eb91d Mon Sep 17 00:00:00 2001
|
||||
From 490d8292fbbd162468db8ce5746c37c8c4e69498 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 7 Jun 2015 18:24:03 -0600
|
||||
Subject: [PATCH] arch linux arm modifications
|
||||
|
||||
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
---
|
||||
board/ti/beagle/beagle.c | 38 +++++++--
|
||||
include/configs/omap3_beagle.h | 172 ++++++++++++++---------------------------
|
||||
2 files changed, 93 insertions(+), 117 deletions(-)
|
||||
board/ti/beagle/beagle.c | 38 +++++++--
|
||||
include/configs/omap3_beagle.h | 172 +++++++++++++-------------------------
|
||||
include/configs/ti_armv7_common.h | 3 -
|
||||
3 files changed, 93 insertions(+), 120 deletions(-)
|
||||
|
||||
diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
|
||||
index ff317ef..8c1639b 100644
|
||||
index 0ed4f52..622be01 100644
|
||||
--- a/board/ti/beagle/beagle.c
|
||||
+++ b/board/ti/beagle/beagle.c
|
||||
@@ -56,6 +56,7 @@
|
||||
|
@ -111,10 +112,10 @@ index ff317ef..8c1639b 100644
|
|||
switch (get_board_revision()) {
|
||||
case REVISION_XM_AB:
|
||||
diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
|
||||
index 65f08a1..5058c3f 100644
|
||||
index 4dbe2b6..945475b 100644
|
||||
--- a/include/configs/omap3_beagle.h
|
||||
+++ b/include/configs/omap3_beagle.h
|
||||
@@ -91,6 +91,12 @@
|
||||
@@ -82,6 +82,12 @@
|
||||
#define CONFIG_USB_ETHER_MCS7830
|
||||
#define CONFIG_USB_ETHER_SMSC95XX
|
||||
|
||||
|
@ -127,7 +128,7 @@ index 65f08a1..5058c3f 100644
|
|||
/* GPIO banks */
|
||||
#define CONFIG_OMAP3_GPIO_5 /* GPIO128..159 is in GPIO bank 5 */
|
||||
#define CONFIG_OMAP3_GPIO_6 /* GPIO160..191 is in GPIO bank 6 */
|
||||
@@ -125,50 +131,62 @@
|
||||
@@ -112,50 +118,62 @@
|
||||
/* devices */
|
||||
|
||||
#define CONFIG_EXTRA_ENV_SETTINGS \
|
||||
|
@ -229,7 +230,7 @@ index 65f08a1..5058c3f 100644
|
|||
"findfdt=" \
|
||||
"if test $beaglerev = AxBx; then " \
|
||||
"setenv fdtfile omap3-beagle.dtb; fi; " \
|
||||
@@ -181,81 +199,11 @@
|
||||
@@ -168,81 +186,11 @@
|
||||
"if test $beaglerev = xMC; then " \
|
||||
"setenv fdtfile omap3-beagle-xm.dtb; fi; " \
|
||||
"if test $fdtfile = undefined; then " \
|
||||
|
@ -314,6 +315,22 @@ index 65f08a1..5058c3f 100644
|
|||
|
||||
/*
|
||||
* OMAP3 has 12 GP timers, they can be driven by the system clock
|
||||
--
|
||||
2.7.0
|
||||
diff --git a/include/configs/ti_armv7_common.h b/include/configs/ti_armv7_common.h
|
||||
index 7db0881..47cbcc6 100644
|
||||
--- a/include/configs/ti_armv7_common.h
|
||||
+++ b/include/configs/ti_armv7_common.h
|
||||
@@ -244,11 +244,8 @@
|
||||
#define CONFIG_SPL_LIBDISK_SUPPORT
|
||||
#define CONFIG_SPL_MMC_SUPPORT
|
||||
#define CONFIG_SPL_FAT_SUPPORT
|
||||
-#define CONFIG_SPL_EXT_SUPPORT
|
||||
#endif
|
||||
|
||||
-#define CONFIG_SYS_THUMB_BUILD
|
||||
-
|
||||
/* General parts of the framework, required. */
|
||||
#define CONFIG_SPL_I2C_SUPPORT
|
||||
#define CONFIG_SPL_LIBCOMMON_SUPPORT
|
||||
--
|
||||
2.9.0
|
||||
|
||||
|
|
|
@ -4,37 +4,38 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=uboot-beagleboard
|
||||
pkgver=2016.01
|
||||
pkgver=2016.09
|
||||
pkgrel=1
|
||||
pkgdesc="U-Boot for BeagleBoard and BeagleBoard-xM"
|
||||
arch=('armv7h')
|
||||
url="http://git.denx.de/u-boot.git/"
|
||||
license=('GPL')
|
||||
makedepends=('git' 'bc')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver}.tar.bz2"
|
||||
backup=('boot/uEnv.txt')
|
||||
source=("ftp://ftp.denx.de/pub/u-boot/u-boot-${pkgver/rc/-rc}.tar.bz2"
|
||||
'0001-arch-linux-arm-modifications.patch'
|
||||
'uEnv.txt')
|
||||
md5sums=('7d4f65fd43d4d706f5c5650e020d899d'
|
||||
'373fac8aefcf8bea149ecb60162f0904'
|
||||
md5sums=('2e69dda70eb28f8042d2f9fbeb1feaa1'
|
||||
'0bd6e9db86c801ee18f2a6c26af5eb6c'
|
||||
'd41d8cd98f00b204e9800998ecf8427e')
|
||||
|
||||
prepare() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
git apply ../0001-arch-linux-arm-modifications.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
|
||||
unset LDFLAGS CFLAGS CXXFLAGS
|
||||
|
||||
make distclean
|
||||
make omap3_beagle_config
|
||||
make
|
||||
make EXTRAVERSION=-${pkgrel}
|
||||
}
|
||||
|
||||
package() {
|
||||
cd u-boot-${pkgver}
|
||||
cd u-boot-${pkgver/rc/-rc}
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp MLO u-boot.img "${srcdir}"/uEnv.txt "${pkgdir}"/boot
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue