mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-aarch64-rc to 4.8.rc4-1
This commit is contained in:
parent
d5fe411c38
commit
dc16319248
4 changed files with 117 additions and 19 deletions
|
@ -0,0 +1,95 @@
|
|||
From e7009ea09b99367602e649037531749965438961 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH 1/2] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index dc989a8..912be75 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -60,6 +60,7 @@
|
||||
#define SUSPEND_SUSPEND3 (0x08)
|
||||
#define SUSPEND_ALLMODES (SUSPEND_SUSPEND0 | SUSPEND_SUSPEND1 | \
|
||||
SUSPEND_SUSPEND2 | SUSPEND_SUSPEND3)
|
||||
+#define MAC_ADDR_LEN (6)
|
||||
|
||||
#define CARRIER_CHECK_DELAY (2 * HZ)
|
||||
|
||||
@@ -80,6 +81,10 @@ static bool turbo_mode = true;
|
||||
module_param(turbo_mode, bool, 0644);
|
||||
MODULE_PARM_DESC(turbo_mode, "Enable multiple frames per Rx transaction");
|
||||
|
||||
+static char *macaddr = ":";
|
||||
+module_param(macaddr, charp, 0);
|
||||
+MODULE_PARM_DESC(macaddr, "MAC address");
|
||||
+
|
||||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||
u32 *data, int in_pm)
|
||||
{
|
||||
@@ -809,8 +814,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
|
||||
}
|
||||
|
||||
+/* Check the macaddr module parameter for a MAC address */
|
||||
+static int smsc95xx_is_macaddr_param(struct usbnet *dev, u8 *dev_mac)
|
||||
+{
|
||||
+ int i, j, got_num, num;
|
||||
+ u8 mtbl[MAC_ADDR_LEN];
|
||||
+
|
||||
+ if (macaddr[0] == ':')
|
||||
+ return 0;
|
||||
+
|
||||
+ i = 0;
|
||||
+ j = 0;
|
||||
+ num = 0;
|
||||
+ got_num = 0;
|
||||
+ while (j < MAC_ADDR_LEN) {
|
||||
+ if (macaddr[i] && macaddr[i] != ':') {
|
||||
+ got_num++;
|
||||
+ if ('0' <= macaddr[i] && macaddr[i] <= '9')
|
||||
+ num = num * 16 + macaddr[i] - '0';
|
||||
+ else if ('A' <= macaddr[i] && macaddr[i] <= 'F')
|
||||
+ num = num * 16 + 10 + macaddr[i] - 'A';
|
||||
+ else if ('a' <= macaddr[i] && macaddr[i] <= 'f')
|
||||
+ num = num * 16 + 10 + macaddr[i] - 'a';
|
||||
+ else
|
||||
+ break;
|
||||
+ i++;
|
||||
+ } else if (got_num == 2) {
|
||||
+ mtbl[j++] = (u8) num;
|
||||
+ num = 0;
|
||||
+ got_num = 0;
|
||||
+ i++;
|
||||
+ } else {
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ if (j == MAC_ADDR_LEN) {
|
||||
+ netif_dbg(dev, ifup, dev->net, "Overriding MAC address with: "
|
||||
+ "%02x:%02x:%02x:%02x:%02x:%02x\n", mtbl[0], mtbl[1], mtbl[2],
|
||||
+ mtbl[3], mtbl[4], mtbl[5]);
|
||||
+ for (i = 0; i < MAC_ADDR_LEN; i++)
|
||||
+ dev_mac[i] = mtbl[i];
|
||||
+ return 1;
|
||||
+ } else {
|
||||
+ return 0;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
static void smsc95xx_init_mac_address(struct usbnet *dev)
|
||||
{
|
||||
+ /* Check module parameters */
|
||||
+ if (smsc95xx_is_macaddr_param(dev, dev->net->dev_addr))
|
||||
+ return;
|
||||
+
|
||||
const u8 *mac_addr;
|
||||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -1,7 +1,7 @@
|
|||
From 162ae1d7fdcd03d424a27fa726ca76b2effd4f8c Mon Sep 17 00:00:00 2001
|
||||
From 4af6314960ef8b5381b9f0f67c01d1b82cc16067 Mon Sep 17 00:00:00 2001
|
||||
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
||||
Date: Thu, 11 Aug 2016 18:50:50 +0100
|
||||
Subject: [PATCH] arm64: dts: qcom: Fix broken interrupt trigger settings
|
||||
Subject: [PATCH 2/2] arm64: dts: qcom: Fix broken interrupt trigger settings
|
||||
|
||||
When a device uses the GIC as its interrupt controller and generates
|
||||
SPIs, only the values 1 (edge rising) and 4 (level high) are legal.
|
|
@ -4,7 +4,7 @@
|
|||
buildarch=8
|
||||
|
||||
_rcver=4.8
|
||||
_rcrel=3
|
||||
_rcrel=4
|
||||
|
||||
pkgbase=linux-aarch64-rc
|
||||
_srcname=linux-4.$((${_rcver##*.}-1))
|
||||
|
@ -12,7 +12,7 @@ _srcname=linux-4.$((${_rcver##*.}-1))
|
|||
_kernelname=${pkgbase#linux}
|
||||
_desc="AArch64 multi-platform (release candidate)"
|
||||
pkgver=${_rcver}.rc${_rcrel}
|
||||
pkgrel=2
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
license=('GPL2')
|
||||
|
@ -21,13 +21,15 @@ options=('!strip')
|
|||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
"https://www.kernel.org/pub/linux/kernel/v4.x/testing/patch-${_rcver}-rc${_rcrel}.xz"
|
||||
#"https://www.kernel.org/pub/linux/kernel/v4.x/testing/${_srcname}.tar.xz"
|
||||
'0001-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch'
|
||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch'
|
||||
'config'
|
||||
'linux.preset')
|
||||
md5sums=('5276563eb1f39a048e4a8a887408c031'
|
||||
'fa0b8dbf79226c52cf0e97bb316bf769'
|
||||
'395e261e50cb231cb6377efdb06a8171'
|
||||
'4bfc0807368b3d1b9d4a5860159cd01a'
|
||||
'a0c0753ff460ff35ef9908ecc97fa943'
|
||||
'8631a338f1c8f58d467809715c6e6deb'
|
||||
'e56e7fb7d65c129d9f242e672b3744ef'
|
||||
'c04d19783413cf0a804150d308f93d7a'
|
||||
'25d8f6983c9a616946848c0e075a949c')
|
||||
|
||||
prepare() {
|
||||
|
@ -37,7 +39,8 @@ prepare() {
|
|||
patch -sp1 -i ../patch-${_rcver}-rc${_rcrel}
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch
|
||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0002-arm64-dts-qcom-Fix-broken-interrupt-trigger-settings.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm64 4.8.0-rc2-1 Kernel Configuration
|
||||
# Linux/arm64 4.8.0-rc3-2 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM64=y
|
||||
CONFIG_64BIT=y
|
||||
|
@ -3065,9 +3065,9 @@ CONFIG_I2C_ARB_GPIO_CHALLENGE=m
|
|||
CONFIG_I2C_MUX_GPIO=m
|
||||
CONFIG_I2C_MUX_PCA9541=m
|
||||
CONFIG_I2C_MUX_PCA954x=m
|
||||
# CONFIG_I2C_MUX_PINCTRL is not set
|
||||
# CONFIG_I2C_MUX_REG is not set
|
||||
# CONFIG_I2C_DEMUX_PINCTRL is not set
|
||||
CONFIG_I2C_MUX_PINCTRL=m
|
||||
CONFIG_I2C_MUX_REG=m
|
||||
CONFIG_I2C_DEMUX_PINCTRL=m
|
||||
CONFIG_I2C_HELPER_AUTO=y
|
||||
CONFIG_I2C_SMBUS=m
|
||||
CONFIG_I2C_ALGOBIT=m
|
||||
|
@ -4519,7 +4519,7 @@ CONFIG_HISI_KIRIN_DW_DSI=m
|
|||
# Frame buffer Devices
|
||||
#
|
||||
CONFIG_FB=y
|
||||
# CONFIG_FIRMWARE_EDID is not set
|
||||
CONFIG_FIRMWARE_EDID=y
|
||||
CONFIG_FB_CMDLINE=y
|
||||
CONFIG_FB_NOTIFY=y
|
||||
# CONFIG_FB_DDC is not set
|
||||
|
@ -5435,7 +5435,7 @@ CONFIG_LEDS_CLASS_FLASH=m
|
|||
CONFIG_LEDS_LM3530=m
|
||||
# CONFIG_LEDS_LM3642 is not set
|
||||
# CONFIG_LEDS_PCA9532 is not set
|
||||
# CONFIG_LEDS_GPIO is not set
|
||||
CONFIG_LEDS_GPIO=m
|
||||
CONFIG_LEDS_LP3944=m
|
||||
# CONFIG_LEDS_LP3952 is not set
|
||||
# CONFIG_LEDS_LP5521 is not set
|
||||
|
@ -5443,10 +5443,10 @@ CONFIG_LEDS_LP3944=m
|
|||
# CONFIG_LEDS_LP5562 is not set
|
||||
# CONFIG_LEDS_LP8501 is not set
|
||||
# CONFIG_LEDS_LP8860 is not set
|
||||
# CONFIG_LEDS_PCA955X is not set
|
||||
# CONFIG_LEDS_PCA963X is not set
|
||||
CONFIG_LEDS_PCA955X=m
|
||||
CONFIG_LEDS_PCA963X=m
|
||||
# CONFIG_LEDS_DAC124S085 is not set
|
||||
# CONFIG_LEDS_PWM is not set
|
||||
CONFIG_LEDS_PWM=m
|
||||
# CONFIG_LEDS_REGULATOR is not set
|
||||
# CONFIG_LEDS_BD2802 is not set
|
||||
CONFIG_LEDS_LT3593=m
|
||||
|
@ -7032,7 +7032,7 @@ CONFIG_SECURITY_NETWORK_XFRM=y
|
|||
# CONFIG_SECURITY_PATH is not set
|
||||
CONFIG_HAVE_HARDENED_USERCOPY_ALLOCATOR=y
|
||||
CONFIG_HAVE_ARCH_HARDENED_USERCOPY=y
|
||||
CONFIG_HARDENED_USERCOPY=y
|
||||
# CONFIG_HARDENED_USERCOPY is not set
|
||||
# CONFIG_SECURITY_SMACK is not set
|
||||
# CONFIG_SECURITY_TOMOYO is not set
|
||||
# CONFIG_SECURITY_APPARMOR is not set
|
||||
|
|
Loading…
Reference in a new issue