extra/libreoffice-fresh to 5.1.3-2

This commit is contained in:
Kevin Mihelich 2016-06-21 02:16:42 +00:00
parent e80e779dac
commit dc3a1b799d
2 changed files with 126 additions and 3 deletions

View file

@ -19,7 +19,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=5.1.3.2
pkgver=5.1.3
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -74,6 +74,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
libreoffice-fresh.sh libreoffice-fresh.csh
update_liborcus_to_0.11.0.diff
remove_unnecessary_orcus_external_usage_from_makefiles.diff
liborcus-0.11.2.diff
gcc6_buildfix.diff)
noextract=(boost_1_59_0.tar.bz2
1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
@ -143,6 +144,7 @@ md5sums=('cbe602264e58f7c93e72068c408e3551'
'e7e4b3e70e99e5cba8f8dfcacf3b0d87'
'3f526b966a672d1237cfcbadae0e3f95'
'ac71e21ecc0976b2ea6e233854963d4b'
'58616b84405f0a610a713bbd060d3214'
'6752d22fc5bcbdbef0640c6aca163e50')
prepare() {
@ -185,8 +187,11 @@ prepare() {
patch -Np1 -i ${srcdir}/update_liborcus_to_0.11.0.diff
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=07d4c443e21cd22545d4516515c50b1c8dd39a9b
patch -Np1 -i ${srcdir}/remove_unnecessary_orcus_external_usage_from_makefiles.diff
sed -i "s:mdds >= 0.12.0:mdds-1.0 >= 0.12.0:g" configure.ac
# return 1
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=db729f3b685fd832a3ec7387b339cf2bbeb4bd4d
patch -Np1 -i ${srcdir}/liborcus-0.11.2.diff
# sed -i "s:mdds >= 0.12.0:mdds-1.2 >= 0.12.0:g" configure.ac
# fix checking whether KDE is >= 4.2... configure: error: KDE version too old
# http://bugs.debian.org/823145

View file

@ -0,0 +1,118 @@
From db729f3b685fd832a3ec7387b339cf2bbeb4bd4d Mon Sep 17 00:00:00 2001
From: Kohei Yoshida <kohei.yoshida@gmail.com>
Date: Wed, 11 May 2016 21:45:56 -0400
Subject: Update mdds to 1.2.0. Note that the API version is also up.
liborcus-0.11.2 is out only to make it buildable with mdds-1.2.
Change-Id: I9648d827b008da252c57be0ebfd2efccb008ac70
Reviewed-on: https://gerrit.libreoffice.org/24944
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Kohei Yoshida <libreoffice@kohei.us>
diff --git a/configure.ac b/configure.ac
index 3f1b7f0..6dea282 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8832,7 +8832,7 @@ AC_SUBST(SYSTEM_BOOST)
dnl ===================================================================
dnl Check for system mdds
dnl ===================================================================
-libo_CHECK_SYSTEM_MODULE([mdds], [MDDS], [mdds >= 0.12.0], ["-I${WORKDIR}/UnpackedTarball/mdds/include"])
+libo_CHECK_SYSTEM_MODULE([mdds], [MDDS], [mdds-1.2 >= 1.2.0], ["-I${WORKDIR}/UnpackedTarball/mdds/include"])
dnl ===================================================================
dnl Check for system glm
@@ -9148,7 +9148,7 @@ if test -z "$enable_orcus" -o "$enable_orcus" != no; then
ENABLE_ORCUS="TRUE"
AC_DEFINE(ENABLE_ORCUS)
- libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.11 >= 0.11.0])
+ libo_CHECK_SYSTEM_MODULE([orcus],[ORCUS],[liborcus-0.11 >= 0.11.2])
if test "$with_system_orcus" != "yes"; then
if test "$SYSTEM_BOOST" = "TRUE"; then
# ===========================================================
diff --git a/sc/inc/mtvelements.hxx b/sc/inc/mtvelements.hxx
index 0bc5162..18edafc 100644
--- a/sc/inc/mtvelements.hxx
+++ b/sc/inc/mtvelements.hxx
@@ -53,6 +53,7 @@ const mdds::mtv::element_t element_type_cellnote = mdds::mtv::element_type_user_
/// Mapped standard element types (for convenience).
const mdds::mtv::element_t element_type_numeric = mdds::mtv::element_type_numeric;
const mdds::mtv::element_t element_type_empty = mdds::mtv::element_type_empty;
+const mdds::mtv::element_t element_type_uint16 = mdds::mtv::element_type_ushort;
/// Custom element blocks.
@@ -65,6 +66,7 @@ typedef mdds::mtv::noncopyable_managed_element_block<element_type_formula, ScFor
/// Mapped standard element blocks (for convenience).
typedef mdds::mtv::numeric_element_block numeric_block;
+typedef mdds::mtv::ushort_element_block uint16_block;
/// This needs to be in the same namespace as CellTextAttr.
MDDS_MTV_DEFINE_ELEMENT_CALLBACKS(CellTextAttr, element_type_celltextattr, CellTextAttr(), celltextattr_block)
diff --git a/sc/source/core/tool/scmatrix.cxx b/sc/source/core/tool/scmatrix.cxx
index f1ce9a5..1689809 100644
--- a/sc/source/core/tool/scmatrix.cxx
+++ b/sc/source/core/tool/scmatrix.cxx
@@ -57,17 +57,15 @@ using ::std::unary_function;
* Custom string trait struct to tell mdds::multi_type_matrix about the
* custom string type and how to handle blocks storing them.
*/
-struct custom_string_trait
+struct matrix_trait
{
- typedef svl::SharedString string_type;
typedef sc::string_block string_element_block;
-
- static const mdds::mtv::element_t string_type_identifier = sc::element_type_string;
+ typedef sc::uint16_block integer_element_block;
typedef mdds::mtv::custom_block_func1<sc::string_block> element_block_func;
};
-typedef mdds::multi_type_matrix<custom_string_trait> MatrixImplType;
+typedef mdds::multi_type_matrix<matrix_trait> MatrixImplType;
namespace {
@@ -2304,6 +2302,7 @@ public:
}
}
break;
+ case mdds::mtm::element_integer:
case mdds::mtm::element_empty:
break;
}
diff --git a/svl/source/misc/gridprinter.cxx b/svl/source/misc/gridprinter.cxx
index 4044b3e..70e7439 100644
--- a/svl/source/misc/gridprinter.cxx
+++ b/svl/source/misc/gridprinter.cxx
@@ -26,12 +26,10 @@ const mdds::mtv::element_t element_type_string = mdds::mtv::element_type_user_st
// String block
typedef mdds::mtv::default_element_block<element_type_string, OUString> string_block;
-struct custom_string_trait
+struct matrix_trait
{
- typedef OUString string_type;
typedef string_block string_element_block;
-
- static const mdds::mtv::element_t string_type_identifier = element_type_string;
+ typedef mdds::mtv::ushort_element_block integer_element_block;
typedef mdds::mtv::custom_block_func1<string_block> element_block_func;
};
@@ -48,7 +46,7 @@ MDDS_MTV_DEFINE_ELEMENT_CALLBACKS(OUString, svl::element_type_string, OUString()
namespace svl {
-typedef mdds::multi_type_matrix<custom_string_trait> MatrixImplType;
+typedef mdds::multi_type_matrix<matrix_trait> MatrixImplType;
struct GridPrinter::Impl
{
--
cgit v0.10.2