mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/chromium to 83.0.4103.116-2
This commit is contained in:
parent
79bc747413
commit
dc52b0c31f
2 changed files with 44 additions and 1 deletions
|
@ -16,7 +16,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=83.0.4103.116
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
arch=('x86_64')
|
||||
|
@ -43,6 +43,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
include-memory-header-to-get-the-definition-of-std-u.patch
|
||||
make-some-of-blink-custom-iterators-STL-compatible.patch
|
||||
avoid-double-destruction-of-ServiceWorkerObjectHost.patch
|
||||
force-mp3-files-to-have-a-start-time-of-zero.patch
|
||||
v8-remove-soon-to-be-removed-getAllFieldPositions.patch
|
||||
chromium-fix-vaapi-on-intel.patch
|
||||
chromium-83-gcc-10.patch
|
||||
|
@ -58,6 +59,7 @@ sha256sums=('bb0c7e8dfee9f3a5e30eca7f34fc9f21caefa82a86c058c552f52b1ae2da2ac3'
|
|||
'071326135bc25226aa165639dff80a03670a17548f2d2ff5cc4f40982b39c52a'
|
||||
'3d7f20e1d2ee7d73ed25e708c0d59a0cb215fcce10a379e3d48a856533c4b0b7'
|
||||
'd793842e9584bf75e3779918297ba0ffa6dd05394ef5b2bf5fb73aa9c86a7e2f'
|
||||
'abc3fad113408332c3b187b083bf33eba59eb5c87fa3ce859023984b5804623c'
|
||||
'e042024423027ad3ef729a7e4709bdf9714aea49d64cfbbf46a645a05703abc2'
|
||||
'e495f2477091557b15bff2c99831e0a3db64ea2ebde7dcb22857a6469c944b9a'
|
||||
'3e5ba8c0a70a4bc673deec0c61eb2b58f05a4c784cbdb7c8118be1eb6580db6d'
|
||||
|
@ -144,6 +146,9 @@ prepare() {
|
|||
# https://chromium-review.googlesource.com/c/chromium/src/+/2094496
|
||||
patch -Np1 -i ../avoid-double-destruction-of-ServiceWorkerObjectHost.patch
|
||||
|
||||
# https://chromium-review.googlesource.com/c/chromium/src/+/2268221
|
||||
patch -Np1 -i ../force-mp3-files-to-have-a-start-time-of-zero.patch
|
||||
|
||||
# https://crbug.com/v8/10393
|
||||
patch -Np1 -d v8 <../v8-remove-soon-to-be-removed-getAllFieldPositions.patch
|
||||
|
||||
|
|
|
@ -0,0 +1,38 @@
|
|||
From 192fc3899f76e9487d77895f31df8d2d13bf9619 Mon Sep 17 00:00:00 2001
|
||||
From: Dale Curtis <dalecurtis@chromium.org>
|
||||
Date: Fri, 26 Jun 2020 01:10:55 +0000
|
||||
Subject: [PATCH] Force mp3 files to have a start time of zero.
|
||||
|
||||
This will allow us to remove our custom patch which breaks upstream
|
||||
ffmpeg functionality for unknown reasons.
|
||||
|
||||
R=sandersd
|
||||
|
||||
Fixed: 1062037
|
||||
Change-Id: I253011843dee4dd6a8c958b14990ad836a9f1dca
|
||||
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2268221
|
||||
Auto-Submit: Dale Curtis <dalecurtis@chromium.org>
|
||||
Reviewed-by: Dan Sanders <sandersd@chromium.org>
|
||||
Commit-Queue: Dale Curtis <dalecurtis@chromium.org>
|
||||
Cr-Commit-Position: refs/heads/master@{#782792}
|
||||
---
|
||||
media/filters/ffmpeg_demuxer.cc | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/media/filters/ffmpeg_demuxer.cc b/media/filters/ffmpeg_demuxer.cc
|
||||
index 01266e1a072..a7ed542b5fc 100644
|
||||
--- a/media/filters/ffmpeg_demuxer.cc
|
||||
+++ b/media/filters/ffmpeg_demuxer.cc
|
||||
@@ -1522,6 +1522,12 @@ void FFmpegDemuxer::OnFindStreamInfoDone(int result) {
|
||||
if (glue_->container() == container_names::CONTAINER_AVI)
|
||||
format_context->flags |= AVFMT_FLAG_GENPTS;
|
||||
|
||||
+ // FFmpeg will incorrectly adjust the start time of MP3 files into the future
|
||||
+ // based on discard samples. We were unable to fix this upstream without
|
||||
+ // breaking ffmpeg functionality. https://crbug.com/1062037
|
||||
+ if (glue_->container() == container_names::CONTAINER_MP3)
|
||||
+ start_time_ = base::TimeDelta();
|
||||
+
|
||||
// For testing purposes, don't overwrite the timeline offset if set already.
|
||||
if (timeline_offset_.is_null()) {
|
||||
timeline_offset_ =
|
Loading…
Reference in a new issue