mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
extra/gst-plugins-bad to 1.6.0-1
This commit is contained in:
parent
d3634b0bee
commit
dc5454c735
2 changed files with 4 additions and 45 deletions
|
@ -5,8 +5,8 @@
|
||||||
# - drop valgrind makedepend
|
# - drop valgrind makedepend
|
||||||
|
|
||||||
pkgname=gst-plugins-bad
|
pkgname=gst-plugins-bad
|
||||||
pkgver=1.4.5
|
pkgver=1.6.0
|
||||||
pkgrel=4
|
pkgrel=1
|
||||||
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
pkgdesc="GStreamer Multimedia Framework Bad Plugins"
|
||||||
arch=('i686' 'x86_64')
|
arch=('i686' 'x86_64')
|
||||||
license=('LGPL')
|
license=('LGPL')
|
||||||
|
@ -15,17 +15,11 @@ depends=('mjpegtools' 'gst-plugins-base-libs' 'curl' 'chromaprint' 'libmms' 'faa
|
||||||
makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'wildmidi' 'librsvg'
|
makedepends=('schroedinger' 'libexif' 'libdvdread' 'libvdpau' 'libmpeg2' 'python' 'wildmidi' 'librsvg'
|
||||||
'gobject-introspection' 'gtk-doc' 'gtk3' 'clutter' 'opencv' 'libtiger' 'ladspa' 'openal' 'libusb')
|
'gobject-introspection' 'gtk-doc' 'gtk3' 'clutter' 'opencv' 'libtiger' 'ladspa' 'openal' 'libusb')
|
||||||
options=(!emptydirs)
|
options=(!emptydirs)
|
||||||
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz
|
source=(${url}/src/$pkgname/$pkgname-$pkgver.tar.xz)
|
||||||
fix-faad2-version-check.patch)
|
sha256sums=('d8ff26128d4ecd2ffeb28e14843808d2d971b09056b7cee6f08afcae01fc0f49')
|
||||||
sha256sums=('152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c'
|
|
||||||
'741492ae7a9518603fc51d87ae331d882f075547ea7fdec19c60f399085f18cc')
|
|
||||||
|
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $pkgname-$pkgver
|
cd $pkgname-$pkgver
|
||||||
|
|
||||||
# https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
|
||||||
patch -Np1 -i ../fix-faad2-version-check.patch
|
|
||||||
|
|
||||||
autoreconf -vi
|
autoreconf -vi
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
|
@ -1,35 +0,0 @@
|
||||||
From 1f738ca5b8711ca5532a326cd646312e60484863 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Wim Taymans <wtaymans@redhat.com>
|
|
||||||
Date: Wed, 13 May 2015 16:23:26 +0200
|
|
||||||
Subject: fix faad2 version check
|
|
||||||
|
|
||||||
On fedora 22, the output of cpp inserts extra debug comments, which
|
|
||||||
makes our regexp for the faad2 version check fail. This in turn causes
|
|
||||||
it to compile with the wrong arguments passed which then causes stack
|
|
||||||
corruption and crashes.
|
|
||||||
|
|
||||||
Fix this by only checking for the version (which should be by itself on
|
|
||||||
a single line). This is potentially less safe, it might be possible that
|
|
||||||
a similar string would appear in a later version in the header file.
|
|
||||||
|
|
||||||
Fixes https://bugzilla.gnome.org/show_bug.cgi?id=748571
|
|
||||||
|
|
||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index f5ce28c..d295253 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -2008,9 +2008,9 @@ AG_GST_CHECK_FEATURE(FAAD, [AAC decoder plug-in], faad, [
|
|
||||||
AC_MSG_CHECKING([Checking FAAD2 version in $faad_hdr])
|
|
||||||
for minor in 10 9 8 7 6 5 0; do
|
|
||||||
if test x$faad2_minor_version = "x"; then
|
|
||||||
- AC_EGREP_CPP([GST_CHECK_FAAD_VERSION \"2\.$minor\"], [
|
|
||||||
+ AC_EGREP_CPP([\"2\.$minor\"$], [
|
|
||||||
#include <$faad_hdr>
|
|
||||||
- GST_CHECK_FAAD_VERSION FAAD2_VERSION
|
|
||||||
+ FAAD2_VERSION
|
|
||||||
], [
|
|
||||||
faad2_minor_version=$minor
|
|
||||||
])
|
|
||||||
--
|
|
||||||
cgit v0.10.2
|
|
||||||
|
|
Loading…
Reference in a new issue