core/linux-armv7-rc to 4.19.rc5-1

This commit is contained in:
Kevin Mihelich 2018-09-25 01:15:14 +00:00
parent 00f4a3623a
commit dc92540ba3
15 changed files with 104 additions and 57 deletions

View file

@ -1,7 +1,7 @@
From 6ea8686dc9fe35d8eb0db8377948f878bb5f197e Mon Sep 17 00:00:00 2001
From 3fe3d31dfe86c2c36fe3dbf318b62c17dad74979 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 01/13] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 01/14] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
};
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 0b2a95fb47a6cae403fb6e7d8b46dbe30d803cf9 Mon Sep 17 00:00:00 2001
From 0318a0c7a4f28fea65ece490b8e5ab999ea28cf0 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 02/13] ARM: atags/fdt: retrieve MAC addresses from Marvell
Subject: [PATCH 02/14] ARM: atags/fdt: retrieve MAC addresses from Marvell
boot loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
}
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 8381475130812e6b31cf700edee0388b0167a988 Mon Sep 17 00:00:00 2001
From aeb39caae840357c6f8746f7b357db39e289dfb0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 03/13] SMILE Plug device tree file
Subject: [PATCH 03/14] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From abf76b3e15bc0a6e777cf7ed908fdeb586513dd2 Mon Sep 17 00:00:00 2001
From 91fb157f637a63b837bb561de7c5e8e82a0742b7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 04/13] fix mvsdio eMMC timing
Subject: [PATCH 04/14] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index e22bbff89c8d..6b30c850ce07 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 96b1b9a89f1418da53e482296fbe8b6d188bdaac Mon Sep 17 00:00:00 2001
From 7b672000c60cd27290cf40aa35465c36ddac377e Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 05/13] net/smsc95xx: Allow mac address to be set as a
Subject: [PATCH 05/14] net/smsc95xx: Allow mac address to be set as a
parameter
---
@ -92,5 +92,5 @@ index 06b4d290784d..3be3b5a4a176 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 1160370454aa52b104daf90f268ed60272c854ab Mon Sep 17 00:00:00 2001
From 9554ee43557caf3307c4d02363edad337b57183b Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 06/13] set default cubietruck led triggers
Subject: [PATCH 06/14] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index 5649161de1d7..2be64a886555 100644
};
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 572a7b93f66d79062d93e7c6fd28ddf140a1c14c Mon Sep 17 00:00:00 2001
From f25e2b18b4773c9419f2308d16e8d119384ac3cf Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 07/13] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 07/14] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
@ -26,5 +26,5 @@ index a09e46c9dbc0..d8117a820812 100644
regulator-always-on;
regulator-boot-on;
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 46ca7d062b22205db04f07e947d3349552f1bcd7 Mon Sep 17 00:00:00 2001
From e1ab434c1ed6331c1bf91060053a48929bfb2f63 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 08/13] ARM: dove: enable ethernet on D3Plug
Subject: [PATCH 08/14] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From a87c1bebbd061ee80fb1b979c2e257a742bc6a83 Mon Sep 17 00:00:00 2001
From 95b35165973f831017aad76240a29f9e3cc7bedd Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:03 +0800
Subject: [PATCH 09/13] power: add power sequence library
Subject: [PATCH 09/14] power: add power sequence library
We have an well-known problem that the device needs to do some power
sequence before it can be recognized by related host, the typical
@ -109,10 +109,10 @@ index 000000000000..554608e5f3b6
+.. kernel-doc:: drivers/power/pwrseq/core.c
+ :export:
diff --git a/MAINTAINERS b/MAINTAINERS
index a5b256b25905..61f64089db76 100644
index 02a39617ec82..5b42de98ef9d 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -11605,6 +11605,15 @@ F: drivers/firmware/psci*.c
@@ -11622,6 +11622,15 @@ F: drivers/firmware/psci*.c
F: include/linux/psci.h
F: include/uapi/linux/psci.h
@ -786,5 +786,5 @@ index 000000000000..c5b278f5f2ae
+
+#endif /* __LINUX_PWRSEQ_H */
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From fce0a6cc938622413cf166231fde1beb586acf3e Mon Sep 17 00:00:00 2001
From cdc5187421ccf419dc0effb8dbaffb6eb1964174 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:05 +0800
Subject: [PATCH 10/13] usb: core: add power sequence handling for USB devices
Subject: [PATCH 10/14] usb: core: add power sequence handling for USB devices
Some hard-wired USB devices need to do power sequence to let the
device work normally, the typical power sequence like: enable USB
@ -162,5 +162,5 @@ index 4accfb63f7dc..abe71c5e84cb 100644
/**
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 84920ea6544dd79a0d5fd1cdb2ee54e91bc657c4 Mon Sep 17 00:00:00 2001
From 94f4eacc527eb42f8601680b98ff5ee82eaa31e5 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:06 +0800
Subject: [PATCH 11/13] ARM: dts: imx6qdl: Enable usb node children with <reg>
Subject: [PATCH 11/14] ARM: dts: imx6qdl: Enable usb node children with <reg>
Give usb nodes #address and #size attributes, so that a child node
representing a permanently connected device such as an onboard hub may
@ -45,5 +45,5 @@ index 61d2d26afbf4..bb67b1e6bc91 100644
interrupts = <0 42 IRQ_TYPE_LEVEL_HIGH>;
clocks = <&clks IMX6QDL_CLK_USBOH3>;
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 6dc233c33d2fd13deea2ff6f469a941f65ed9bcf Mon Sep 17 00:00:00 2001
From 19ac8e8f7c88d8e622f7eb6195b82bf3dd5c4558 Mon Sep 17 00:00:00 2001
From: Peter Chen <peter.chen@nxp.com>
Date: Wed, 21 Jun 2017 14:42:07 +0800
Subject: [PATCH 12/13] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
Subject: [PATCH 12/14] ARM: dts: imx6qdl-udoo.dtsi: fix onboard USB HUB
property
The current dts describes USB HUB's property at USB controller's
@ -76,5 +76,5 @@ index 4f27861bbb32..dead14b0d4bf 100644
&usdhc3 {
--
2.18.0
2.19.0

View file

@ -1,7 +1,7 @@
From 3c8593ae4e13a0eff55883dc4e2d99044050ca23 Mon Sep 17 00:00:00 2001
From 1493af9612c94615a73c09a75f2bfaeabb2df0f0 Mon Sep 17 00:00:00 2001
From: Joshua Clayton <stillcompiling@gmail.com>
Date: Wed, 21 Jun 2017 14:42:08 +0800
Subject: [PATCH 13/13] ARM: dts: imx6q-evi: Fix onboard hub reset line
Subject: [PATCH 13/14] ARM: dts: imx6q-evi: Fix onboard hub reset line
Previously the onboard hub was made to work by treating its
reset gpio as a regulator enable.
@ -70,5 +70,5 @@ index fcd257bc5ac3..d32fa81bba95 100644
>;
};
--
2.18.0
2.19.0

View file

@ -0,0 +1,44 @@
From b3da2b98cf8ebab28279669f5cfab83b505b918f Mon Sep 17 00:00:00 2001
From: Hal Emmerich <hal@halemmerich.com>
Date: Thu, 19 Jul 2018 21:48:08 -0500
Subject: [PATCH 14/14] usb: dwc2: disable power_down on rockchip devices
The bug would let the usb controller enter partial power down,
which was formally known as hibernate, upon boot if nothing was plugged
in to the port. Partial power down couldn't be exited properly, so any
usb devices plugged in after boot would not be usable.
Before the name change, params.hibernation was false by default, so
_dwc2_hcd_suspend() would skip entering hibernation. With the
rename, _dwc2_hcd_suspend() was changed to use params.power_down
to decide whether or not to enter partial power down.
Since params.power_down is non-zero by default, it needs to be set
to 0 for rockchip devices to restore functionality.
This bug was reported in the linux-usb thread:
REGRESSION: usb: dwc2: USB device not seen after boot
The commit that caused this regression is:
6d23ee9caa6790aea047f9aca7f3c03cb8d96eb6
Signed-off-by: Hal Emmerich <hal@halemmerich.com>
---
drivers/usb/dwc2/params.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/usb/dwc2/params.c b/drivers/usb/dwc2/params.c
index bf7052e037d6..09292dc977e4 100644
--- a/drivers/usb/dwc2/params.c
+++ b/drivers/usb/dwc2/params.c
@@ -81,6 +81,7 @@ static void dwc2_set_rk_params(struct dwc2_hsotg *hsotg)
p->host_perio_tx_fifo_size = 256;
p->ahbcfg = GAHBCFG_HBSTLEN_INCR16 <<
GAHBCFG_HBSTLEN_SHIFT;
+ p->power_down = 0;
}
static void dwc2_set_ltq_params(struct dwc2_hsotg *hsotg)
--
2.19.0

View file

@ -4,7 +4,7 @@
buildarch=4
_rcver=4.19
_rcrel=4
_rcrel=5
_rcnrel=armv7-x1
pkgbase=linux-armv7-rc
@ -33,27 +33,29 @@ source=("https://git.kernel.org/torvalds/t/${_srcname}.tar.gz"
'0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch'
'0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch'
'0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch'
'0014-usb-dwc2-disable-power_down-on-rockchip-devices.patch'
'config'
'kernel.its'
'kernel.keyblock'
'kernel_data_key.vbprivk'
'linux.preset'
'99-linux.hook')
md5sums=('9ec996e158431e07b6a0da072a7b636c'
'5b9c39e069e4ded0bd65fbe8c8a35297'
'e006cc9c6c38207cee7c8e7a7344d445'
'fb0b2320b6303eec8018eedb5f18697b'
'1d2f258cde46197de614583998caecc8'
'245dba8b6a1e7982b8213a448b77facf'
'2a4918f32075b69b790ddf3ccc026a27'
'5b9bd510403b18f5441d972e2e3cb12a'
'9a4c64547f4a928cf7a6eff34140eb00'
'41ca0b9b3b51c96c5d7c664ffdf801e2'
'151a35f6362e0ba0b2302817a6f8d780'
'a1cb2662e0d0478bf3d89666912e9408'
'cf42944b8f43808da0169ceb527a62ce'
'34cb78e69877d11c4d6de608b9224b18'
'aa9f3877d2b523bffa06ec337bb823e4'
md5sums=('5a3109e96d992abf0771de7327a412b5'
'b83ff4d0bb7b9bcb52bbec06a38504b4'
'b12466afb3d0b5265e4f3eb286197be7'
'256bbae12b94f732f69cca9297ff96de'
'3b1720b2334c4efb16e0da002734a00e'
'7ccb756e46aa9a61a2ffdf0549f0edc3'
'fcbf4fef50ca6cbd2b360a3603cde764'
'6f5d1259ca3c23ed24c8c23f7a9af93f'
'fc30a0f23a9f185baf3bd02cb55609b4'
'4169c9ea2f1f0511fd242df1021fadfc'
'2028de0c679e6926a311d6805d767824'
'f868d4a5d828f56e018a7c28256081bd'
'1d400b52890fb0d08911e4a4b25bfec5'
'18ebf11f2ad87660c62eea3c49258efa'
'c7652c4ef9ef6f5204cff75ee2304ad8'
'd90174a3bcbf777d907413b92b7ad1b6'
'e919f9d0b5184bb61e2dc405efb4bac5'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -82,6 +84,7 @@ prepare() {
git apply ../0011-ARM-dts-imx6qdl-Enable-usb-node-children-with-reg.patch
git apply ../0012-ARM-dts-imx6qdl-udoo.dtsi-fix-onboard-USB-HUB-proper.patch
git apply ../0013-ARM-dts-imx6q-evi-Fix-onboard-hub-reset-line.patch
git apply ../0014-usb-dwc2-disable-power_down-on-rockchip-devices.patch
cat "${srcdir}/config" > ./.config