mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Merge pull request #801 from CrawX/removepatch
alarm/xbmc-imx remove wandboard detect patch
This commit is contained in:
commit
dc97b00fa0
2 changed files with 2 additions and 27 deletions
|
@ -6,13 +6,13 @@
|
|||
buildarch=4
|
||||
|
||||
pkgname=xbmc-imx-git
|
||||
pkgver=13.20140407
|
||||
pkgver=13.20140411
|
||||
pkgrel=1
|
||||
pkgdesc="A software media player and entertainment hub for digital media for select imx6 systems"
|
||||
arch=('armv7h')
|
||||
url="http://xbmc.org"
|
||||
license=('GPL' 'custom')
|
||||
depends=('fribidi' 'lzo2' 'smbclient' 'libtiff' 'libpng' 'libcdio' 'yajl' 'libmariadbclient' 'libjpeg-turbo' 'libsamplerate' 'libssh' 'libmicrohttpd' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez-libs' 'tinyxml' 'libplist' 'swig' 'taglib' 'libxslt' 'libfslvpuwrap' 'gpu-viv-bin-mx6q-fb' 'libcec-imx6')
|
||||
depends=('fribidi' 'lzo2' 'smbclient' 'libtiff' 'libpng' 'libcdio' 'yajl' 'libmariadbclient' 'libjpeg-turbo' 'libsamplerate' 'libssh' 'libmicrohttpd' 'sdl_image' 'python2' 'libass' 'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'libbluray' 'libnfs' 'afpfs-ng' 'libshairport' 'avahi' 'bluez-libs' 'tinyxml' 'libplist' 'swig' 'taglib' 'libxslt' 'libfslvpuwrap' 'gpu-viv-bin-mx6q-fb' 'libcec-imx6' 'firmware-imx')
|
||||
makedepends=('boost' 'cmake' 'gperf' 'nasm' 'zip' 'udisks' 'upower' 'git' 'autoconf' 'java-runtime-headless' 'linux-headers-imx6-fsl')
|
||||
optdepends=(
|
||||
'lirc: remote controller support'
|
||||
|
@ -24,12 +24,10 @@ provides=("xbmc")
|
|||
conflicts=("xbmc")
|
||||
install="xbmc.install"
|
||||
source=('xbmc.service'
|
||||
'fix-wandboard.patch'
|
||||
'runxbmc'
|
||||
'xbmc.conf')
|
||||
|
||||
md5sums=('07096dfd530cc432fa6073ee1a32e7f6'
|
||||
'4ddb9c84c81b03da4e6aae46d7e82edb'
|
||||
'730ac095a89b05c3c2cf2dd93947cb5c'
|
||||
'00704fd638de9b7f071479cb22e81dae')
|
||||
|
||||
|
@ -58,9 +56,6 @@ prepare() {
|
|||
|
||||
cd "${srcdir}/${_gitname}"
|
||||
|
||||
# fix running on wandboard-dt
|
||||
patch -p0 <../fix-wandboard.patch
|
||||
|
||||
# fix lsb_release dependency
|
||||
sed -i -e 's:/usr/bin/lsb_release -d:cat /etc/arch-release:' xbmc/utils/SystemInfo.cpp
|
||||
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
diff --git xbmc/windowing/egl/EGLNativeTypeIMX.cpp xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||
index 4ffa708..e85a633 100644
|
||||
--- xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||
+++ xbmc/windowing/egl/EGLNativeTypeIMX.cpp
|
||||
@@ -48,11 +48,15 @@ bool CEGLNativeTypeIMX::CheckCompatibility()
|
||||
{
|
||||
std::string strName;
|
||||
std::string str2 ("mxc_sdc_fb");
|
||||
+ std::string str3 ("platform:fb.24");
|
||||
get_sysfs_str("/sys/class/graphics/fb0/device/modalias", strName);
|
||||
StringUtils::Trim(strName);
|
||||
size_t found = strName.find(str2);
|
||||
if (found!=std::string::npos)
|
||||
return true;
|
||||
+ found = strName.find(str3);
|
||||
+ if (found!=std::string::npos)
|
||||
+ return true;
|
||||
return false;
|
||||
}
|
||||
|
Loading…
Reference in a new issue