added alarm/uboot-boundary

This commit is contained in:
Kevin Mihelich 2014-05-03 16:32:42 +00:00
parent 24b4cf907c
commit dcc28117cf
3 changed files with 161 additions and 0 deletions

View file

@ -0,0 +1,61 @@
setenv bootargs
setenv nextcon 0;
if hdmidet ; then
setenv bootargs $bootargs video=mxcfb${nextcon}:dev=hdmi,1280x720M@60,if=RGB24
setenv fbmem "fbmem=28M";
setexpr nextcon $nextcon + 1
else
echo "------ no HDMI monitor";
fi
i2c dev 2
if i2c probe 0x04 ; then
setenv bootargs $bootargs video=mxcfb${nextcon}:dev=ldb,LDB-XGA,if=RGB666
if test "0" -eq $nextcon; then
setenv fbmem "fbmem=10M";
else
setenv fbmem ${fbmem},10M
fi
setexpr nextcon $nextcon + 1
else
echo "------ no Freescale display";
fi
if i2c probe 0x38 ; then
setenv bootargs $bootargs video=mxcfb${nextcon}:dev=ldb,1024x600M@60,if=RGB666
if test "0" -eq $nextcon; then
setenv fbmem "fbmem=10M";
else
setenv fbmem ${fbmem},10M
fi
setexpr nextcon $nextcon + 1
else
echo "------ no 1024x600 display";
fi
if i2c probe 0x48 ; then
setenv bootargs $bootargs video=mxcfb${nextcon}:dev=lcd,CLAA-WVGA,if=RGB666
if test "0" -eq $nextcon; then
setenv fbmem "fbmem=10M";
else
setenv fbmem ${fbmem},10M
fi
setexpr nextcon $nextcon + 1
else
echo "------ no 800x480 display";
fi
while test "3" -ne $nextcon ; do
setenv bootargs $bootargs video=mxcfb${nextcon}:off ;
setexpr nextcon $nextcon + 1 ;
done
setenv bootargs $bootargs $fbmem
setenv bootargs $bootargs console=ttymxc1,115200 vmalloc=400M root=/dev/mmcblk0p1 rw rootwait consoleblank=0
setenv fdtfile imx6q-nitrogen6x.dtb
load ${dtype} ${disk}:1 10800000 /boot/zImage && load ${dtype} ${disk}:1 11000000 /boot/dtbs/${fdtfile} && bootz 10800000 - 11000000
load ${dtype} ${disk}:1 10800000 /boot/uImage && bootm 10800000

View file

@ -0,0 +1,45 @@
# U-Boot: Boundary Devices Nitrogen6X/Sabre Lite
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
buildarch=4
pkgname=uboot-boundary
pkgver=2014.04
pkgrel=1
arch=('armv7h')
pkgdesc="U-Boot for Nitrogen6X/Sabre Lite"
url="https://github.com/boundarydevices/u-boot-imx6/tree/production"
license=('GPL')
makedepends=('uboot-mkimage')
backup=('6x_bootscript')
_commit=64683040a54eeba258ede1a7f06e1348e9130653
source=("https://github.com/boundarydevices/u-boot-imx6/archive/${_commit}.tar.gz"
'6x_bootscript'
'alarm.patch')
md5sums=('dfdcf985d228b853606b91cb193916d4'
'4c78341ff205c4e99f428385869c22e0'
'9c8304b11ad58a9b9604d89d076856dd')
prepare() {
cd u-boot-imx6-${_commit}
patch -p1 -i "${srcdir}"/alarm.patch
}
build() {
cd u-boot-imx6-${_commit}
unset CFLAGS
unset CXXFLAGS
make distclean
make nitrogen6q_config
make
}
package() {
cd u-boot-imx6-${_commit}
mkdir -p "${pkgdir}"/boot
cp u-boot.imx "${pkgdir}"/boot
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n "boot script" -d ../6x_bootscript ${pkgdir}/6x_bootscript
}

View file

@ -0,0 +1,55 @@
diff -urN a/include/configs/nitrogen6x.h b/include/configs/nitrogen6x.h
--- a/include/configs/nitrogen6x.h 2014-04-25 14:14:19.000000000 -0600
+++ b/include/configs/nitrogen6x.h 2014-05-02 18:51:44.604279073 -0600
@@ -77,6 +77,8 @@
#define CONFIG_BOUNCE_BUFFER
#define CONFIG_CMD_EXT2
#define CONFIG_CMD_FAT
+#define CONFIG_CMD_EXT4
+#define CONFIG_CMD_FS_GENERIC
#define CONFIG_DOS_PARTITION
#ifdef CONFIG_MX6Q
@@ -189,6 +191,8 @@
#define CONFIG_DRIVE_TYPES CONFIG_DRIVE_SATA CONFIG_DRIVE_MMC CONFIG_DRIVE_USB
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+
#if defined(CONFIG_SABRELITE)
#define CONFIG_EXTRA_ENV_SETTINGS \
"script=boot.scr\0" \
@@ -275,13 +279,11 @@
"usb start ;" \
"fi; " \
"for disk in 0 1 ; do ${dtype} dev ${disk} ;" \
- "for fs in fat ext2 ; do " \
- "${fs}load " \
- "${dtype} ${disk}:1 " \
- "10008000 " \
- "/6x_bootscript" \
- "&& source 10008000 ; " \
- "done ; " \
+ "load " \
+ "${dtype} ${disk}:1 " \
+ "10008000 " \
+ "/6x_bootscript" \
+ "&& source 10008000 ; " \
"done ; " \
"done; " \
"setenv stdout serial,vga ; " \
@@ -295,11 +297,9 @@
"upgradeu=for dtype in ${bootdevs}" \
"; do " \
"for disk in 0 1 ; do ${dtype} dev ${disk} ;" \
- "for fs in fat ext2 ; do " \
- "${fs}load ${dtype} ${disk}:1 10008000 " \
- "/6x_upgrade " \
- "&& source 10008000 ; " \
- "done ; " \
+ "load ${dtype} ${disk}:1 10008000 " \
+ "/6x_upgrade " \
+ "&& source 10008000 ; " \
"done ; " \
"done\0" \
"usbnet_devaddr=00:19:b8:00:00:02\0" \