extra/vtk to 9.3.1-4

This commit is contained in:
Kevin Mihelich 2024-09-12 18:12:14 +00:00
parent 4d853f4657
commit dcd5be1ce1
3 changed files with 58 additions and 4 deletions

View file

@ -1,7 +1,7 @@
pkgbase = vtk
pkgdesc = Software system for 3D computer graphics, image processing, and visualization
pkgver = 9.3.1
pkgrel = 1
pkgrel = 4
url = https://www.vtk.org
arch = x86_64
license = BSD-3-Clause
@ -108,8 +108,12 @@ pkgbase = vtk
source = https://www.vtk.org/files/release/9.3/VTK-9.3.1.tar.gz
source = vtk-occt.patch
source = ospray-3.patch
source = https://github.com/Kitware/VTK/commit/761aa1d15970fcb6aadb7d6152737fa9b2d4b0d0.patch
source = fmt-11.patch
sha256sums = 8354ec084ea0d2dc3d23dbe4243823c4bfc270382d0ce8d658939fd50061cab8
sha256sums = df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011
sha256sums = faf3fd2eea2f73a07f5dcbd67920161a07ae554e008ad1e4099153fec2882278
sha256sums = 46de5cee71d696d9632472e27ed369ec49f0e276c3e4bb0a397397d928553864
sha256sums = 8161d4e184a3f2d075be26605c0d38f04314a8e26146ab5b1c33f87dabc2b0d2
pkgname = vtk

View file

@ -17,7 +17,7 @@
pkgname=vtk
# May need bootstrapping on upgrades due to circular vtk <-> opencascade dependency
pkgver=9.3.1
pkgrel=1
pkgrel=4
pkgdesc="Software system for 3D computer graphics, image processing, and visualization"
arch=(x86_64)
url="https://www.vtk.org"
@ -127,10 +127,14 @@ optdepends=(
options=(staticlibs)
source=(${url}/files/release/${pkgver%.*}/VTK-${pkgver}.tar.gz
vtk-occt.patch
ospray-3.patch)
ospray-3.patch
https://github.com/Kitware/VTK/commit/761aa1d15970fcb6aadb7d6152737fa9b2d4b0d0.patch
fmt-11.patch)
sha256sums=('8354ec084ea0d2dc3d23dbe4243823c4bfc270382d0ce8d658939fd50061cab8'
'df958eabc7dc4f5b33383ce0fb0f90a3ba202c1c2a24d3b5b9e7cfb1fb38b011'
'faf3fd2eea2f73a07f5dcbd67920161a07ae554e008ad1e4099153fec2882278')
'faf3fd2eea2f73a07f5dcbd67920161a07ae554e008ad1e4099153fec2882278'
'46de5cee71d696d9632472e27ed369ec49f0e276c3e4bb0a397397d928553864'
'8161d4e184a3f2d075be26605c0d38f04314a8e26146ab5b1c33f87dabc2b0d2')
prepare() {
cd ${pkgname^^}-${pkgver}
@ -139,6 +143,8 @@ prepare() {
patch -Np1 -i "$srcdir"/vtk-occt.patch
patch -Np1 -i ../ospray-3.patch # Fix build with ospray 3.0
patch -Np1 -i "$srcdir"/761aa1d15970fcb6aadb7d6152737fa9b2d4b0d0.patch # Fix OCCT 7.8.0
patch -p1 -i ../fmt-11.patch # Fix build with fmt 11
}
build() {

44
extra/vtk/fmt-11.patch Normal file
View file

@ -0,0 +1,44 @@
diff -ru VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_IOFactory.C VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_IOFactory.C
--- VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_IOFactory.C 2024-09-08 10:39:43.785130427 +0200
+++ VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_IOFactory.C 2024-09-08 10:42:08.072087946 +0200
@@ -12,6 +12,7 @@
#include <cstddef> // for nullptr
#include "vtk_fmt.h"
#include VTK_FMT(fmt/ostream.h)
+#include VTK_FMT(fmt/ranges.h)
#include <map> // for _Rb_tree_iterator, etc
#include <ostream> // for basic_ostream, etc
#include <set>
diff -ru VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_StructuredBlock.C VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_StructuredBlock.C
--- VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_StructuredBlock.C 2024-09-08 10:39:43.788463820 +0200
+++ VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_StructuredBlock.C 2024-09-08 10:57:28.625305675 +0200
@@ -15,6 +15,7 @@
#include <Ioss_StructuredBlock.h>
#include "vtk_fmt.h"
#include VTK_FMT(fmt/ostream.h)
+#include VTK_FMT(fmt/ranges.h)
#include <cstddef> // for size_t
#include <numeric>
diff -ru VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_Utils.C VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_Utils.C
--- VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_Utils.C 2024-09-08 10:39:43.791797211 +0200
+++ VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_Utils.C 2024-09-08 10:47:06.456187726 +0200
@@ -21,6 +21,7 @@
#include VTK_FMT(fmt/chrono.h)
#include VTK_FMT(fmt/format.h)
#include VTK_FMT(fmt/ostream.h)
+#include VTK_FMT(fmt/ranges.h)
#include <fstream>
#include <sstream>
#include <string>
diff -ru VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_ZoneConnectivity.C VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_ZoneConnectivity.C
--- VTK-9.3.1.orig/ThirdParty/ioss/vtkioss/Ioss_ZoneConnectivity.C 2024-09-08 10:39:43.791797211 +0200
+++ VTK-9.3.1/ThirdParty/ioss/vtkioss/Ioss_ZoneConnectivity.C 2024-09-08 10:51:18.889659250 +0200
@@ -9,6 +9,7 @@
#include <cstddef> // for size_t
#include "vtk_fmt.h"
#include VTK_FMT(fmt/ostream.h)
+#include VTK_FMT(fmt/ranges.h)
#include <string> // for string
#include <vector> // for vector