extra/libreoffice-fresh to 5.1.2-1

This commit is contained in:
Kevin Mihelich 2016-04-11 18:46:52 +00:00
parent 29d9e4d1a8
commit dcdaa9462e
3 changed files with 12 additions and 87 deletions

View file

@ -17,9 +17,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=5.1.1.3
pkgver=5.1.1
pkgrel=4
_LOver=5.1.2.2
pkgver=5.1.2
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -73,8 +73,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
make-pyuno-work-with-system-wide-module-install.diff
libreoffice-fresh.sh libreoffice-fresh.csh
update_liborcus_to_0.11.0.diff
remove_unnecessary_orcus_external_usage_from_makefiles.diff
buildfix.diff)
remove_unnecessary_orcus_external_usage_from_makefiles.diff)
noextract=(boost_1_59_0.tar.bz2
1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -104,11 +103,11 @@ noextract=(boost_1_59_0.tar.bz2
libfreehand-0.1.1.tar.bz2
185d60944ea767075d27247c3162b3bc-unowinreg.dll)
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
md5sums=('5354a6172015603ba057a2fbbfc9977e'
md5sums=('6145510261094a85a6cecaecefa10c94'
'SKIP'
'c4bde6b9f65eea1b0d7e6dc73537cdab'
'0ff7ef91f9f84d5a9a21e3bee72bdae7'
'SKIP'
'4cfbacd4328863aaf08107e7d3b329a7'
'4075e99e6075fb7bd163a5f66e24c0f3'
'SKIP'
'6aa9a5c6a4ca1016edd0ed1178e3cb87'
'1f24ab1d39f4a51faf22244c94a6203f'
@ -141,9 +140,8 @@ md5sums=('5354a6172015603ba057a2fbbfc9977e'
'dcb5ad3e5f7139227677ea064b075422'
'4195735a80876ae812fca5736b50192a'
'e7e4b3e70e99e5cba8f8dfcacf3b0d87'
'9ad03bcf1549acc0274e67bfc4c95390'
'ac71e21ecc0976b2ea6e233854963d4b'
'97dac0a03bbcaa4ee29f262dbcb4b427')
'46585d8df3706ce004c494bfb9c23391'
'ac71e21ecc0976b2ea6e233854963d4b')
prepare() {
@ -163,9 +161,6 @@ prepare() {
# fix not upstreamable pyuno paths - patch taken from Debian
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# https://gerrit.libreoffice.org/#/c/22695/
patch -Np1 -i ${srcdir}/buildfix.diff
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
@ -182,8 +177,6 @@ prepare() {
# qt4 fix
sed -i "s:qmake:qmake-qt4:g" configure.ac
# mdds 1.0.0/liborcus 0.11.0 fix
# https://cgit.freedesktop.org/libreoffice/core/commit/?id=b325b4c286b56a63316063a3ac4648bf7b7efcbe
patch -Np1 -i ${srcdir}/update_liborcus_to_0.11.0.diff
@ -191,7 +184,6 @@ prepare() {
patch -Np1 -i ${srcdir}/remove_unnecessary_orcus_external_usage_from_makefiles.diff
sed -i "s:mdds >= 0.12.0:mdds-1.0 >= 0.12.0:g" configure.ac
# sed -i "s:liborcus-0.10:liborcus-0.11:g" configure.ac
}
build() {
@ -328,7 +320,7 @@ package_libreoffice-fresh() {
'lcms2' 'poppler>=0.24.0' 'libvisio' 'libetonyek' 'libodfgen' 'libcdr'
'libmspub' 'harfbuzz-icu' 'glew' 'nss' 'clucene' 'hicolor-icon-theme'
'desktop-file-utils' 'shared-mime-info' 'xdg-utils' 'glu' 'libpagemaker'
'gst-plugins-base-libs' 'libxinerama' 'libabw' 'libmwaw' 'libe-book' 'libcups' 'gtk2'
'libxinerama' 'libabw' 'libmwaw' 'libe-book' 'libcups' 'gtk2'
'liborcus' 'liblangtag' 'libexttextcat' 'libfbclient' 'libcmis')
optdepends=('java-runtime: adds java support'
'java-environment: required by extension-wiki-publisher and extension-nlpsolver'

View file

@ -1,67 +0,0 @@
From 36ae1972ff64c80dc053680c82032904f7bbdcb8 Mon Sep 17 00:00:00 2001
From: Fabio Buso <dev.siroibaf@gmail.com>
Date: Thu, 25 Feb 2016 09:45:03 +0100
Subject: Use rtl::math::isNan()
isnan() not found causes compilation error
System: Archlinux (Kernel Version 4.4) - GCC 5.3.0
Change-Id: Id0bb4555428896678437e8abf228f1c208f1e7a0
Reviewed-on: https://gerrit.libreoffice.org/22695
Reviewed-by: Tor Lillqvist <tml@collabora.com>
Tested-by: Tor Lillqvist <tml@collabora.com>
diff --git a/svx/source/items/e3ditem.cxx b/svx/source/items/e3ditem.cxx
index 9e623dc..9604bce 100644
--- a/svx/source/items/e3ditem.cxx
+++ b/svx/source/items/e3ditem.cxx
@@ -19,6 +19,7 @@
#include <com/sun/star/drawing/Direction3D.hpp>
#include <tools/stream.hxx>
+#include <rtl/math.hxx>
#include <svx/e3ditem.hxx>
@@ -87,7 +88,7 @@ SvStream& SvxB3DVectorItem::Store(SvStream &rStream, sal_uInt16 /*nItemVersion*/
bool SvxB3DVectorItem::QueryValue( uno::Any& rVal, sal_uInt8 /*nMemberId*/ ) const
{
- assert(!isnan(aVal.getX()) && !isnan(aVal.getY()) && !isnan(aVal.getZ()));
+ assert(!rtl::math::isNan(aVal.getX()) && !rtl::math::isNan(aVal.getY()) && !rtl::math::isNan(aVal.getZ()));
drawing::Direction3D aDirection;
@@ -111,7 +112,7 @@ bool SvxB3DVectorItem::PutValue( const uno::Any& rVal, sal_uInt8 /*nMemberId*/ )
aVal.setY(aDirection.DirectionY);
aVal.setZ(aDirection.DirectionZ);
- assert(!isnan(aVal.getX()) && !isnan(aVal.getY()) && !isnan(aVal.getZ()));
+ assert(!rtl::math::isNan(aVal.getX()) && !rtl::math::isNan(aVal.getY()) && !rtl::math::isNan(aVal.getZ()));
return true;
}
diff --git a/xmloff/source/draw/ximp3dscene.cxx b/xmloff/source/draw/ximp3dscene.cxx
index 5cf205f..69fb32a 100644
--- a/xmloff/source/draw/ximp3dscene.cxx
+++ b/xmloff/source/draw/ximp3dscene.cxx
@@ -18,6 +18,7 @@
*/
#include <sax/tools/converter.hxx>
+#include <rtl/math.hxx>
#include "ximp3dscene.hxx"
#include <xmloff/xmluconv.hxx>
@@ -66,7 +67,7 @@ SdXML3DLightContext::SdXML3DLightContext(
{
::basegfx::B3DVector aVal;
SvXMLUnitConverter::convertB3DVector(aVal, sValue);
- if (!isnan(aVal.getX()) && !isnan(aVal.getY()) && !isnan(aVal.getZ()))
+ if (!rtl::math::isNan(aVal.getX()) && !rtl::math::isNan(aVal.getY()) && !rtl::math::isNan(aVal.getZ()))
{
maDirection = aVal;
}
--
cgit v0.10.2

View file

@ -73,8 +73,8 @@ index 906a579..475112b 100644
+++ b/download.lst
@@ -117,8 +117,8 @@ export OPENCOLLADA_TARBALL := OpenCOLLADA-master-6509aa13af.tar.bz2
export OPENLDAP_TARBALL := 804c6cb5698db30b75ad0ff1c25baefd-openldap-2.4.31.tgz
export OPENSSL_MD5SUM := a06c547dac9044161a477211049f60ef
export OPENSSL_TARBALL := openssl-1.0.2a.tar.gz
export OPENSSL_MD5SUM := f3c710c045cdee5fd114feb69feba7aa
export OPENSSL_TARBALL := openssl-1.0.2g.tar.gz
-export ORCUS_MD5SUM := e6efcbe50a5fd4d50d513c9a7a4139b0
-export ORCUS_TARBALL := liborcus-0.9.2.tar.gz
+export ORCUS_MD5SUM := ca1e5d486b29cd519bb1d9845a6a768e