mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/pixman to 0.24.4-2
This commit is contained in:
parent
1ff61dbc55
commit
dd64e26f7c
2 changed files with 3 additions and 53 deletions
|
@ -8,7 +8,7 @@
|
||||||
plugrel=1
|
plugrel=1
|
||||||
|
|
||||||
pkgname=pixman
|
pkgname=pixman
|
||||||
pkgver=0.24.2
|
pkgver=0.24.4
|
||||||
pkgrel=2
|
pkgrel=2
|
||||||
pkgdesc="The pixel-manipulation library for X and cairo"
|
pkgdesc="The pixel-manipulation library for X and cairo"
|
||||||
arch=(i686 x86_64)
|
arch=(i686 x86_64)
|
||||||
|
@ -16,14 +16,11 @@ url="http://xorg.freedesktop.org"
|
||||||
license=('custom')
|
license=('custom')
|
||||||
depends=('glibc')
|
depends=('glibc')
|
||||||
options=('!libtool')
|
options=('!libtool')
|
||||||
source=(http://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2
|
source=(http://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2)
|
||||||
revert-reject-trapezoids-where-top-is-above-the-edges.patch)
|
sha1sums=('683450f917015366ac7918fc517c76801aeff374')
|
||||||
sha1sums=('233eed3cd16ee1b2a842140477503d2c68b74418'
|
|
||||||
'ee36251d47ccefd5e276cabdba9917fbb2be787a')
|
|
||||||
|
|
||||||
build() {
|
build() {
|
||||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||||
patch -Np1 -i "${srcdir}/revert-reject-trapezoids-where-top-is-above-the-edges.patch"
|
|
||||||
[[ $CARCH = "arm" ]] && CONFIG="--disable-arm-simd --disable-arm-neon --disable-arm-iwmmxt"
|
[[ $CARCH = "arm" ]] && CONFIG="--disable-arm-simd --disable-arm-neon --disable-arm-iwmmxt"
|
||||||
[[ $CARCH = "armv7h" ]] && CONFIG="--disable-arm-neon --disable-arm-iwmmxt"
|
[[ $CARCH = "armv7h" ]] && CONFIG="--disable-arm-neon --disable-arm-iwmmxt"
|
||||||
./configure --prefix=/usr --disable-static $CONFIG
|
./configure --prefix=/usr --disable-static $CONFIG
|
||||||
|
|
|
@ -1,47 +0,0 @@
|
||||||
From e5555d7a749c90288463ed1c294f58963c607e52 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Søren Sandmann Pedersen <ssp@redhat.com>
|
|
||||||
Date: Wed, 25 Jan 2012 19:03:05 +0000
|
|
||||||
Subject: Revert "Reject trapezoids where top (botttom) is above (below) the edges"
|
|
||||||
|
|
||||||
Cairo 1.10 will sometimes generate trapezoids like this, so we can't
|
|
||||||
consider them invalid. Fixes bug 45009, reported by Michael Biebl.
|
|
||||||
|
|
||||||
This reverts commit 2437ae80e5066dec9fe52f56b016bf136d7cea06.
|
|
||||||
---
|
|
||||||
diff --git a/pixman/pixman.h b/pixman/pixman.h
|
|
||||||
index 20ff496..18d9513 100644
|
|
||||||
--- a/pixman/pixman.h
|
|
||||||
+++ b/pixman/pixman.h
|
|
||||||
@@ -908,14 +908,10 @@ struct pixman_triangle
|
|
||||||
};
|
|
||||||
|
|
||||||
/* whether 't' is a well defined not obviously empty trapezoid */
|
|
||||||
-#define pixman_trapezoid_valid(t) \
|
|
||||||
- ((t)->left.p1.y != (t)->left.p2.y && \
|
|
||||||
- (t)->right.p1.y != (t)->right.p2.y && \
|
|
||||||
- (int) ((t)->bottom - (t)->top) > 0 && \
|
|
||||||
- (t)->bottom <= (t)->left.p2.y && \
|
|
||||||
- (t)->bottom <= (t)->right.p2.y && \
|
|
||||||
- (t)->top >= (t)->left.p1.y && \
|
|
||||||
- (t)->top >= (t)->right.p1.y)
|
|
||||||
+#define pixman_trapezoid_valid(t) \
|
|
||||||
+ ((t)->left.p1.y != (t)->left.p2.y && \
|
|
||||||
+ (t)->right.p1.y != (t)->right.p2.y && \
|
|
||||||
+ (int) ((t)->bottom - (t)->top) > 0)
|
|
||||||
|
|
||||||
struct pixman_span_fix
|
|
||||||
{
|
|
||||||
diff --git a/test/composite-traps-test.c b/test/composite-traps-test.c
|
|
||||||
index de518d8..ff03b50 100644
|
|
||||||
--- a/test/composite-traps-test.c
|
|
||||||
+++ b/test/composite-traps-test.c
|
|
||||||
@@ -251,6 +251,6 @@ test_composite (int testnum,
|
|
||||||
int
|
|
||||||
main (int argc, const char *argv[])
|
|
||||||
{
|
|
||||||
- return fuzzer_test_main("composite traps", 40000, 0x4346479C,
|
|
||||||
+ return fuzzer_test_main("composite traps", 40000, 0xE3112106,
|
|
||||||
test_composite, argc, argv);
|
|
||||||
}
|
|
||||||
--
|
|
||||||
cgit v0.9.0.2-2-gbebe
|
|
Loading…
Reference in a new issue