mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
removed community/haproxy
This commit is contained in:
parent
827abea0ce
commit
dd9f0cacaf
5 changed files with 0 additions and 184 deletions
|
@ -1,39 +0,0 @@
|
|||
diff --git a/admin/iprange/Makefile b/admin/iprange/Makefile
|
||||
index 13598d8..eb89fb9 100644
|
||||
--- a/admin/iprange/Makefile
|
||||
+++ b/admin/iprange/Makefile
|
||||
@@ -7,7 +7,7 @@ OBJS = iprange ip6range
|
||||
all: $(OBJS)
|
||||
|
||||
%: %.c
|
||||
- $(CC) $(LDFLAGS) $(OPTIMIZE) -o $@ $^
|
||||
+ $(CC) $(OPTIMIZE) $(CFLAGS) $(LDFLAGS) -o $@ $^
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) *.o *.a *~
|
||||
diff --git a/dev/poll/Makefile b/dev/poll/Makefile
|
||||
index fdee514..9be926c 100644
|
||||
--- a/dev/poll/Makefile
|
||||
+++ b/dev/poll/Makefile
|
||||
@@ -5,7 +5,7 @@ INCLUDE =
|
||||
OBJS = poll
|
||||
|
||||
poll: poll.c
|
||||
- $(CC) $(OPTIMIZE) $(DEFINE) $(INCLUDE) -o $@ $^
|
||||
+ $(CC) $(OPTIMIZE) $(CFLAGS) $(LDFLAGS) $(DEFINE) $(INCLUDE) -o $@ $^
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) *.[oas] *~
|
||||
diff --git a/dev/tcploop/Makefile b/dev/tcploop/Makefile
|
||||
index 42a6259..e8a6ff7 100644
|
||||
--- a/dev/tcploop/Makefile
|
||||
+++ b/dev/tcploop/Makefile
|
||||
@@ -5,7 +5,7 @@ INCLUDE =
|
||||
OBJS = tcploop
|
||||
|
||||
tcploop: tcploop.c
|
||||
- $(CC) $(OPTIMIZE) $(DEFINE) $(INCLUDE) -o $@ $^
|
||||
+ $(CC) $(OPTIMIZE) $(CFLAGS) $(LDFLAGS) $(DEFINE) $(INCLUDE) -o $@ $^
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) *.[oas] *~
|
|
@ -1,87 +0,0 @@
|
|||
# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=haproxy
|
||||
pkgver=2.5.1
|
||||
pkgrel=1
|
||||
|
||||
pkgdesc='Reliable, high performance TCP/HTTP load balancer'
|
||||
url='https://www.haproxy.org/'
|
||||
arch=('x86_64')
|
||||
license=('GPL')
|
||||
|
||||
depends=('openssl' 'pcre' 'zlib' 'libxcrypt' 'libcrypt.so' 'lua' 'systemd-libs')
|
||||
makedepends=('systemd')
|
||||
|
||||
backup=('etc/haproxy/haproxy.cfg')
|
||||
|
||||
install=haproxy.install
|
||||
|
||||
source=(https://www.haproxy.org/download/${pkgver%.*}/src/haproxy-$pkgver.tar.gz
|
||||
haproxy.cfg
|
||||
haproxy.sysusers
|
||||
0001-Use-CFLAGS-and-LDFLAGS-when-building-admin.patch)
|
||||
|
||||
sha256sums=('3e90790dfc832afa6ca4fdf4528de2ce2e74f3e1f74bed0d70ad54bd5920e954'
|
||||
'e88edeb2fe23508565e46ff485c93cfb7c2e9c64f231538452ec7ecd7ec37a42'
|
||||
'b02b4088205039f0979aef0ef3e22957f493dd54eabefaee7011f2d795303b3e'
|
||||
'8cdbb8be7a712f7b2c7f4823a96d2d2926d96b57632e9669069354d7f2df9fd2')
|
||||
|
||||
prepare() {
|
||||
cd haproxy-$pkgver
|
||||
|
||||
patch -p1 <"$srcdir"/0001-Use-CFLAGS-and-LDFLAGS-when-building-admin.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd haproxy-$pkgver
|
||||
|
||||
export CFLAGS="$CFLAGS -fwrapv"
|
||||
|
||||
[[ $CARCH == "arm" || $CARCH == "armv6h" ]] && ADDLIB="-latomic"
|
||||
make \
|
||||
ADDLIB=$ADDLIB \
|
||||
CFLAGS="$CFLAGS" \
|
||||
LDFLAGS="$LDFLAGS" \
|
||||
CPU=generic \
|
||||
TARGET=linux-glibc \
|
||||
USE_GETADDRINFO=1 \
|
||||
USE_LUA=1 \
|
||||
USE_OPENSSL=1 \
|
||||
USE_PCRE=1 USE_PCRE_JIT=1 \
|
||||
USE_PROMEX=1 \
|
||||
USE_SYSTEMD=1 \
|
||||
USE_ZLIB=1
|
||||
|
||||
make \
|
||||
SBINDIR=/usr/bin \
|
||||
OPTIMIZE= \
|
||||
CFLAGS="$CFLAGS" \
|
||||
LDFLAGS="$LDFLAGS" \
|
||||
admin/{halog/halog,iprange/ip{,6}range}
|
||||
make \
|
||||
SBINDIR=/usr/bin \
|
||||
-C admin/systemd/
|
||||
}
|
||||
|
||||
package() {
|
||||
cd haproxy-$pkgver
|
||||
make \
|
||||
PREFIX="$pkgdir"/usr \
|
||||
SBINDIR="$pkgdir"/usr/bin \
|
||||
DOCDIR="$pkgdir"/usr/share/$pkgname \
|
||||
install
|
||||
|
||||
for admin in admin/{halog/halog,iprange/ip{,6}range}; do
|
||||
install -D -m0755 $admin "$pkgdir"/usr/bin/$(basename $admin)
|
||||
done
|
||||
|
||||
install -D -m0644 ../haproxy.sysusers "$pkgdir"/usr/lib/sysusers.d/haproxy.conf
|
||||
install -D -m0644 ../haproxy.cfg "$pkgdir"/etc/haproxy/haproxy.cfg
|
||||
install -D -m0644 admin/systemd/haproxy.service \
|
||||
"$pkgdir"/usr/lib/systemd/system/haproxy.service
|
||||
cp -r examples "$pkgdir"/usr/share/haproxy/examples
|
||||
}
|
|
@ -1,49 +0,0 @@
|
|||
#---------------------------------------------------------------------
|
||||
# Example configuration. See the full configuration manual online.
|
||||
#
|
||||
# http://www.haproxy.org/download/1.7/doc/configuration.txt
|
||||
#
|
||||
#---------------------------------------------------------------------
|
||||
|
||||
global
|
||||
maxconn 20000
|
||||
log 127.0.0.1 local0
|
||||
user haproxy
|
||||
chroot /usr/share/haproxy
|
||||
pidfile /run/haproxy.pid
|
||||
daemon
|
||||
|
||||
frontend main
|
||||
bind :5000
|
||||
mode http
|
||||
log global
|
||||
option httplog
|
||||
option dontlognull
|
||||
option http_proxy
|
||||
option forwardfor except 127.0.0.0/8
|
||||
maxconn 8000
|
||||
timeout client 30s
|
||||
|
||||
acl url_static path_beg -i /static /images /javascript /stylesheets
|
||||
acl url_static path_end -i .jpg .gif .png .css .js
|
||||
|
||||
use_backend static if url_static
|
||||
default_backend app
|
||||
|
||||
backend static
|
||||
mode http
|
||||
balance roundrobin
|
||||
timeout connect 5s
|
||||
timeout server 5s
|
||||
server static 127.0.0.1:4331 check
|
||||
|
||||
backend app
|
||||
mode http
|
||||
balance roundrobin
|
||||
timeout connect 5s
|
||||
timeout server 30s
|
||||
timeout queue 30s
|
||||
server app1 127.0.0.1:5001 check
|
||||
server app2 127.0.0.1:5002 check
|
||||
server app3 127.0.0.1:5003 check
|
||||
server app4 127.0.0.1:5004 check
|
|
@ -1,8 +0,0 @@
|
|||
post_install() {
|
||||
printf '==> %s\n' "The example config chroots HAProxy, meaning that logging to journald won't work."
|
||||
printf ' %s\n' "Either disable chrooting, use rsyslog, or bind /run/systemd/journal/dev-log into the chroot."
|
||||
}
|
||||
|
||||
post_upgrade() {
|
||||
post_install $1
|
||||
}
|
|
@ -1 +0,0 @@
|
|||
u haproxy - - -
|
Loading…
Reference in a new issue