mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
Added python-distribute
This commit is contained in:
parent
c56023729e
commit
ddc8a4ea19
5 changed files with 76 additions and 52 deletions
|
@ -1,8 +1,6 @@
|
|||
# Maintainer: Ian Botley <ianjb@plugboxlinux.org>
|
||||
# Contributor: Alexander Holler <holler@ahsoftware.de>
|
||||
|
||||
# NOTE: Comment out your LDFLAGS in /etc/makepkg.conf for making this!
|
||||
|
||||
pkgname=u-boot
|
||||
pkgver=2010.03
|
||||
pkgrel=2
|
||||
|
@ -39,6 +37,7 @@ md5sums=('2bf5ebf497dddc52440b1ea386cc1332'
|
|||
'5c289aea0486daa8b969715dbb1367c7'
|
||||
'a6b9b231c4e9e4eea2d24c5ed028844d'
|
||||
'af964ca6d1a1456652b1463bd0db0052')
|
||||
LDFLAGS=""
|
||||
|
||||
build() {
|
||||
cd $srcdir/$pkgname-$pkgver
|
||||
|
|
|
@ -1,47 +0,0 @@
|
|||
# Contributor: Andrew Wright <andreww@photism.org>
|
||||
# Maintainer: Paul Mattal <paul@archlinux.org>
|
||||
|
||||
pkgname=apache-ant
|
||||
pkgver=1.7.1
|
||||
pkgrel=3
|
||||
pkgdesc="A java-based build tool."
|
||||
arch=('arm')
|
||||
license=('APACHE')
|
||||
url="http://ant.apache.org/"
|
||||
depends=('java-runtime')
|
||||
optdepends=('junit: to jave junit on the classpath in javac tasks')
|
||||
source=(http://archive.apache.org/dist/ant/binaries/${pkgname}-${pkgver}-bin.tar.bz2
|
||||
${pkgname}.sh)
|
||||
md5sums=('9330447f3763b87570dd1118c49a8efd'
|
||||
'593ee6ebd9b8ec321534a028e686880f')
|
||||
|
||||
build() {
|
||||
# install profile.d script
|
||||
install -dm755 ${pkgdir}/etc/profile.d || return 1
|
||||
install -m755 ${srcdir}/${pkgname}.sh ${pkgdir}/etc/profile.d/ || return 1
|
||||
|
||||
# Get the ANT_HOME env var
|
||||
source ${srcdir}/${pkgname}.sh || return 1
|
||||
|
||||
cd ${srcdir}/${pkgname}-${pkgver}
|
||||
install -dm755 ${pkgdir}/${ANT_HOME}/{bin,lib} || return 1
|
||||
|
||||
install -m644 ./lib/*.jar ${pkgdir}/${ANT_HOME}/lib || return 1
|
||||
cp -Rp ./etc ${pkgdir}/${ANT_HOME} || return 1
|
||||
|
||||
# Do not copy Windows .bat/.cmd files
|
||||
find ./bin -type f -a ! -name \*.bat -a ! -name \*.cmd \
|
||||
-exec install -m755 {} ${pkgdir}/${ANT_HOME}/bin \; || return 1
|
||||
|
||||
# symlink to junit so it's on the javac build path for ant
|
||||
# matches behavior on ubuntu 9 and makes sense for compatibility
|
||||
# http://bugs.archlinux.org/task/15229
|
||||
cd $startdir/pkg/usr/share/java/apache-ant/lib || return 1
|
||||
ln -s ../../junit.jar . || return 1
|
||||
cd - || return 1
|
||||
|
||||
# The license says the NOTICE file should be redistributed for derivative
|
||||
# works, so lets supply it.
|
||||
install -dm755 ${pkgdir}/usr/share/licenses/${pkgname} || return 1
|
||||
install -m644 LICENSE NOTICE ${pkgdir}/usr/share/licenses/${pkgname} || return 1
|
||||
}
|
|
@ -1,3 +0,0 @@
|
|||
export ANT_HOME=/usr/share/java/apache-ant
|
||||
export PATH=$PATH:$ANT_HOME/bin
|
||||
|
24
extra/python-distribute/PKGBUILD
Normal file
24
extra/python-distribute/PKGBUILD
Normal file
|
@ -0,0 +1,24 @@
|
|||
# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
|
||||
# Contributor: Sebastien Binet <binet@farnsworth>
|
||||
|
||||
# Plugbox changes: Submitted by pepedog to replace ABS for python 2.6/7/3.0
|
||||
|
||||
pkgname=python-distribute
|
||||
pkgver=0.6.14
|
||||
pkgrel=5
|
||||
pkgdesc="A collection of extensions to the Python distutils"
|
||||
arch=('any')
|
||||
license=('PSF')
|
||||
url="http://packages.python.org/distribute"
|
||||
depends=('python2')
|
||||
source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
|
||||
distribute-${pkgver}_python2_and_3.patch)
|
||||
sha1sums=('6bea50b97f36bf751548bb486a534204a690aa4d'
|
||||
'de635febfb11dc6878e5bdbac4a0e1d539c19d79')
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/distribute-${pkgver}
|
||||
patch -Np1 -i ../distribute-${pkgver}_python2_and_3.patch
|
||||
python2 setup.py install --prefix=/usr --root=${pkgdir}
|
||||
}
|
||||
# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
|
|
@ -0,0 +1,51 @@
|
|||
diff -Naur distribute-0.6.14.ori//distribute.egg-info/entry_points.txt distribute-0.6.14/distribute.egg-info/entry_points.txt
|
||||
--- distribute-0.6.14.ori//distribute.egg-info/entry_points.txt 2010-07-14 20:14:10.000000000 -0400
|
||||
+++ distribute-0.6.14/distribute.egg-info/entry_points.txt 2010-10-21 09:26:43.386667396 -0400
|
||||
@@ -31,7 +31,8 @@
|
||||
depends.txt = setuptools.command.egg_info:warn_depends_obsolete
|
||||
|
||||
[console_scripts]
|
||||
-easy_install = setuptools.command.easy_install:main
|
||||
+easy_install-3.1 = setuptools.command.easy_install:main
|
||||
+easy_install-2.7 = setuptools.command.easy_install:main
|
||||
easy_install-2.6 = setuptools.command.easy_install:main
|
||||
|
||||
[setuptools.file_finders]
|
||||
diff -Naur distribute-0.6.14.ori//distribute_setup.py distribute-0.6.14/distribute_setup.py
|
||||
--- distribute-0.6.14.ori//distribute_setup.py 2010-07-14 19:53:38.000000000 -0400
|
||||
+++ distribute-0.6.14/distribute_setup.py 2010-10-21 09:25:18.356667404 -0400
|
||||
@@ -299,8 +299,7 @@
|
||||
log.warn('Could not find the install location')
|
||||
return
|
||||
pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
|
||||
- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
|
||||
- (SETUPTOOLS_FAKED_VERSION, pyver)
|
||||
+ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
|
||||
pkg_info = os.path.join(placeholder, setuptools_file)
|
||||
if os.path.exists(pkg_info):
|
||||
log.warn('%s already exists', pkg_info)
|
||||
diff -Naur distribute-0.6.14.ori//setup.py distribute-0.6.14/setup.py
|
||||
--- distribute-0.6.14.ori//setup.py 2010-07-14 19:53:38.000000000 -0400
|
||||
+++ distribute-0.6.14/setup.py 2010-10-21 09:32:44.850000736 -0400
|
||||
@@ -96,6 +96,8 @@
|
||||
f.close()
|
||||
|
||||
|
||||
+console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
|
||||
+
|
||||
# if we are installing Distribute using "python setup.py install"
|
||||
# we need to get setuptools out of the way
|
||||
def _easy_install_marker():
|
||||
@@ -182,11 +184,7 @@
|
||||
"dependency_links.txt = setuptools.command.egg_info:overwrite_arg",
|
||||
],
|
||||
|
||||
- "console_scripts": [
|
||||
- "easy_install = setuptools.command.easy_install:main",
|
||||
- "easy_install-%s = setuptools.command.easy_install:main"
|
||||
- % sys.version[:3]
|
||||
- ],
|
||||
+ "console_scripts": console_scripts,
|
||||
|
||||
"setuptools.file_finders":
|
||||
["svn_cvs = setuptools.command.sdist:_default_revctrl"],
|
Loading…
Reference in a new issue