mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/llvm to 3.9.0-1
This commit is contained in:
parent
419b014a0b
commit
ddd77c8def
4 changed files with 123 additions and 1581 deletions
|
@ -1,322 +0,0 @@
|
|||
Index: cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
===================================================================
|
||||
--- cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
+++ cfe/trunk/docs/ItaniumMangleAbiTags.rst
|
||||
@@ -0,0 +1,101 @@
|
||||
+========
|
||||
+ABI tags
|
||||
+========
|
||||
+
|
||||
+Introduction
|
||||
+============
|
||||
+
|
||||
+This text tries to describe gcc semantic for mangling "abi_tag" attributes
|
||||
+described in https://gcc.gnu.org/onlinedocs/gcc/C_002b_002b-Attributes.html
|
||||
+
|
||||
+There is no guarantee the following rules are correct, complete or make sense
|
||||
+in any way as they were determined empirically by experiments with gcc5.
|
||||
+
|
||||
+Declaration
|
||||
+===========
|
||||
+
|
||||
+ABI tags are declared in an abi_tag attribute and can be applied to a
|
||||
+function, variable, class or inline namespace declaration. The attribute takes
|
||||
+one or more strings (called tags); the order does not matter.
|
||||
+
|
||||
+See https://gcc.gnu.org/onlinedocs/gcc/C_002b_002b-Attributes.html for
|
||||
+details.
|
||||
+
|
||||
+Tags on an inline namespace are called "implicit tags", all other tags are
|
||||
+"explicit tags".
|
||||
+
|
||||
+Mangling
|
||||
+========
|
||||
+
|
||||
+All tags that are "active" on an <unqualified-name> are emitted after the
|
||||
+<unqualified-name>, before <template-args> or <discriminator>, and are part of
|
||||
+the same <substitution> the <unqualified-name> is.
|
||||
+
|
||||
+They are mangled as:
|
||||
+
|
||||
+ <abi-tags> ::= <abi-tag>* # sort by name
|
||||
+ <abi-tag> ::= B <tag source-name>
|
||||
+
|
||||
+Example:
|
||||
+
|
||||
+ __attribute__((abi_tag("test")))
|
||||
+ void Func();
|
||||
+
|
||||
+ gets mangled as: _Z4FuncB4testv (prettified as `Func[abi:test]()`)
|
||||
+
|
||||
+Active tags
|
||||
+===========
|
||||
+
|
||||
+A namespace does not have any active tags. For types (class / struct / union /
|
||||
+enum), the explicit tags are the active tags.
|
||||
+
|
||||
+For variables and functions, the active tags are the explicit tags plus any
|
||||
+"required tags" which are not in the "available tags" set:
|
||||
+
|
||||
+ derived-tags := (required-tags - available-tags)
|
||||
+ active-tags := explicit-tags + derived-tags
|
||||
+
|
||||
+Required tags for a function
|
||||
+============================
|
||||
+
|
||||
+If a function is used as a local scope for another name, and is part of
|
||||
+another function as local scope, it doesn't have any required tags.
|
||||
+
|
||||
+If a function is used as a local scope for a guard variable name, it doesn't
|
||||
+have any required tags.
|
||||
+
|
||||
+Otherwise the function requires any implicit or explicit tag used in the name
|
||||
+for the return type.
|
||||
+
|
||||
+Example:
|
||||
+ namespace A {
|
||||
+ inline namespace B __attribute__((abi_tag)) {
|
||||
+ struct C { int x; };
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
+ A::C foo();
|
||||
+
|
||||
+ gets mangled as: _Z3fooB1Bv (prettified as `foo[abi:B]()`)
|
||||
+
|
||||
+Required tags for a variable
|
||||
+============================
|
||||
+
|
||||
+A variable requires any implicit or explicit tag used in its type.
|
||||
+
|
||||
+Available tags
|
||||
+==============
|
||||
+
|
||||
+All tags used in the prefix and in the template arguments for a name are
|
||||
+available. Also, for functions, all tags from the <bare-function-type>
|
||||
+(which might include the return type for template functions) are available.
|
||||
+
|
||||
+For <local-name>s all active tags used in the local part (<function-
|
||||
+encoding>) are available, but not implicit tags which were not active.
|
||||
+
|
||||
+Implicit and explicit tags used in the <unqualified-name> for a function (as
|
||||
+in the type of a cast operator) are NOT available.
|
||||
+
|
||||
+Example: a cast operator to std::string (which is
|
||||
+std::__cxx11::basic_string<...>) will use 'cxx11' as an active tag, as it is
|
||||
+required from the return type `std::string` but not available.
|
||||
Index: cfe/trunk/include/clang/Basic/Attr.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/Attr.td
|
||||
+++ cfe/trunk/include/clang/Basic/Attr.td
|
||||
@@ -358,6 +358,14 @@
|
||||
// Attributes begin here
|
||||
//
|
||||
|
||||
+def AbiTag : Attr {
|
||||
+ let Spellings = [GCC<"abi_tag">];
|
||||
+ let Args = [VariadicStringArgument<"Tags">];
|
||||
+ let Subjects = SubjectList<[Struct, Var, Function, Namespace], ErrorDiag,
|
||||
+ "ExpectedStructClassVariableFunctionOrInlineNamespace">;
|
||||
+ let Documentation = [AbiTagsDocs];
|
||||
+}
|
||||
+
|
||||
def AddressSpace : TypeAttr {
|
||||
let Spellings = [GNU<"address_space">];
|
||||
let Args = [IntArgument<"AddressSpace">];
|
||||
Index: cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
+++ cfe/trunk/include/clang/Basic/AttrDocs.td
|
||||
@@ -2132,3 +2132,16 @@
|
||||
optimizations like C++'s named return value optimization (NRVO).
|
||||
}];
|
||||
}
|
||||
+
|
||||
+def AbiTagsDocs : Documentation {
|
||||
+ let Content = [{
|
||||
+The ``abi_tag`` attribute can be applied to a function, variable, class or
|
||||
+inline namespace declaration to modify the mangled name of the entity. It gives
|
||||
+the ability to distinguish between different versions of the same entity but
|
||||
+with different ABI versions supported. For example, a newer version of a class
|
||||
+could have a different set of data members and thus have a different size. Using
|
||||
+the ``abi_tag`` attribute, it is possible to have different mangled names for
|
||||
+a global variable of the class type. Therefor, the old code could keep using
|
||||
+the old manged name and the new code will use the new mangled name with tags.
|
||||
+ }];
|
||||
+}
|
||||
Index: cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
+++ cfe/trunk/include/clang/Basic/DiagnosticSemaKinds.td
|
||||
@@ -2477,7 +2477,8 @@
|
||||
"Objective-C instance methods|init methods of interface or class extension declarations|"
|
||||
"variables, functions and classes|Objective-C protocols|"
|
||||
"functions and global variables|structs, unions, and typedefs|structs and typedefs|"
|
||||
- "interface or protocol declarations|kernel functions|non-K&R-style functions}1">,
|
||||
+ "interface or protocol declarations|kernel functions|non-K&R-style functions|"
|
||||
+ "structs, classes, variables, functions, and inline namespaces}1">,
|
||||
InGroup<IgnoredAttributes>;
|
||||
def err_attribute_wrong_decl_type : Error<warn_attribute_wrong_decl_type.Text>;
|
||||
def warn_type_attribute_wrong_type : Warning<
|
||||
@@ -4195,6 +4196,13 @@
|
||||
def err_redefinition_extern_inline : Error<
|
||||
"redefinition of a 'extern inline' function %0 is not supported in "
|
||||
"%select{C99 mode|C++}1">;
|
||||
+def warn_attr_abi_tag_namespace : Warning<
|
||||
+ "'abi_tag' attribute on %select{non-inline|anonymous}0 namespace ignored">,
|
||||
+ InGroup<IgnoredAttributes>;
|
||||
+def err_abi_tag_on_redeclaration : Error<
|
||||
+ "cannot add 'abi_tag' attribute in a redeclaration">;
|
||||
+def err_new_abi_tag_on_redeclaration : Error<
|
||||
+ "'abi_tag' %0 missing in original declaration">;
|
||||
|
||||
def note_deleted_dtor_no_operator_delete : Note<
|
||||
"virtual destructor requires an unambiguous, accessible 'operator delete'">;
|
||||
Index: cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
===================================================================
|
||||
--- cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
+++ cfe/trunk/include/clang/Sema/AttributeList.h
|
||||
@@ -895,7 +895,8 @@
|
||||
ExpectedStructOrTypedef,
|
||||
ExpectedObjectiveCInterfaceOrProtocol,
|
||||
ExpectedKernelFunction,
|
||||
- ExpectedFunctionWithProtoType
|
||||
+ ExpectedFunctionWithProtoType,
|
||||
+ ExpectedStructClassVariableFunctionOrInlineNamespace
|
||||
};
|
||||
|
||||
} // end namespace clang
|
||||
Index: cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
+++ cfe/trunk/lib/Sema/SemaDecl.cpp
|
||||
@@ -2398,6 +2398,24 @@
|
||||
}
|
||||
}
|
||||
|
||||
+ // Re-declaration cannot add abi_tag's.
|
||||
+ if (const auto *NewAbiTagAttr = New->getAttr<AbiTagAttr>()) {
|
||||
+ if (const auto *OldAbiTagAttr = Old->getAttr<AbiTagAttr>()) {
|
||||
+ for (const auto &NewTag : NewAbiTagAttr->tags()) {
|
||||
+ if (std::find(OldAbiTagAttr->tags_begin(), OldAbiTagAttr->tags_end(),
|
||||
+ NewTag) == OldAbiTagAttr->tags_end()) {
|
||||
+ Diag(NewAbiTagAttr->getLocation(),
|
||||
+ diag::err_new_abi_tag_on_redeclaration)
|
||||
+ << NewTag;
|
||||
+ Diag(OldAbiTagAttr->getLocation(), diag::note_previous_declaration);
|
||||
+ }
|
||||
+ }
|
||||
+ } else {
|
||||
+ Diag(NewAbiTagAttr->getLocation(), diag::err_abi_tag_on_redeclaration);
|
||||
+ Diag(Old->getLocation(), diag::note_previous_declaration);
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
if (!Old->hasAttrs())
|
||||
return;
|
||||
|
||||
Index: cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
+++ cfe/trunk/lib/Sema/SemaDeclAttr.cpp
|
||||
@@ -4615,6 +4615,42 @@
|
||||
Attr.getRange(), S.Context, Attr.getAttributeSpellingListIndex()));
|
||||
}
|
||||
|
||||
+static void handleAbiTagAttr(Sema &S, Decl *D, const AttributeList &Attr) {
|
||||
+ SmallVector<std::string, 4> Tags;
|
||||
+ for (unsigned I = 0, E = Attr.getNumArgs(); I != E; ++I) {
|
||||
+ StringRef Tag;
|
||||
+ if (!S.checkStringLiteralArgumentAttr(Attr, I, Tag))
|
||||
+ return;
|
||||
+ Tags.push_back(Tag);
|
||||
+ }
|
||||
+
|
||||
+ if (const auto *NS = dyn_cast<NamespaceDecl>(D)) {
|
||||
+ if (!NS->isInline()) {
|
||||
+ S.Diag(Attr.getLoc(), diag::warn_attr_abi_tag_namespace) << 0;
|
||||
+ return;
|
||||
+ }
|
||||
+ if (NS->isAnonymousNamespace()) {
|
||||
+ S.Diag(Attr.getLoc(), diag::warn_attr_abi_tag_namespace) << 1;
|
||||
+ return;
|
||||
+ }
|
||||
+ if (Attr.getNumArgs() == 0)
|
||||
+ Tags.push_back(NS->getName());
|
||||
+ } else if (!checkAttributeAtLeastNumArgs(S, Attr, 1))
|
||||
+ return;
|
||||
+
|
||||
+ // Store tags sorted and without duplicates.
|
||||
+ std::sort(Tags.begin(), Tags.end());
|
||||
+ Tags.erase(std::unique(Tags.begin(), Tags.end()), Tags.end());
|
||||
+
|
||||
+ D->addAttr(::new (S.Context)
|
||||
+ AbiTagAttr(Attr.getRange(), S.Context, Tags.data(), Tags.size(),
|
||||
+ Attr.getAttributeSpellingListIndex()));
|
||||
+
|
||||
+ // FIXME: remove this warning as soon as mangled part is ready.
|
||||
+ S.Diag(Attr.getRange().getBegin(), diag::warn_attribute_ignored)
|
||||
+ << Attr.getName();
|
||||
+}
|
||||
+
|
||||
static void handleARMInterruptAttr(Sema &S, Decl *D,
|
||||
const AttributeList &Attr) {
|
||||
// Check the attribute arguments.
|
||||
@@ -5637,6 +5673,9 @@
|
||||
case AttributeList::AT_Thread:
|
||||
handleDeclspecThreadAttr(S, D, Attr);
|
||||
break;
|
||||
+ case AttributeList::AT_AbiTag:
|
||||
+ handleAbiTagAttr(S, D, Attr);
|
||||
+ break;
|
||||
|
||||
// Thread safety attributes:
|
||||
case AttributeList::AT_AssertExclusiveLock:
|
||||
Index: cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
===================================================================
|
||||
--- cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
+++ cfe/trunk/test/SemaCXX/attr-abi-tag-syntax.cpp
|
||||
@@ -0,0 +1,43 @@
|
||||
+// RUN: %clang_cc1 -std=c++11 -fsyntax-only -verify %s
|
||||
+
|
||||
+namespace N1 {
|
||||
+
|
||||
+namespace __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on non-inline namespace ignored}}
|
||||
+
|
||||
+namespace N __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on non-inline namespace ignored}}
|
||||
+
|
||||
+} // namespace N1
|
||||
+
|
||||
+namespace N2 {
|
||||
+
|
||||
+inline namespace __attribute__((__abi_tag__)) {}
|
||||
+// expected-warning@-1 {{'abi_tag' attribute on anonymous namespace ignored}}
|
||||
+
|
||||
+inline namespace N __attribute__((__abi_tag__)) {}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-2 {{'__abi_tag__' attribute ignored}}
|
||||
+
|
||||
+} // namespcace N2
|
||||
+
|
||||
+__attribute__((abi_tag("B", "A"))) extern int a1;
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-2 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+__attribute__((abi_tag("A", "B"))) extern int a1;
|
||||
+// expected-note@-1 {{previous declaration is here}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+__attribute__((abi_tag("A", "C"))) extern int a1;
|
||||
+// expected-error@-1 {{'abi_tag' C missing in original declaration}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
||||
+
|
||||
+extern int a2;
|
||||
+// expected-note@-1 {{previous declaration is here}}
|
||||
+__attribute__((abi_tag("A")))extern int a2;
|
||||
+// expected-error@-1 {{cannot add 'abi_tag' attribute in a redeclaration}}
|
||||
+// FIXME: remove this warning as soon as attribute fully supported.
|
||||
+// expected-warning@-3 {{'abi_tag' attribute ignored}}
|
File diff suppressed because it is too large
Load diff
|
@ -16,9 +16,9 @@
|
|||
# - v8: disable lldb, unsupported architecture
|
||||
|
||||
pkgname=('llvm' 'llvm-libs' 'llvm-ocaml' 'lldb' 'clang' 'clang-tools-extra')
|
||||
pkgver=3.8.1
|
||||
pkgver=3.9.0
|
||||
pkgrel=1
|
||||
_ocaml_ver=4.02.3
|
||||
_ocaml_ver=4.03.0
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://llvm.org/"
|
||||
license=('custom:University of Illinois/NCSA Open Source License')
|
||||
|
@ -32,26 +32,23 @@ source=(http://llvm.org/releases/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
|
|||
http://llvm.org/releases/$pkgver/clang-tools-extra-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/compiler-rt-$pkgver.src.tar.xz{,.sig}
|
||||
http://llvm.org/releases/$pkgver/lldb-$pkgver.src.tar.xz{,.sig}
|
||||
D17567-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
|
||||
D18035-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
|
||||
msan-prevent-initialization-failure-with-newer-glibc.patch
|
||||
llvm-Config-llvm-config.h
|
||||
remove-threadpool.patch)
|
||||
sha256sums=('6e82ce4adb54ff3afc18053d6981b6aed1406751b8742582ed50f04b5ab475f9'
|
||||
sha256sums=('66c73179da42cee1386371641241f79ded250e117a79f571bbd69e56daa48948'
|
||||
'SKIP'
|
||||
'4cd3836dfb4b88b597e075341cae86d61c63ce3963e45c7fe6a8bf59bb382cdf'
|
||||
'7596a7c7d9376d0c89e60028fe1ceb4d3e535e8ea8b89e0eb094e0dcb3183d28'
|
||||
'SKIP'
|
||||
'664a5c60220de9c290bf2a5b03d902ab731a4f95fe73a00856175ead494ec396'
|
||||
'5b7aec46ec8e999ec683c87ad744082e1133781ee4b01905b4bdae5d20785f14'
|
||||
'SKIP'
|
||||
'0df011dae14d8700499dfc961602ee0a9572fef926202ade5dcdfe7858411e5c'
|
||||
'e0e5224fcd5740b61e416c549dd3dcda92f10c524216c1edb5e979e42078a59a'
|
||||
'SKIP'
|
||||
'349148116a47e39dcb5d5042f10d8a6357d2c865034563283ca512f81cdce8a3'
|
||||
'61280e07411e3f2b4cca0067412b39c16b0a9edd19d304d3fc90249899d12384'
|
||||
'SKIP'
|
||||
'406754764e83d58bc3b859ab4b7893abd48c760278c4619cf4341ef9b9b75c85'
|
||||
'd71f8677882c86accddb8a5b720f298a4d7a2ad3bce6091951a46396b8f14da1'
|
||||
'8e4f194c2283b91644a7fff43bc4e58c36b5507f2a4d90b72f275c0bd7511c20'
|
||||
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48'
|
||||
'ea686a21076aeefdb81af22ab7e5d786e4f6d490507320275f443d8bcf663040')
|
||||
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D'
|
||||
'11E521D646982372EB577A1F8F0871F202119294')
|
||||
validpgpkeys=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/llvm-$pkgver.src"
|
||||
|
@ -66,9 +63,8 @@ prepare() {
|
|||
|
||||
[[ $CARCH != 'aarch64' && $CARCH != 'arm' ]] && mv "$srcdir/lldb-$pkgver.src" tools/lldb
|
||||
|
||||
# https://llvm.org/bugs/show_bug.cgi?id=23529
|
||||
patch -d tools/clang -Np2 <../D17567-PR23529-Sema-part-of-attrbute-abi_tag-support.patch
|
||||
patch -d tools/clang -Np0 <../D18035-PR23529-Mangler-part-of-attrbute-abi_tag-support.patch
|
||||
# https://reviews.llvm.org/D24736
|
||||
patch -Np0 -d projects/compiler-rt <../msan-prevent-initialization-failure-with-newer-glibc.patch
|
||||
|
||||
if [[ $CARCH == "arm" ]]; then
|
||||
patch -p1 -i ../remove-threadpool.patch
|
||||
|
@ -89,7 +85,6 @@ build() {
|
|||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DLLVM_BUILD_LLVM_DYLIB=ON \
|
||||
-DLLVM_DYLIB_EXPORT_ALL=ON \
|
||||
-DLLVM_LINK_LLVM_DYLIB=ON \
|
||||
-DLLVM_ENABLE_RTTI=ON \
|
||||
-DLLVM_ENABLE_FFI=ON \
|
||||
|
@ -97,6 +92,7 @@ build() {
|
|||
-DLLVM_BUILD_DOCS=ON \
|
||||
-DLLVM_ENABLE_SPHINX=ON \
|
||||
-DLLVM_ENABLE_DOXYGEN=OFF \
|
||||
-DLLDB_DISABLE_LIBEDIT=1 \
|
||||
-DSPHINX_WARNINGS_AS_ERRORS=OFF \
|
||||
-DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \
|
||||
-DLLVM_BINUTILS_INCDIR=/usr/include \
|
||||
|
@ -184,7 +180,7 @@ package_llvm-ocaml() {
|
|||
package_lldb() {
|
||||
pkgdesc="Next generation, high-performance debugger"
|
||||
url="http://lldb.llvm.org/"
|
||||
depends=('libedit' 'libxml2' 'python2' 'python2-six')
|
||||
depends=('libxml2' 'python2' 'python2-six')
|
||||
|
||||
[[ $CARCH == "aarch64" || $CARCH == "arm" ]] && return
|
||||
|
||||
|
@ -192,6 +188,10 @@ package_lldb() {
|
|||
|
||||
make -C build/tools/lldb DESTDIR="$pkgdir" install
|
||||
|
||||
# https://bugs.archlinux.org/task/50759
|
||||
sed -i "/import_module('_lldb')/s/_lldb/lldb.&/" \
|
||||
"$pkgdir/usr/lib/python2.7/site-packages/lldb/__init__.py"
|
||||
|
||||
# Remove bundled six library
|
||||
rm "$pkgdir/usr/lib/python2.7/site-packages/six.py"
|
||||
|
||||
|
@ -253,10 +253,8 @@ package_clang-tools-extra() {
|
|||
make -C build/tools/clang/tools/extra DESTDIR="$pkgdir" install
|
||||
|
||||
# Use Python 2
|
||||
sed -i \
|
||||
-e 's|env python$|&2|' \
|
||||
-e 's|/usr/bin/python$|&2|' \
|
||||
"$pkgdir"/usr/share/clang/{clang-tidy-diff,run-clang-tidy}.py
|
||||
sed -i 's|/usr/bin/env python|&2|' \
|
||||
"$pkgdir"/usr/share/clang/{clang-tidy-diff,run-clang-tidy,run-find-all-symbols}.py
|
||||
|
||||
install -Dm644 tools/clang/tools/extra/LICENSE.TXT \
|
||||
"$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
|
|
|
@ -0,0 +1,103 @@
|
|||
Index: lib/msan/msan_interceptors.cc
|
||||
===================================================================
|
||||
--- lib/msan/msan_interceptors.cc (revision 282231)
|
||||
+++ lib/msan/msan_interceptors.cc (revision 282232)
|
||||
@@ -64,6 +64,23 @@
|
||||
return in_interceptor_scope;
|
||||
}
|
||||
|
||||
+static uptr allocated_for_dlsym;
|
||||
+static const uptr kDlsymAllocPoolSize = 1024;
|
||||
+static uptr alloc_memory_for_dlsym[kDlsymAllocPoolSize];
|
||||
+
|
||||
+static bool IsInDlsymAllocPool(const void *ptr) {
|
||||
+ uptr off = (uptr)ptr - (uptr)alloc_memory_for_dlsym;
|
||||
+ return off < sizeof(alloc_memory_for_dlsym);
|
||||
+}
|
||||
+
|
||||
+static void *AllocateFromLocalPool(uptr size_in_bytes) {
|
||||
+ uptr size_in_words = RoundUpTo(size_in_bytes, kWordSize) / kWordSize;
|
||||
+ void *mem = (void *)&alloc_memory_for_dlsym[allocated_for_dlsym];
|
||||
+ allocated_for_dlsym += size_in_words;
|
||||
+ CHECK_LT(allocated_for_dlsym, kDlsymAllocPoolSize);
|
||||
+ return mem;
|
||||
+}
|
||||
+
|
||||
#define ENSURE_MSAN_INITED() do { \
|
||||
CHECK(!msan_init_is_running); \
|
||||
if (!msan_inited) { \
|
||||
@@ -227,7 +244,7 @@
|
||||
|
||||
INTERCEPTOR(void, free, void *ptr) {
|
||||
GET_MALLOC_STACK_TRACE;
|
||||
- if (!ptr) return;
|
||||
+ if (!ptr || UNLIKELY(IsInDlsymAllocPool(ptr))) return;
|
||||
MsanDeallocate(&stack, ptr);
|
||||
}
|
||||
|
||||
@@ -234,7 +251,7 @@
|
||||
#if !SANITIZER_FREEBSD
|
||||
INTERCEPTOR(void, cfree, void *ptr) {
|
||||
GET_MALLOC_STACK_TRACE;
|
||||
- if (!ptr) return;
|
||||
+ if (!ptr || UNLIKELY(IsInDlsymAllocPool(ptr))) return;
|
||||
MsanDeallocate(&stack, ptr);
|
||||
}
|
||||
#define MSAN_MAYBE_INTERCEPT_CFREE INTERCEPT_FUNCTION(cfree)
|
||||
@@ -907,27 +924,29 @@
|
||||
|
||||
INTERCEPTOR(void *, calloc, SIZE_T nmemb, SIZE_T size) {
|
||||
GET_MALLOC_STACK_TRACE;
|
||||
- if (UNLIKELY(!msan_inited)) {
|
||||
+ if (UNLIKELY(!msan_inited))
|
||||
// Hack: dlsym calls calloc before REAL(calloc) is retrieved from dlsym.
|
||||
- const SIZE_T kCallocPoolSize = 1024;
|
||||
- static uptr calloc_memory_for_dlsym[kCallocPoolSize];
|
||||
- static SIZE_T allocated;
|
||||
- SIZE_T size_in_words = ((nmemb * size) + kWordSize - 1) / kWordSize;
|
||||
- void *mem = (void*)&calloc_memory_for_dlsym[allocated];
|
||||
- allocated += size_in_words;
|
||||
- CHECK(allocated < kCallocPoolSize);
|
||||
- return mem;
|
||||
- }
|
||||
+ return AllocateFromLocalPool(nmemb * size);
|
||||
return MsanCalloc(&stack, nmemb, size);
|
||||
}
|
||||
|
||||
INTERCEPTOR(void *, realloc, void *ptr, SIZE_T size) {
|
||||
GET_MALLOC_STACK_TRACE;
|
||||
+ if (UNLIKELY(IsInDlsymAllocPool(ptr))) {
|
||||
+ uptr offset = (uptr)ptr - (uptr)alloc_memory_for_dlsym;
|
||||
+ uptr copy_size = Min(size, kDlsymAllocPoolSize - offset);
|
||||
+ void *new_ptr = AllocateFromLocalPool(size);
|
||||
+ internal_memcpy(new_ptr, ptr, copy_size);
|
||||
+ return new_ptr;
|
||||
+ }
|
||||
return MsanReallocate(&stack, ptr, size, sizeof(u64), false);
|
||||
}
|
||||
|
||||
INTERCEPTOR(void *, malloc, SIZE_T size) {
|
||||
GET_MALLOC_STACK_TRACE;
|
||||
+ if (UNLIKELY(!msan_inited))
|
||||
+ // Hack: dlsym calls malloc before REAL(malloc) is retrieved from dlsym.
|
||||
+ return AllocateFromLocalPool(size);
|
||||
return MsanReallocate(&stack, nullptr, size, sizeof(u64), false);
|
||||
}
|
||||
|
||||
Index: lib/asan/asan_malloc_linux.cc
|
||||
===================================================================
|
||||
--- lib/asan/asan_malloc_linux.cc (revision 282231)
|
||||
+++ lib/asan/asan_malloc_linux.cc (revision 282232)
|
||||
@@ -78,7 +78,11 @@
|
||||
if (UNLIKELY(IsInDlsymAllocPool(ptr))) {
|
||||
uptr offset = (uptr)ptr - (uptr)alloc_memory_for_dlsym;
|
||||
uptr copy_size = Min(size, kDlsymAllocPoolSize - offset);
|
||||
- void *new_ptr = asan_malloc(size, &stack);
|
||||
+ void *new_ptr;
|
||||
+ if (UNLIKELY(!asan_inited))
|
||||
+ new_ptr = AllocateFromLocalPool(size);
|
||||
+ else
|
||||
+ new_ptr = asan_malloc(size, &stack);
|
||||
internal_memcpy(new_ptr, ptr, copy_size);
|
||||
return new_ptr;
|
||||
}
|
Loading…
Reference in a new issue