community/x42-plugins to 20180320-3

This commit is contained in:
Kevin Mihelich 2018-07-24 00:25:27 +00:00
parent 408e854839
commit ddeee9cc4a
2 changed files with 71 additions and 4 deletions

View file

@ -7,7 +7,7 @@
pkgname=x42-plugins
pkgver=20180320
pkgrel=2
pkgrel=3
pkgdesc="Collection of LV2 plugins"
arch=('x86_64')
url="https://github.com/x42/x42-plugins"
@ -15,8 +15,15 @@ license=('GPL')
depends=('jack' 'libglvnd' 'liblo' 'libltc' 'pango' 'zita-convolver')
makedepends=('gtk2' 'ftgl' 'ttf-freefont' 'lv2')
groups=('lv2-plugins' 'pro-audio')
source=("http://gareus.org/misc/${pkgname}/${pkgname}-${pkgver}.tar.xz")
sha512sums=('3e2f13179073b38e846e0855031e7f842b535ad13f64b309ca4da8c0738a77ab8b70e117edfa1a97263ff37d279a4d9a26950c1883507d8e710b8cd54061bb32')
source=("http://gareus.org/misc/${pkgname}/${pkgname}-${pkgver}.tar.xz"
'zita-convolver4.patch')
sha512sums=('3e2f13179073b38e846e0855031e7f842b535ad13f64b309ca4da8c0738a77ab8b70e117edfa1a97263ff37d279a4d9a26950c1883507d8e710b8cd54061bb32'
'15dd15c5552492e7cbaad08b7fd42a7778a03fa12838cc930c386cba30e22ce91d9335543b4b229d13514849c3ed221760176a1b95e0ce7d215247c11a05e628')
prepare() {
cd "${pkgname}-${pkgver}/convoLV2"
patch -Np1 -i ../../zita-convolver4.patch
}
build() {
cd "${pkgname}-${pkgver}"
@ -30,4 +37,3 @@ package() {
}
# vim:set ts=2 sw=2 et:

View file

@ -0,0 +1,61 @@
From f814f1ef95d3d4a89a1dbb8a8319879ad411f25f Mon Sep 17 00:00:00 2001
From: Robin Gareus <robin@gareus.org>
Date: Wed, 6 Jun 2018 19:22:43 +0200
Subject: [PATCH] Update for libzita-convolver-4 compatibility
---
Makefile | 2 +-
convolution.cc | 9 +++++++--
2 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 6d7f1a9..6e14710 100644
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ endif
ifeq ($(LIBZITACONVOLVER),)
ifeq ($(shell test -f /usr/include/zita-convolver.h -o -f /usr/local/include/zita-convolver.h || echo no ), no)
- $(error "libzita-convolver3, is required")
+ $(error "libzita-convolver3 or 4, is required")
endif
LOADLIBES += -lzita-convolver
endif
diff --git a/convolution.cc b/convolution.cc
index c3bea41..6ace44b 100644
--- a/convolution.cc
+++ b/convolution.cc
@@ -47,8 +47,8 @@
#include <samplerate.h>
#include "convolution.h"
-#if ZITA_CONVOLVER_MAJOR_VERSION != 3
-# error "This programs requires zita-convolver 3.x.x"
+#if ZITA_CONVOLVER_MAJOR_VERSION != 3 && ZITA_CONVOLVER_MAJOR_VERSION != 4
+# error "This programs requires zita-convolver 3 or 4"
#endif
#ifndef SRC_QUALITY // alternatives: SRC_SINC_FASTEST, SRC_SINC_MEDIUM_QUALITY, (SRC_ZERO_ORDER_HOLD, SRC_LINEAR)
@@ -344,7 +344,9 @@ int clv_initialize (
clv->convproc = new Convproc;
clv->convproc->set_options (options);
+#if ZITA_CONVOLVER_MAJOR_VERSION == 3
clv->convproc->set_density (clv->density);
+#endif
if (audiofile_read (clv->ir_fn, sample_rate, &p, &n_chan, &n_frames)) {
fprintf(stderr, "convoLV2: failed to read IR.\n");
@@ -379,6 +381,9 @@ int clv_initialize (
/*quantum*/ buffersize,
/*min-part*/ buffersize /* must be >= fragm */,
/*max-part*/ buffersize /* Convproc::MAXPART -> stich output every period */
+#if ZITA_CONVOLVER_MAJOR_VERSION == 4
+ , clv->density
+#endif
)) {
fprintf (stderr, "convoLV2: Cannot initialize convolution engine.\n");
goto errout;
--
2.18.0