mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/mesa to 10.2.7-1
This commit is contained in:
parent
2366d19040
commit
de0f5161e3
2 changed files with 29 additions and 3 deletions
|
@ -10,7 +10,7 @@
|
|||
|
||||
pkgbase=mesa
|
||||
pkgname=('mesa' 'mesa-libgl')
|
||||
pkgver=10.2.6
|
||||
pkgver=10.2.7
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('python2' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
|
@ -21,8 +21,8 @@ license=('custom')
|
|||
options=('!libtool')
|
||||
source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/MesaLib-${pkgver}.tar.bz2{,.sig}
|
||||
LICENSE)
|
||||
sha256sums=('193314d2adba98e43697d726739ac46b4299aae324fa1821aa226890c28ac806'
|
||||
SKIP
|
||||
sha256sums=('27b958063a4c002071f14ed45c7d2a1ee52cd85e4ac8876e8a1c273495a7d43f'
|
||||
'SKIP'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
|
||||
|
||||
build() {
|
||||
|
|
26
extra/mesa/llvm35.patch
Normal file
26
extra/mesa/llvm35.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
From 564821c917f4a9d5a0de2ee77b90b0cd85e3d3a6 Mon Sep 17 00:00:00 2001
|
||||
From: Aaron Watry <awatry@gmail.com>
|
||||
Date: Fri, 20 Jun 2014 19:13:30 -0500
|
||||
Subject: gallivm: Fix build after LLVM commit 211259
|
||||
|
||||
Signed-off-by: Aaron Watry <awatry@gmail.com>
|
||||
Reviewed-by: Tom Stellard <thomas.stellard@amd.com>
|
||||
|
||||
diff --git a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||
index df26883..413a0c2 100644
|
||||
--- a/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||
+++ b/src/gallium/auxiliary/gallivm/lp_bld_debug.cpp
|
||||
@@ -51,7 +51,9 @@
|
||||
#include <llvm/MC/MCInstPrinter.h>
|
||||
#include <llvm/MC/MCRegisterInfo.h>
|
||||
|
||||
-#if HAVE_LLVM >= 0x0303
|
||||
+#if HAVE_LLVM >= 0x0305
|
||||
+#define OwningPtr std::unique_ptr
|
||||
+#elif HAVE_LLVM >= 0x0303
|
||||
#include <llvm/ADT/OwningPtr.h>
|
||||
#endif
|
||||
|
||||
--
|
||||
cgit v0.10.2
|
||||
|
Loading…
Reference in a new issue