extra/meson to 0.63.2-1

This commit is contained in:
Kevin Mihelich 2022-09-04 01:26:21 +00:00
parent 8ccbdda01f
commit de3d6a97ca
3 changed files with 46 additions and 15 deletions

View file

@ -64,7 +64,7 @@ index 0d8bafb4b745..9e101ce63aa4 100644
# Xcode uses GCC_PREFIX_HEADER which only allows one file per target/executable. Precompiling various header files and
# applying a particular pch to each source file will require custom scripts (as a build phase) and build flags per each
diff --git a/mesonbuild/compilers/compilers.py b/mesonbuild/compilers/compilers.py
index 18ba6e951fe8..61b9cb40f406 100644
index 20e35ee6b1bc..4f18af7f3e5e 100644
--- a/mesonbuild/compilers/compilers.py
+++ b/mesonbuild/compilers/compilers.py
@@ -247,15 +247,17 @@ msvc_winlibs = ['kernel32.lib', 'user32.lib', 'gdi32.lib',
@ -103,7 +103,7 @@ index b38f626a820f..3f020e2cfd00 100644
'1': ['-optimize+'],
'2': ['-optimize+'],
diff --git a/mesonbuild/compilers/d.py b/mesonbuild/compilers/d.py
index 35ab02470545..f866af641ed7 100644
index 8e331ec359a1..ab42099ae74b 100644
--- a/mesonbuild/compilers/d.py
+++ b/mesonbuild/compilers/d.py
@@ -64,15 +64,17 @@ d_feature_args = {'gcc': {'unittest': '-funittest',
@ -170,10 +170,10 @@ index 5083ace7c72b..4ac9b92c60c2 100644
'g': ['-Og'],
'1': ['-O1'],
diff --git a/mesonbuild/compilers/mixins/compcert.py b/mesonbuild/compilers/mixins/compcert.py
index 5e2ba0de5000..71d138a9ec23 100644
index ce872002c341..78f4f9f13574 100644
--- a/mesonbuild/compilers/mixins/compcert.py
+++ b/mesonbuild/compilers/mixins/compcert.py
@@ -38,6 +38,7 @@ ccomp_buildtype_args = {
@@ -40,6 +40,7 @@ ccomp_buildtype_args = {
} # type: T.Dict[str, T.List[str]]
ccomp_optimization_args = {
@ -218,10 +218,10 @@ index 2698b393096a..9877a54ff4c8 100644
'g': ['/Od'],
'1': ['/O1'],
diff --git a/mesonbuild/compilers/mixins/ti.py b/mesonbuild/compilers/mixins/ti.py
index cbad3004fa66..c9028b8498c3 100644
index 9ee6f272f410..d2d7f3b55fdc 100644
--- a/mesonbuild/compilers/mixins/ti.py
+++ b/mesonbuild/compilers/mixins/ti.py
@@ -39,6 +39,7 @@ ti_buildtype_args = {
@@ -41,6 +41,7 @@ ti_buildtype_args = {
} # type: T.Dict[str, T.List[str]]
ti_optimization_args = {
@ -242,10 +242,10 @@ index f4f2f1e1d0c7..d3b01108192e 100644
'g': [], # No specific flag to optimize debugging, /Zi or /ZI will create debug information
'1': ['/O1'],
diff --git a/mesonbuild/compilers/mixins/xc16.py b/mesonbuild/compilers/mixins/xc16.py
index 243356105af6..917791c0e4ce 100644
index 3c8b68b3258a..27c4fbc05664 100644
--- a/mesonbuild/compilers/mixins/xc16.py
+++ b/mesonbuild/compilers/mixins/xc16.py
@@ -39,6 +39,7 @@ xc16_buildtype_args = {
@@ -41,6 +41,7 @@ xc16_buildtype_args = {
} # type: T.Dict[str, T.List[str]]
xc16_optimization_args = {
@ -278,7 +278,7 @@ index a2b57b872f4a..6515387d1639 100644
'g': [],
'1': ['-O'],
diff --git a/mesonbuild/coredata.py b/mesonbuild/coredata.py
index a82a9fa702cd..d37889b44a48 100644
index 916212aacf2d..90c212d5a3ed 100644
--- a/mesonbuild/coredata.py
+++ b/mesonbuild/coredata.py
@@ -693,34 +693,34 @@ class CoreData:

View file

@ -0,0 +1,25 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Sun, 4 Sep 2022 00:16:08 +0000
Subject: [PATCH] Add missing cdata update in genmarshal tests
Otherwise the test is flaky, as it may try to include a header that's
not generated yet.
---
test cases/frameworks/7 gnome/genmarshal/meson.build | 3 +++
1 file changed, 3 insertions(+)
diff --git a/test cases/frameworks/7 gnome/genmarshal/meson.build b/test cases/frameworks/7 gnome/genmarshal/meson.build
index 7686b4bbeab1..9a2cd7a0007d 100644
--- a/test cases/frameworks/7 gnome/genmarshal/meson.build
+++ b/test cases/frameworks/7 gnome/genmarshal/meson.build
@@ -39,6 +39,9 @@ foreach mlist : mlists
marshaller_c = marshallers[0]
marshaller_h = marshallers[1]
+ cdata = configuration_data()
+ cdata.set_quoted('MARSHALLER_HEADER', 'marshaller-@0@.h'.format(idx))
+
main_c = configure_file(input: 'main.c.in',
output: 'main-@0@.c'.format(idx),
configuration: cdata)

View file

@ -6,8 +6,8 @@
# - disable lto in arch-meson
pkgname=meson
pkgver=0.63.1
pkgrel=2
pkgver=0.63.2
pkgrel=1
pkgdesc='High productivity build system'
url='https://mesonbuild.com/'
arch=('any')
@ -18,15 +18,17 @@ checkdepends=('gcc-objc' 'vala' 'rust' 'gcc-fortran' 'mono' 'boost' 'qt5-base' '
'itstool' 'gtk3' 'java-environment=8' 'gtk-doc' 'llvm' 'clang' 'sdl2' 'graphviz'
'doxygen' 'vulkan-validation-layers' 'openssh' 'mercurial' 'gtk-sharp-2' 'qt5-tools'
'libwmf' 'valgrind' 'cmake' 'netcdf-fortran' 'openmpi' 'nasm' 'gnustep-base' 'libelf'
'python-pytest-xdist' 'python2-setuptools' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
'python-pytest-xdist' 'ldc' 'rust-bindgen' 'cuda' 'hotdoc')
source=(https://github.com/mesonbuild/meson/releases/download/${pkgver}/meson-${pkgver}.tar.gz{,.asc}
0001-Skip-broken-tests.patch
0002-compilers-Add-optimization-plain-option.patch
0003-Add-missing-cdata-update-in-genmarshal-tests.patch
arch-meson)
sha512sums=('25f96e18bcdbb6346c44d9f8e63035d6cb3d8f781cf43ac5530ddd6f8090f4d16d192f8d331240154602e92b498b410fabb1381dc5f39db1dfb9da05a964d44e'
sha512sums=('770d8d82502c5cd419123e09f6a445d2cbaea4463c5fa79f1497c868bf5defc5e5779a6e550ef5fcf75d57322d2b25b61574f4df0cbf001c4325c6abdbbc30b4'
'SKIP'
'b59d90b5466fcf877969a49982308b1c89f0f4521e4d3774a4531bb2c0093f46b5ea2ef569e32984632e6f9c7e91328bc3511978427b553ed8c97a64a52b79ff'
'9335dd98626ebddb1bbc6247c4ec8b1cd28c8b97e520d0e0d657671093b6bc6ca4399d2e06311ca9084b4920660aa48b29402fb2aae946c7e5e44d90cd970e8c'
'cb53d50775c4d6c1278be73f123bd5ce80aec21bb2790289285add4052e57c4d3885b693a44f671a8e1ab8a9af40b782add5c723924a5892d71807354562dbd0'
'a13b2d6e4b594fbd34fe19c6e077076b062145500451089a44365407045a76fb5ad5449a3b23d8d7a8d18f7ab061abd4874c815d9fa2e7d7a5f4d288339f1128'
'278f5e4de3aa1170d9b4f9f212985d664f44d90ffec727febeeea1ed570046c6469558a5d123a41bf4c2fdf99dbe7832515b06f1ace423c63e2e95ba6d0ef235')
validpgpkeys=('19E2D6D9B46D8DAA6288F877C24E631BABB1FE70') # Jussi Pakkanen <jpakkane@gmail.com>
@ -37,6 +39,10 @@ prepare() {
# Fix buildtype plain to not add -O0
# https://github.com/mesonbuild/meson/pull/10593
patch -Np1 -i ../0002-compilers-Add-optimization-plain-option.patch
# Fix flaky test
# https://github.com/mesonbuild/meson/pull/10772
patch -Np1 -i ../0003-Add-missing-cdata-update-in-genmarshal-tests.patch
}
build() {
@ -47,7 +53,7 @@ build() {
check() (
cd ${pkgname}-${pkgver}
export LC_CTYPE=en_US.UTF-8 CPPFLAGS= CFLAGS= CXXFLAGS= LDFLAGS=
./run_tests.py
./run_tests.py --failfast
)
package() {