extra/ruby to 2.1.2-1

This commit is contained in:
Kevin Mihelich 2014-05-09 20:44:46 +00:00
parent 5f397e743a
commit df20cd31d4
2 changed files with 3 additions and 36 deletions

View file

@ -1,26 +0,0 @@
From 4c4da3fc650a3595ecc06f49072f1ffae07db706 Mon Sep 17 00:00:00 2001
From: Thomas Dziedzic <gostrc@gmail.com>
Date: Sat, 1 Mar 2014 21:41:28 -0800
Subject: [PATCH] Fix undeclared identifier error by using the actual type of
rl_pre_input_hook
---
ext/readline/readline.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/ext/readline/readline.c b/ext/readline/readline.c
index 659adb9..7bc0eed 100644
--- a/ext/readline/readline.c
+++ b/ext/readline/readline.c
@@ -1974,7 +1974,7 @@ Init_readline()
rl_attempted_completion_function = readline_attempted_completion_function;
#if defined(HAVE_RL_PRE_INPUT_HOOK)
- rl_pre_input_hook = (Function *)readline_pre_input_hook;
+ rl_pre_input_hook = (rl_hook_func_t *)readline_pre_input_hook;
#endif
#ifdef HAVE_RL_CATCH_SIGNALS
rl_catch_signals = 0;
--
1.9.0

View file

@ -4,12 +4,11 @@
# Contributor: Jeramy Rutley <jrutley@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch to fix building against readline 6.3
# - patch to fix running ruby on v5 (#705)
pkgname=('ruby' 'ruby-docs')
pkgver=2.1.1
pkgrel=2
pkgver=2.1.2
pkgrel=1
arch=('i686' 'x86_64')
url='http://www.ruby-lang.org/en/'
license=('BSD' 'custom')
@ -20,20 +19,14 @@ makedepends=('gdbm' 'openssl' 'libffi' 'doxygen' 'graphviz' 'libyaml') # 'tk'
options=('!emptydirs' '!makeflags' 'staticlibs')
source=("http://cache.ruby-lang.org/pub/ruby/${pkgver:0:3}/ruby-${pkgver}.tar.bz2"
'gemrc'
'0001-Fix-undeclared-identifier-error-by-using-the-actual-.patch'
'0002-Use-only-unsigned-long-for-rb_serial_t.patch')
md5sums=('1546eeb763ac7754365664be763a1e8f'
md5sums=('29a615966c7feb6554be736e7dcd590c770ee692'
'6fb8e7a09955e0f64be3158fb4a27e7a'
'0496e962e0ce11507b7577a8eb93af58'
'f6f9c200c5e9afc4d5b21575da4821a2')
build() {
cd ruby-${pkgver}
# readline 6.3 doesn't define Function anymore
# https://bugs.ruby-lang.org/issues/9578
patch -Np1 -i ${srcdir}/0001-Fix-undeclared-identifier-error-by-using-the-actual-.patch
# fixes https://bugs.ruby-lang.org/issues/9507
[[ $CARCH == 'arm' ]] && patch -Np1 -i ../0002-Use-only-unsigned-long-for-rb_serial_t.patch