community/mplayer-vaapi to 36265-12

This commit is contained in:
Kevin Mihelich 2014-08-18 11:07:17 +00:00
parent 7aee6d8752
commit df3f78e69e
2 changed files with 21 additions and 3 deletions

View file

@ -8,7 +8,7 @@
pkgname=mplayer-vaapi
pkgver=36265
pkgrel=11
pkgrel=12
pkgdesc="A movie player, compiled with vaapi support"
arch=('i686' 'x86_64')
url="http://gitorious.org/vaapi/mplayer"
@ -26,14 +26,16 @@ backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
source=(http://pkgbuild.com/~foutrelis/sources/$pkgname/$pkgname-$pkgver.tar.xz{,.sig}
cdio-includes.patch
tweak-desktop-file.patch
subreader-fix-srt-parsing.patch)
subreader-fix-srt-parsing.patch
include-samba-4.0.patch)
options=('!buildflags' '!emptydirs')
install=mplayer-vaapi.install
sha256sums=('5747c28c30c15d1000fb655a8abaa4b22483746d0e82775b27466948ae0c549a'
'SKIP'
'72e6c654f9733953ad2466d0ea1a52f23e753791d8232d90f13293eb1b358720'
'5a09fb462729a4e573568f9e8c1f57dbe7f69c0b68cfa4f6d70b3e52c450d93b'
'8b6cd325d89ff8bce3662c6aaa9b61b8e6163c6574e09b575426a1eed02b8ad3')
'8b6cd325d89ff8bce3662c6aaa9b61b8e6163c6574e09b575426a1eed02b8ad3'
'169eb47b3b838ea95e50c871bdbbfb6fe0b9349b054da830f55f3b4d5055e4f3')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@ -43,6 +45,9 @@ prepare() {
# http://bugzilla.mplayerhq.hu/show_bug.cgi?id=2139
patch -Np0 -i "$srcdir/subreader-fix-srt-parsing.patch"
# https://bugs.archlinux.org/task/41588
patch -Np1 -i "$srcdir/include-samba-4.0.patch"
}
build() {
@ -64,6 +69,7 @@ build() {
--enable-xvmc \
--enable-radio \
--enable-radio-capture \
--enable-smb \
--disable-vdpau \
--enable-vaapi \
--language=all \

View file

@ -0,0 +1,12 @@
diff -rupN a/stream/stream_smb.c b/stream/stream_smb.c
--- a/stream/stream_smb.c 2013-03-16 13:38:34.000000000 +0000
+++ b/stream/stream_smb.c 2013-10-31 20:05:32.473947926 +0000
@@ -18,7 +18,7 @@
#include "config.h"
-#include <libsmbclient.h>
+#include <samba-4.0/libsmbclient.h>
#include <unistd.h>
#include "mp_msg.h"