mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
core/linux-aarch64 to 4.13.0-1
This commit is contained in:
parent
5958fae784
commit
df51245dc2
6 changed files with 430 additions and 111 deletions
|
@ -1,14 +1,14 @@
|
|||
From 7e89ba6ecc97cfc35857e84004105d63808c5cd7 Mon Sep 17 00:00:00 2001
|
||||
From 30d7acb45632070aa9929baa68aff42a5fcb1643 Mon Sep 17 00:00:00 2001
|
||||
From: popcornmix <popcornmix@gmail.com>
|
||||
Date: Tue, 18 Feb 2014 01:43:50 -0300
|
||||
Subject: [PATCH] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
Subject: [PATCH 1/4] net/smsc95xx: Allow mac address to be set as a parameter
|
||||
|
||||
---
|
||||
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 56 insertions(+)
|
||||
|
||||
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
|
||||
index 831aa33d078a..03625547d794 100644
|
||||
index 340c13484e5c..ae49ded12f6c 100644
|
||||
--- a/drivers/net/usb/smsc95xx.c
|
||||
+++ b/drivers/net/usb/smsc95xx.c
|
||||
@@ -60,6 +60,7 @@
|
||||
|
@ -30,7 +30,7 @@ index 831aa33d078a..03625547d794 100644
|
|||
static int __must_check __smsc95xx_read_reg(struct usbnet *dev, u32 index,
|
||||
u32 *data, int in_pm)
|
||||
{
|
||||
@@ -910,8 +915,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
@@ -911,8 +916,59 @@ static int smsc95xx_ioctl(struct net_device *netdev, struct ifreq *rq, int cmd)
|
||||
return generic_mii_ioctl(&dev->mii, if_mii(rq), cmd, NULL);
|
||||
}
|
||||
|
||||
|
@ -91,5 +91,5 @@ index 831aa33d078a..03625547d794 100644
|
|||
|
||||
/* maybe the boot loader passed the MAC address in devicetree */
|
||||
--
|
||||
2.11.1
|
||||
2.14.1
|
||||
|
||||
|
|
|
@ -0,0 +1,42 @@
|
|||
From 08b91100c5dc3f294ace4d92d5c29ce8b2ff2e6d Mon Sep 17 00:00:00 2001
|
||||
From: Shawn Lin <shawn.lin@rock-chips.com>
|
||||
Date: Fri, 21 Jul 2017 16:30:59 +0800
|
||||
Subject: [PATCH 2/4] arm64: dts: rockchip: enable sdmmc controller on
|
||||
rk3399-firefly
|
||||
|
||||
This allows basic support for SD highspeed cards but no UHS-I mode
|
||||
got ready due to the propagated defer-probe error from RK805.
|
||||
|
||||
Cc: Kever Yang <kever.yang@rock-chips.com>
|
||||
Signed-off-by: Shawn Lin <shawn.lin@rock-chips.com>
|
||||
Signed-off-by: Heiko Stuebner <heiko@sntech.de>
|
||||
---
|
||||
arch/arm64/boot/dts/rockchip/rk3399-firefly.dts | 12 ++++++++++++
|
||||
1 file changed, 12 insertions(+)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
index ba1d9810ad1e..e01ef8a77f5e 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
@@ -630,6 +630,18 @@
|
||||
status = "okay";
|
||||
};
|
||||
|
||||
+&sdmmc {
|
||||
+ bus-width = <4>;
|
||||
+ cap-mmc-highspeed;
|
||||
+ cap-sd-highspeed;
|
||||
+ cd-gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
|
||||
+ disable-wp;
|
||||
+ max-frequency = <150000000>;
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&sdmmc_clk &sdmmc_cmd &sdmmc_bus4>;
|
||||
+ status = "okay";
|
||||
+};
|
||||
+
|
||||
&sdhci {
|
||||
bus-width = <8>;
|
||||
keep-power-in-suspend;
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -0,0 +1,26 @@
|
|||
From 05a27b58acc1caa8c4f80bc9dd46c100abd35244 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Mon, 7 Aug 2017 19:34:57 -0600
|
||||
Subject: [PATCH 3/4] arm64: dts: rockchip: disable pwm0 on rk3399-firefly
|
||||
|
||||
Workaround for intermittent boot hangs due to pwm0 probe disabling the PWM clock.
|
||||
---
|
||||
arch/arm64/boot/dts/rockchip/rk3399-firefly.dts | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
index e01ef8a77f5e..1fd4e87c61d5 100644
|
||||
--- a/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
+++ b/arch/arm64/boot/dts/rockchip/rk3399-firefly.dts
|
||||
@@ -618,7 +618,7 @@
|
||||
};
|
||||
|
||||
&pwm0 {
|
||||
- status = "okay";
|
||||
+ status = "disabled";
|
||||
};
|
||||
|
||||
&pwm2 {
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -0,0 +1,145 @@
|
|||
From 0c9149a1813b56d043fa3db8f8591f0b2677ee50 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Thu, 17 Aug 2017 21:18:11 -0600
|
||||
Subject: [PATCH 4/4] Revert "arm64: dts: qcom: Collapse usb support into one
|
||||
node"
|
||||
|
||||
This reverts commit ed75d6a969056cc8f5dd2df3af6c75b792b9116b.
|
||||
---
|
||||
arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi | 34 ++++++++---------
|
||||
arch/arm64/boot/dts/qcom/msm8916.dtsi | 62 ++++++++++++++++---------------
|
||||
2 files changed, 49 insertions(+), 47 deletions(-)
|
||||
|
||||
diff --git a/arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi b/arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi
|
||||
index bd310ac1967a..f326f4fb4d72 100644
|
||||
--- a/arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/apq8016-sbc.dtsi
|
||||
@@ -215,16 +215,22 @@
|
||||
usb@78d9000 {
|
||||
extcon = <&usb_id>, <&usb_id>;
|
||||
status = "okay";
|
||||
- adp-disable;
|
||||
- hnp-disable;
|
||||
- srp-disable;
|
||||
- ulpi {
|
||||
- phy {
|
||||
- v1p8-supply = <&pm8916_l7>;
|
||||
- v3p3-supply = <&pm8916_l13>;
|
||||
- extcon = <&usb_id>;
|
||||
- };
|
||||
- };
|
||||
+ };
|
||||
+
|
||||
+ ehci@78d9000 {
|
||||
+ status = "okay";
|
||||
+ };
|
||||
+
|
||||
+ phy@78d9000 {
|
||||
+ v1p8-supply = <&pm8916_l7>;
|
||||
+ v3p3-supply = <&pm8916_l13>;
|
||||
+ vddcx-supply = <&pm8916_s1>;
|
||||
+ extcon = <&usb_id>, <&usb_id>;
|
||||
+ dr_mode = "otg";
|
||||
+ status = "okay";
|
||||
+ switch-gpio = <&pm8916_gpios 4 GPIO_ACTIVE_HIGH>;
|
||||
+ pinctrl-names = "default";
|
||||
+ pinctrl-0 = <&usb_sw_sel_pm>;
|
||||
};
|
||||
|
||||
lpass@07708000 {
|
||||
@@ -342,14 +348,6 @@
|
||||
pinctrl-0 = <&usb_id_default>;
|
||||
};
|
||||
|
||||
- usb-switch {
|
||||
- compatible = "toshiba,tc7usb40mu";
|
||||
- switch-gpios = <&pm8916_gpios 4 GPIO_ACTIVE_HIGH>;
|
||||
- extcon = <&usb_id>;
|
||||
- pinctrl-names = "default";
|
||||
- pinctrl-0 = <&usb_sw_sel_pm>;
|
||||
- };
|
||||
-
|
||||
hdmi-out {
|
||||
compatible = "hdmi-connector";
|
||||
type = "a";
|
||||
diff --git a/arch/arm64/boot/dts/qcom/msm8916.dtsi b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
||||
index 039991f80831..17691abea608 100644
|
||||
--- a/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
||||
+++ b/arch/arm64/boot/dts/qcom/msm8916.dtsi
|
||||
@@ -546,40 +546,44 @@
|
||||
status = "disabled";
|
||||
};
|
||||
|
||||
- otg: usb@78d9000 {
|
||||
+ usb_dev: usb@78d9000 {
|
||||
compatible = "qcom,ci-hdrc";
|
||||
- reg = <0x78d9000 0x200>,
|
||||
- <0x78d9200 0x200>;
|
||||
+ reg = <0x78d9000 0x400>;
|
||||
+ dr_mode = "peripheral";
|
||||
+ interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ usb-phy = <&usb_otg>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ usb_host: ehci@78d9000 {
|
||||
+ compatible = "qcom,ehci-host";
|
||||
+ reg = <0x78d9000 0x400>;
|
||||
+ interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+ usb-phy = <&usb_otg>;
|
||||
+ status = "disabled";
|
||||
+ };
|
||||
+
|
||||
+ usb_otg: phy@78d9000 {
|
||||
+ compatible = "qcom,usb-otg-snps";
|
||||
+ reg = <0x78d9000 0x400>;
|
||||
interrupts = <GIC_SPI 134 IRQ_TYPE_LEVEL_HIGH>,
|
||||
<GIC_SPI 140 IRQ_TYPE_LEVEL_HIGH>;
|
||||
+
|
||||
+ qcom,vdd-levels = <500000 1000000 1320000>;
|
||||
+ qcom,phy-init-sequence = <0x44 0x6B 0x24 0x13>;
|
||||
+ dr_mode = "peripheral";
|
||||
+ qcom,otg-control = <2>; // PMIC
|
||||
+ qcom,manual-pullup;
|
||||
+
|
||||
clocks = <&gcc GCC_USB_HS_AHB_CLK>,
|
||||
- <&gcc GCC_USB_HS_SYSTEM_CLK>;
|
||||
- clock-names = "iface", "core";
|
||||
- assigned-clocks = <&gcc GCC_USB_HS_SYSTEM_CLK>;
|
||||
- assigned-clock-rates = <80000000>;
|
||||
- resets = <&gcc GCC_USB_HS_BCR>;
|
||||
- reset-names = "core";
|
||||
- phy_type = "ulpi";
|
||||
- dr_mode = "otg";
|
||||
- ahb-burst-config = <0>;
|
||||
- phy-names = "usb-phy";
|
||||
- phys = <&usb_hs_phy>;
|
||||
- status = "disabled";
|
||||
- #reset-cells = <1>;
|
||||
+ <&gcc GCC_USB_HS_SYSTEM_CLK>,
|
||||
+ <&gcc GCC_USB2A_PHY_SLEEP_CLK>;
|
||||
+ clock-names = "iface", "core", "sleep";
|
||||
|
||||
- ulpi {
|
||||
- usb_hs_phy: phy {
|
||||
- compatible = "qcom,usb-hs-phy-msm8916",
|
||||
- "qcom,usb-hs-phy";
|
||||
- #phy-cells = <0>;
|
||||
- clocks = <&xo_board>, <&gcc GCC_USB2A_PHY_SLEEP_CLK>;
|
||||
- clock-names = "ref", "sleep";
|
||||
- resets = <&gcc GCC_USB2A_PHY_BCR>, <&otg 0>;
|
||||
- reset-names = "phy", "por";
|
||||
- qcom,init-seq = /bits/ 8 <0x0 0x44
|
||||
- 0x1 0x6b 0x2 0x24 0x3 0x13>;
|
||||
- };
|
||||
- };
|
||||
+ resets = <&gcc GCC_USB2A_PHY_BCR>,
|
||||
+ <&gcc GCC_USB_HS_BCR>;
|
||||
+ reset-names = "phy", "link";
|
||||
+ status = "disabled";
|
||||
};
|
||||
|
||||
intc: interrupt-controller@b000000 {
|
||||
--
|
||||
2.14.1
|
||||
|
|
@ -4,10 +4,10 @@
|
|||
buildarch=8
|
||||
|
||||
pkgbase=linux-aarch64
|
||||
_srcname=linux-4.12
|
||||
_srcname=linux-4.13
|
||||
_kernelname=${pkgbase#linux}
|
||||
_desc="AArch64 multi-platform"
|
||||
pkgver=4.12.10
|
||||
pkgver=4.13.0
|
||||
pkgrel=1
|
||||
arch=('aarch64')
|
||||
url="http://www.kernel.org/"
|
||||
|
@ -15,15 +15,20 @@ license=('GPL2')
|
|||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'inetutils' 'bc' 'git')
|
||||
options=('!strip')
|
||||
source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
|
||||
"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
#"http://www.kernel.org/pub/linux/kernel/v4.x/patch-${pkgver}.xz"
|
||||
'0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch'
|
||||
'0002-arm64-dts-rockchip-enable-sdmmc-controller-on-rk3399.patch'
|
||||
'0003-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch'
|
||||
'0004-Revert-arm64-dts-qcom-Collapse-usb-support-into-one-.patch'
|
||||
'config'
|
||||
'linux.preset'
|
||||
'99-linux.hook')
|
||||
md5sums=('fc454157e2d024d401a60905d6481c6b'
|
||||
'372499380d29bbbc176d7672bd21f812'
|
||||
'1d852d09fa6ec38017b3ebe631c02d32'
|
||||
'614b82f1f1dec2f87161cb1fa325ec51'
|
||||
md5sums=('ab1a2abc6f37b752dd2595338bec4e78'
|
||||
'7062ef1caf651c728e2710df877cdc27'
|
||||
'c98c7bf062b6da22eaedd94c7c565397'
|
||||
'17fcc7db40486466de2dbb8560473206'
|
||||
'c4da0e330c9aa3cdf99c4f642cadefc6'
|
||||
'1e260c74fa12632a6c0def911f50d1bd'
|
||||
'b5ef67d6086e20de7b82265f562f88b1'
|
||||
'1d4477026533efaa0358a40855d50a83')
|
||||
|
||||
|
@ -31,10 +36,13 @@ prepare() {
|
|||
cd "${srcdir}/${_srcname}"
|
||||
|
||||
# add upstream patch
|
||||
git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
#git apply --whitespace=nowarn ../patch-${pkgver}
|
||||
|
||||
# ALARM patches
|
||||
git apply ../0001-net-smsc95xx-Allow-mac-address-to-be-set-as-a-parame.patch
|
||||
git apply ../0002-arm64-dts-rockchip-enable-sdmmc-controller-on-rk3399.patch
|
||||
git apply ../0003-arm64-dts-rockchip-disable-pwm0-on-rk3399-firefly.patch
|
||||
git apply ../0004-Revert-arm64-dts-qcom-Collapse-usb-support-into-one-.patch
|
||||
|
||||
cat "${srcdir}/config" > ./.config
|
||||
|
||||
|
@ -179,10 +187,6 @@ _package-headers() {
|
|||
|
||||
cp arch/${KARCH}/kernel/asm-offsets.s "${pkgdir}/usr/lib/modules/${_kernver}/build/arch/${KARCH}/kernel/"
|
||||
|
||||
# add docbook makefile
|
||||
install -D -m644 Documentation/DocBook/Makefile \
|
||||
"${pkgdir}/usr/lib/modules/${_kernver}/build/Documentation/DocBook/Makefile"
|
||||
|
||||
# add dm headers
|
||||
mkdir -p "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
|
||||
cp drivers/md/*.h "${pkgdir}/usr/lib/modules/${_kernver}/build/drivers/md"
|
||||
|
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue