mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/coin-or-clp: fix
This commit is contained in:
parent
9ae00e9f87
commit
df77396542
2 changed files with 19 additions and 15 deletions
|
@ -1,23 +1,25 @@
|
|||
From 26d0b1d47b76575260a96d1712b1e95cc996ec9c Mon Sep 17 00:00:00 2001
|
||||
From 472517388e866758b74821d4fa3945cf7da4b838 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sat, 23 Feb 2019 11:39:31 -0700
|
||||
Subject: [PATCH] Remove MMX header
|
||||
Date: Mon, 17 Jun 2019 17:41:11 -0600
|
||||
Subject: [PATCH] Remove MMX and NEON headers
|
||||
|
||||
---
|
||||
Clp/src/ClpPackedMatrix.cpp | 6 ------
|
||||
Clp/src/ClpSimplexDual.cpp | 6 ------
|
||||
2 files changed, 12 deletions(-)
|
||||
Clp/src/ClpPackedMatrix.cpp | 8 --------
|
||||
Clp/src/ClpSimplexDual.cpp | 8 --------
|
||||
2 files changed, 16 deletions(-)
|
||||
|
||||
diff --git a/Clp/src/ClpPackedMatrix.cpp b/Clp/src/ClpPackedMatrix.cpp
|
||||
index e79bfaa..df2be84 100644
|
||||
index ed26ff7..df2be84 100644
|
||||
--- a/Clp/src/ClpPackedMatrix.cpp
|
||||
+++ b/Clp/src/ClpPackedMatrix.cpp
|
||||
@@ -6747,12 +6747,6 @@ ClpPackedMatrix3::ClpPackedMatrix3()
|
||||
@@ -6747,14 +6747,6 @@ ClpPackedMatrix3::ClpPackedMatrix3()
|
||||
, ifActive_(0)
|
||||
{
|
||||
}
|
||||
-#ifdef _MSC_VER
|
||||
-#include <intrin.h>
|
||||
-#elif defined(__arm__)
|
||||
-#include <arm_neon.h>
|
||||
-#else
|
||||
-#include <immintrin.h>
|
||||
-//#include <fmaintrin.h>
|
||||
|
@ -26,15 +28,17 @@ index e79bfaa..df2be84 100644
|
|||
ClpPackedMatrix3::ClpPackedMatrix3(ClpSimplex *model, const CoinPackedMatrix *columnCopy)
|
||||
: numberBlocks_(0)
|
||||
diff --git a/Clp/src/ClpSimplexDual.cpp b/Clp/src/ClpSimplexDual.cpp
|
||||
index a25cd1d..a0a5085 100644
|
||||
index b5de7cc..ce46064 100644
|
||||
--- a/Clp/src/ClpSimplexDual.cpp
|
||||
+++ b/Clp/src/ClpSimplexDual.cpp
|
||||
@@ -3550,12 +3550,6 @@ void moveAndZero(clpTempInfo *info, int type, void *extra)
|
||||
@@ -3554,14 +3554,6 @@ void moveAndZero(clpTempInfo *info, int type, void *extra)
|
||||
}
|
||||
}
|
||||
#endif
|
||||
-#ifdef _MSC_VER
|
||||
-#include <intrin.h>
|
||||
-#elif defined(__arm__)
|
||||
-#include <arm_neon.h>
|
||||
-#else
|
||||
-#include <immintrin.h>
|
||||
-//#include <fmaintrin.h>
|
||||
|
@ -43,5 +47,5 @@ index a25cd1d..a0a5085 100644
|
|||
const CoinIndexedVector *columnArray,
|
||||
CoinIndexedVector *spareArray,
|
||||
--
|
||||
2.20.1
|
||||
2.21.0
|
||||
|
|
@ -3,7 +3,7 @@
|
|||
# Contributor: Daniel Ehlers <danielehlers@mindeye.net>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - patch to remove MMX headers
|
||||
# - patch to remove MMX and NEON headers
|
||||
|
||||
pkgname=coin-or-clp
|
||||
pkgver=1.17.3
|
||||
|
@ -15,13 +15,13 @@ license=(EPL)
|
|||
groups=(coin-or)
|
||||
depends=(coin-or-osi suitesparse)
|
||||
source=("https://www.coin-or.org/download/source/Clp/Clp-${pkgver}.tgz"
|
||||
0001-Remove-MMX-header.patch)
|
||||
0001-Remove-MMX-and-NEON-headers.patch)
|
||||
sha256sums=('a13bf54291ad503cf76f5f93f2643d2add4faa5d0e60ff2db902ef715c094573'
|
||||
'72410d6472ba22790f183fba1249e7da46946ca88251c19ac511a7385e439b44')
|
||||
'0d778e38571919a804a0c98e8182b768f7d069f39cf01cc22f551d0ff18317c1')
|
||||
|
||||
prepare() {
|
||||
cd Clp-$pkgver/Clp
|
||||
patch -p2 -i $srcdir/0001-Remove-MMX-header.patch
|
||||
patch -p2 -i $srcdir/0001-Remove-MMX-and-NEON-headers.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue