mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/vlc to 3.0.13-1
This commit is contained in:
parent
0567748d00
commit
df7cfd58df
3 changed files with 46 additions and 5 deletions
|
@ -7,11 +7,11 @@
|
|||
# - enable gles2
|
||||
|
||||
pkgname=vlc
|
||||
_vlcver=3.0.12
|
||||
_vlcver=3.0.13
|
||||
# optional fixup version including hyphen
|
||||
_vlcfixupver=
|
||||
pkgver=${_vlcver}${_vlcfixupver//-/.r}
|
||||
pkgrel=6
|
||||
pkgrel=1
|
||||
pkgdesc='Multi-platform MPEG, VCD/DVD, and DivX player'
|
||||
url='https://www.videolan.org/vlc/'
|
||||
arch=('x86_64')
|
||||
|
@ -104,11 +104,13 @@ replaces=('vlc-plugin')
|
|||
options=('!emptydirs')
|
||||
source=(https://download.videolan.org/${pkgname}/${_vlcver}/${pkgname}-${_vlcver}${_vlcfixupver}.tar.xz{,.asc}
|
||||
update-vlc-plugin-cache.hook
|
||||
vlc-3.0.11.1-srt_1.4.2.patch)
|
||||
sha512sums=('ebec92bf732540be117551e94613747c53514ade7e280167c08400375738df9a01ee0e5d7c7733aca151a4f80f1c7163fd41318f2cc80b04a3201f0ba697e5df'
|
||||
vlc-3.0.11.1-srt_1.4.2.patch
|
||||
vlc-live-media-2021.patch)
|
||||
sha512sums=('0badca9d71b682b1dd6f05acab48d77baffe22e6a00be6db2a790644bab74738f9807e889fd0348af72628694b5210896638ac2cd99d0efc0e1c2cef7ab28bff'
|
||||
'SKIP'
|
||||
'b247510ffeadfd439a5dadd170c91900b6cdb05b5ca00d38b1a17c720ffe5a9f75a32e0cb1af5ebefdf1c23c5acc53513ed983a736e8fa30dd8fad237ef49dd3'
|
||||
'090c75878894f89184179f534da503a78234cf4f0f5af602873ea2ba6b68326afed71ef6160d1352bdd5c05e45b36bfcd23b7286d5111a900b7c11829642ae0d')
|
||||
'ac1d33d434aca2a0ad6e70800073deeaefc02b8fd72656b682ca833ee0cffe10dfa19a9355388700cab46ffbf9421c007d00ed04c7fa562698ff81e70db5f283'
|
||||
'ad17d6f4f2cc83841c1c89623c339ec3ee94f6084ea980e2c8cbc3903854c85e5396e31bfd8dc90745b41794670903d854c4d282d8adec263087a9d47b226ccc')
|
||||
validpgpkeys=('65F7C6B4206BD057A7EB73787180713BE58D1ADC') # VideoLAN Release Signing Key
|
||||
|
||||
prepare() {
|
||||
|
@ -125,6 +127,7 @@ prepare() {
|
|||
echo "Applying patch $src..."
|
||||
patch -Np1 < "../$src"
|
||||
done
|
||||
autoreconf -vf
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
|
@ -1,3 +1,15 @@
|
|||
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
|
||||
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
|
||||
+++ vlc-3.0.13/configure.ac 2021-05-03 16:10:00.342592591 +0200
|
||||
@@ -4016,7 +4016,7 @@
|
||||
dnl
|
||||
dnl SRT plugin
|
||||
dnl
|
||||
-PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2 srt < 1.3.0], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
|
||||
+PKG_ENABLE_MODULES_VLC([SRT], [access_srt access_output_srt], [srt >= 1.2.2], [SRT input/output plugin], [auto], [], [], [-DENABLE_SRT])
|
||||
|
||||
EXTEND_HELP_STRING([Visualisations and Video filter plugins:])
|
||||
dnl
|
||||
diff -ruN a/modules/access/srt.c b/modules/access/srt.c
|
||||
--- a/modules/access/srt.c 2018-04-23 10:03:39.000000000 +0200
|
||||
+++ b/modules/access/srt.c 2020-09-26 10:35:18.830149487 +0200
|
||||
|
|
26
extra/vlc/vlc-live-media-2021.patch
Normal file
26
extra/vlc/vlc-live-media-2021.patch
Normal file
|
@ -0,0 +1,26 @@
|
|||
diff -ru vlc-3.0.13.orig/configure.ac vlc-3.0.13/configure.ac
|
||||
--- vlc-3.0.13.orig/configure.ac 2021-04-27 15:18:39.000000000 +0200
|
||||
+++ vlc-3.0.13/configure.ac 2021-05-03 16:26:26.691200904 +0200
|
||||
@@ -1825,7 +1825,7 @@
|
||||
AC_MSG_ERROR([Update live555 or pass --disable-live555 to disable RTSP input support.])
|
||||
])
|
||||
], [
|
||||
- other_libs="-lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
+ other_libs="-lcrypto -lssl -lgroupsock -lBasicUsageEnvironment -lUsageEnvironment"
|
||||
other_libs_pic="-lgroupsock_pic -lBasicUsageEnvironment_pic -lUsageEnvironment_pic"
|
||||
AS_IF([test "${SYS}" = "mingw32"], [
|
||||
# add ws2_32 for closesocket, select, recv
|
||||
diff -ru vlc-3.0.13.orig/modules/access/live555.cpp vlc-3.0.13/modules/access/live555.cpp
|
||||
--- vlc-3.0.13.orig/modules/access/live555.cpp 2019-03-29 20:01:15.000000000 +0100
|
||||
+++ vlc-3.0.13/modules/access/live555.cpp 2021-05-03 16:04:38.030121796 +0200
|
||||
@@ -852,7 +852,9 @@
|
||||
if( !p_sys->b_multicast )
|
||||
{
|
||||
/* We need different rollover behaviour for multicast */
|
||||
- p_sys->b_multicast = IsMulticastAddress( sub->connectionEndpointAddress() );
|
||||
+ struct sockaddr_storage tempAddr;
|
||||
+ sub->getConnectionEndpointAddress(tempAddr);
|
||||
+ p_sys->b_multicast = IsMulticastAddress( tempAddr );
|
||||
}
|
||||
|
||||
tk = (live_track_t*)malloc( sizeof( live_track_t ) );
|
Loading…
Reference in a new issue