extra/libreoffice-fresh to 5.2.4-1

This commit is contained in:
Kevin Mihelich 2016-12-23 01:17:09 +00:00
parent 97446e3ee0
commit e04fb8ea72
2 changed files with 43 additions and 8 deletions

View file

@ -17,9 +17,9 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=5.2.3.3
pkgver=5.2.3
pkgrel=4
_LOver=5.2.4.2
pkgver=5.2.4
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -71,7 +71,8 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
make-pyuno-work-with-system-wide-module-install.diff
libreoffice-fresh.sh libreoffice-fresh.csh
update_liborcus_to_0.11.0.diff
remove_unnecessary_orcus_external_usage_from_makefiles.diff)
remove_unnecessary_orcus_external_usage_from_makefiles.diff
buildfix.diff)
noextract=(boost_1_60_0.tar.bz2
ce12af00283eb90d9281956524250d6e-xmlsec1-1.2.20.tar.gz
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -99,11 +100,11 @@ noextract=(boost_1_60_0.tar.bz2
976734806026a4ef8bdd17937c8898b9-icu4c-57_1-src.tgz
185d60944ea767075d27247c3162b3bc-unowinreg.dll)
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
sha256sums=('a8f1365d166bf24ac4b97ed8466f46cca29cf72e7e992bb84d24c3dc8e1c32c1'
sha256sums=('8b73d1afa6a1ff6bc153ab1f31afc86c42cc8d0e5831bf82e66a8df0fcf6eb10'
'SKIP'
'443be26b35c6b454d5d1ca17c58cc33ae90946f8e1003a98118467b49989cd3a'
'fef3a7699d20e198ac66267f50ffce5bcbef48617434af477de8887340ebe182'
'SKIP'
'8401e51c4b91cd47f103ba09519f0b5b9213561b7d6296ff5bdc2d1622950a48'
'620cab5f916663275895a9b50b8e00f7e96dbd8dc8129e79bc266274af3cae1c'
'SKIP'
'686affff989ac2488f79a97b9479efb9f2abae035b5ed4d8226de6857933fd3b'
'3221593ca50f362b546a0888a1431ad24be1470f96b2469c0e0df5e1c55e7305'
@ -135,7 +136,8 @@ sha256sums=('a8f1365d166bf24ac4b97ed8466f46cca29cf72e7e992bb84d24c3dc8e1c32c1'
'76f62957d0058092b11316357d9d716a62b48a53e5277426ffa87429ab5510e4'
'd24cfcb556ae1db02087c49012bbc4621f9ef7e3465ca832e1410326d260f283'
'4fc7b046fe96464a576d897330d1caa14998ab767002f84edf11a63b9ec35a7f'
'f6df5179582803bd71211a392218e9f7c062dc183832d6823cc7a13021e3e543')
'f6df5179582803bd71211a392218e9f7c062dc183832d6823cc7a13021e3e543'
'898785fc665f4c661666e4f78e0307a77640c37ce005354db75782cffa61286c')
prepare() {
@ -166,6 +168,9 @@ prepare() {
esac
ARCH_FLAGS="$ARCH_FLAGS $i"
done
# upstream fix for broken test
patch -Np1 -i ../buildfix.diff
}
build() {

View file

@ -0,0 +1,30 @@
From 014394f10a11a1b36f8a2e8a0722ec2fddf74b40 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Caol=C3=A1n=20McNamara?= <caolanm@redhat.com>
Date: Fri, 9 Dec 2016 15:26:59 +0000
Subject: oss-fuzz we don't want this stream to automatically resize on seeks
past end
Change-Id: Ie42b2e173cd3ed9faaf17c3c978227613129fa84
(cherry picked from commit f212bd45a7c7d97fb16380cd9fa7c6abbfb71e05)
(cherry picked from commit b832d7019f7e7499f5fb3da5d5f49ddbf0f35585)
Reviewed-on: https://gerrit.libreoffice.org/31803
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Michael Stahl <mstahl@redhat.com>
diff --git a/vcl/source/filter/wmf/winwmf.cxx b/vcl/source/filter/wmf/winwmf.cxx
index 88ab38f..c4f7e78 100644
--- a/vcl/source/filter/wmf/winwmf.cxx
+++ b/vcl/source/filter/wmf/winwmf.cxx
@@ -1093,7 +1093,7 @@ void WMFReader::ReadRecordParams( sal_uInt16 nFunc )
{ // first EMF comment
nEMFRecCount = nComRecCount;
nEMFSize = nEMFTotalSize;
- pEMFStream = o3tl::make_unique<SvMemoryStream>( nEMFSize );
+ pEMFStream = o3tl::make_unique<SvMemoryStream>(nEMFSize, 0);
}
else if( ( nEMFRecCount != nComRecCount ) || ( nEMFSize != nEMFTotalSize ) ) // add additional checks here
{
--
cgit v0.10.2