alarm/omxplayer-git to 530.1f1d0cc-1

This commit is contained in:
Kevin Mihelich 2022-03-05 17:16:19 +00:00
parent 4e6995ee4e
commit e0522d9502
2 changed files with 19 additions and 17 deletions

View file

@ -1,30 +1,33 @@
From 992bf584507a84ef94c26d72d776d7b76188b410 Mon Sep 17 00:00:00 2001
From 501dd92d440fcfe4862a6f505818d459eccbce27 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 24 Sep 2014 08:47:14 -0600
Subject: [PATCH] alarm fixes
---
Makefile | 31 +++++++++----------------------
Makefile | 35 +++++++++++------------------------
omxplayer.cpp | 4 ++--
2 files changed, 11 insertions(+), 24 deletions(-)
2 files changed, 13 insertions(+), 26 deletions(-)
diff --git a/Makefile b/Makefile
index 5f4e414..cb836a5 100644
index 8d00dec..70cd9a7 100644
--- a/Makefile
+++ b/Makefile
@@ -2,9 +2,9 @@ CFLAGS=-pipe -mfloat-abi=hard -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapc
@@ -1,10 +1,10 @@
-CFLAGS=-pipe -mfloat-abi=hard -mcpu=arm1176jzf-s -fomit-frame-pointer -mabi=aapcs-linux -mtune=arm1176jzf-s -mfpu=vfp -Wno-psabi -g
+CFLAGS=-pipe -fomit-frame-pointer -march=armv7-a -mfloat-abi=hard -mfpu=neon -Wno-psabi -g
CFLAGS+=-std=c++0x -D__STDC_CONSTANT_MACROS -D__STDC_LIMIT_MACROS -DTARGET_POSIX -DTARGET_LINUX -fPIC -DPIC -D_REENTRANT -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CMAKE_CONFIG -D__VIDEOCORE4__ -U_FORTIFY_SOURCE -Wall -DHAVE_OMXLIB -DUSE_EXTERNAL_FFMPEG -DHAVE_LIBAVCODEC_AVCODEC_H -DHAVE_LIBAVUTIL_OPT_H -DHAVE_LIBAVUTIL_MEM_H -DHAVE_LIBAVUTIL_AVUTIL_H -DHAVE_LIBAVFORMAT_AVFORMAT_H -DHAVE_LIBAVFILTER_AVFILTER_H -DHAVE_LIBSWRESAMPLE_SWRESAMPLE_H -DOMX -DOMX_SKIP64BIT -ftree-vectorize -DUSE_EXTERNAL_OMX -DTARGET_RASPBERRY_PI -DUSE_EXTERNAL_LIBBCM_HOST
LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
-LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/
-LDFLAGS+=-L./ -Lffmpeg_compiled/usr/local/lib/ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
+LDFLAGS=-L$(SDKSTAGE)/opt/vc/lib/ -L/usr/lib/ffmpeg4.4
+LDFLAGS+=-L./ -lc -lbrcmGLESv2 -lbrcmEGL -lbcm_host -lopenmaxil -lfreetype -lz -lasound
-INCLUDES+=-I./ -Ilinux -Iffmpeg_compiled/usr/local/include/ -I /usr/include/dbus-1.0 -I /usr/lib/arm-linux-gnueabihf/dbus-1.0/include -I/usr/include/freetype2 -isystem$(SDKSTAGE)/opt/vc/include -isystem$(SDKSTAGE)/opt/vc/include/interface/vcos/pthreads
+INCLUDES+=-I./ -Ilinux -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/freetype2 -I/opt/vc/include
+INCLUDES+=-I./ -Ilinux -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/freetype2 -I/opt/vc/include -I/usr/include/ffmpeg4.4
DIST ?= omxplayer-dist
STRIP ?= strip
@@ -41,7 +41,7 @@ SRC= linux/XMemUtils.cpp \
@@ -42,7 +42,7 @@ SRC= linux/XMemUtils.cpp \
OBJS+=$(filter %.o,$(SRC:.cpp=.o))
@ -33,7 +36,7 @@ index 5f4e414..cb836a5 100644
%.o: %.cpp
@rm -f $@
@@ -53,7 +53,7 @@ version:
@@ -54,7 +54,7 @@ version:
bash gen_version.sh > version.h
omxplayer.bin: version $(OBJS)
@ -42,7 +45,7 @@ index 5f4e414..cb836a5 100644
$(STRIP) omxplayer.bin
help.h: README.md Makefile
@@ -76,25 +76,12 @@ clean:
@@ -77,25 +77,12 @@ clean:
@rm -rf $(DIST)
@rm -f omxplayer-dist.tar.gz
@ -74,10 +77,10 @@ index 5f4e414..cb836a5 100644
uninstall:
rm -rf /usr/bin/omxplayer
diff --git a/omxplayer.cpp b/omxplayer.cpp
index 0d4ab5e..82a8342 100644
index b20ffb7..333bf5f 100644
--- a/omxplayer.cpp
+++ b/omxplayer.cpp
@@ -83,8 +83,8 @@ bool m_osd = true;
@@ -84,8 +84,8 @@ bool m_osd = !is_model_pi4() && !is_fkms_active();
bool m_no_keys = false;
std::string m_external_subtitles_path;
bool m_has_external_subtitles = false;
@ -89,5 +92,5 @@ index 0d4ab5e..82a8342 100644
bool m_asked_for_font = false;
bool m_asked_for_italic_font = false;
--
2.19.2
2.35.1

View file

@ -5,13 +5,13 @@
buildarch=4
pkgname=omxplayer-git
pkgver=528.f543a0d
pkgver=530.1f1d0cc
pkgrel=1
pkgdesc="omxplayer is a command line media player for the RaspberryPi"
arch=('armv6h' 'armv7h')
url="https://github.com/popcornmix/omxplayer"
license=(GPL2)
depends=('ffmpeg' 'raspberrypi-firmware' 'fbset')
depends=('ffmpeg4.4' 'raspberrypi-firmware' 'fbset')
makedepends=('git' 'boost')
optdepends=('ttf-freefont')
provides=(omxplayer)
@ -19,7 +19,7 @@ conflicts=('omxplayer' 'omxplayer-bin')
source=('git://github.com/popcornmix/omxplayer.git'
'0001-alarm-fixes.patch')
md5sums=('SKIP'
'75c23b95d9baab613997ec0fdd8e5eb0')
'f0a3f74ace409cf428536d791aa7b500')
pkgver() {
cd omxplayer
@ -35,7 +35,6 @@ prepare() {
build() {
cd "${srcdir}/omxplayer"
[[ $CARCH == "armv7h" ]] && CFLAGS=`echo $CFLAGS | sed -e 's/vfpv3-d16/neon/'` && CXXFLAGS="$CFLAGS"
make
}