extra/kwin to 5.2.0.1-3

This commit is contained in:
Kevin Mihelich 2015-02-18 15:38:03 +00:00
parent d790196221
commit e0570eb428
2 changed files with 31 additions and 1 deletions

View file

@ -10,7 +10,7 @@
pkgname=kwin
pkgver=5.2.0.1
_dir=5.2.0
pkgrel=2
pkgrel=3
pkgdesc='KDE Window manager'
arch=('i686' 'x86_64')
url='https://projects.kde.org/projects/kde/workspace/kwin'
@ -23,10 +23,12 @@ install=${pkgname}.install
conflicts=('kdebase-workspace')
source=("http://download.kde.org/stable/plasma/${_dir}/${pkgname}-${pkgver}.tar.xz"
'kdebug-341971.patch'
'libinput.0.8.0.patch'
"rpi_fix_build.patch"
"kwin_remove_eglonxbackend.patch")
md5sums=('47b6ce31b45450fa702098c9f3f5ac95'
'037db2eab5f9e07c74122f1a5fd4fe31'
'0ccc6b0113e37bd994c65ffb6a4518ff'
'3e11a42013f03d55b4b730463bdd6fe0'
'28a1e8bd701a8fd1421e6ec238b4c522')
@ -36,6 +38,9 @@ prepare() {
cd "${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}"/kdebug-341971.patch
#https://bugs.kde.org/show_bug.cgi?id=342893
patch -Np1 -i "${srcdir}"/libinput.0.8.0.patch
# Raspberry Pi
if [ "$CARCH" == 'armv6h' ]; then
patch -p1 -i "${srcdir}/rpi_fix_build.patch"

View file

@ -0,0 +1,25 @@
commit a93a2ab1918630c6d571b5a24379c15a0458d1fa
Author: Martin Gräßlin <mgraesslin@kde.org>
Date: Wed Jan 28 16:20:57 2015 +0100
Disable libinput integration if >= 0.8 is found
libinput 0.8 is incompatible causing the build to fail. As we are in
dependency freeze the only option is to disable the build.
BUG: 342893
FIXED-IN: 5.2.1
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 550ef57..8d9c593 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -145,7 +145,7 @@ set_package_properties(UDev PROPERTIES URL "http://www.freedesktop.org/software
PURPOSE "Required for input handling on Wayland."
)
set(HAVE_INPUT FALSE)
-if (Libinput_FOUND AND UDEV_FOUND)
+if (Libinput_FOUND AND UDEV_FOUND AND Libinput_VERSION VERSION_LESS 0.8)
set(HAVE_INPUT TRUE)
endif()