alarm/uboot-odroid-c2 to 2015.01-8

This commit is contained in:
Kevin Mihelich 2016-06-17 00:59:15 +00:00
parent abc09d6beb
commit e07ebdc5cf
6 changed files with 23 additions and 146 deletions

View file

@ -1,29 +0,0 @@
From f1c2966fe1b01b98f405b8bf9aeebec552bbfec3 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 19:29:25 -0700
Subject: [PATCH 1/4] remove cross compiling
---
Makefile | 6 ------
1 file changed, 6 deletions(-)
diff --git a/Makefile b/Makefile
index 1da09c2..2968eb4 100644
--- a/Makefile
+++ b/Makefile
@@ -244,12 +244,6 @@ export HOSTARCH HOSTOS
# set default to nothing for native builds
ifeq ($(HOSTARCH),$(ARCH))
CROSS_COMPILE ?=
-else
-ifeq ($(CROSS_COMPILE),)
-CROSS_COMPILE = /opt/toolchains/gcc-linaro-aarch64-none-elf-4.9-2014.09_linux/bin/aarch64-none-elf-
-export CROSS_COMPILE
-endif
-
endif
KCONFIG_CONFIG ?= .config
--
2.7.1

View file

@ -1,7 +1,7 @@
From 12983d91742d4b981d032b94a5349427670b2cc9 Mon Sep 17 00:00:00 2001
From b5553dc73dcf40b1cf1c3114278706526c386956 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 20:59:26 -0700
Subject: [PATCH 2/4] sd_fusing tweaks
Subject: [PATCH 1/2] sd_fusing tweaks
---
sd_fuse/sd_fusing.sh | 13 ++++++-------
@ -39,5 +39,5 @@ index 538185b..c14e0e2 100755
-echo Finished.
+echo "Successfully wrote U-Boot to $1"
--
2.7.1
2.8.0

View file

@ -1,7 +1,7 @@
From 1c175a4cfda5cf7c783bb0a43481b8f8d821d9bd Mon Sep 17 00:00:00 2001
From 79e1cf43cb41de41944272ea46e077b6315ce8c0 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 21:23:59 -0700
Subject: [PATCH 4/4] arch linux arm modifications
Subject: [PATCH 2/2] arch linux arm modifications
---
common/cmd_cfgload.c | 2 +-
@ -9,7 +9,7 @@ Subject: [PATCH 4/4] arch linux arm modifications
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/common/cmd_cfgload.c b/common/cmd_cfgload.c
index 6774e37..bb08f96 100644
index 90e2541..7166d26 100644
--- a/common/cmd_cfgload.c
+++ b/common/cmd_cfgload.c
@@ -52,7 +52,7 @@ static char* read_cfgload(void)
@ -22,7 +22,7 @@ index 6774e37..bb08f96 100644
filesize = getenv_ulong("filesize", 16, 0);
diff --git a/include/configs/odroidc2.h b/include/configs/odroidc2.h
index 74da65d..a03d388 100644
index 307d643..6c1564b 100755
--- a/include/configs/odroidc2.h
+++ b/include/configs/odroidc2.h
@@ -75,6 +75,13 @@
@ -40,5 +40,5 @@ index 74da65d..a03d388 100644
#define CONFIG_SYS_MAXARGS 64
--
2.7.1
2.8.0

View file

@ -1,93 +0,0 @@
From 434cc0fd97f9a82f94a5f128a633c071b09fd119 Mon Sep 17 00:00:00 2001
From: Hans de Goede <hdegoede@redhat.com>
Date: Sat, 7 Feb 2015 22:52:40 +0100
Subject: [PATCH 3/4] Add linux/compiler-gcc5.h to fix builds with gcc5
Add linux/compiler-gcc5/h from the kernel sources at:
commit 5631b8fba640a4ab2f8a954f63a603fa34eda96b
Author: Steven Noonan <steven@uplinklabs.net>
Date: Sat Oct 25 15:09:42 2014 -0700
compiler/gcc4+: Remove inaccurate comment about 'asm goto' miscompiles
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
---
include/linux/compiler-gcc5.h | 65 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 65 insertions(+)
create mode 100644 include/linux/compiler-gcc5.h
diff --git a/include/linux/compiler-gcc5.h b/include/linux/compiler-gcc5.h
new file mode 100644
index 0000000..c8c5659
--- /dev/null
+++ b/include/linux/compiler-gcc5.h
@@ -0,0 +1,65 @@
+#ifndef __LINUX_COMPILER_H
+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
+#endif
+
+#define __used __attribute__((__used__))
+#define __must_check __attribute__((warn_unused_result))
+#define __compiler_offsetof(a, b) __builtin_offsetof(a, b)
+
+/* Mark functions as cold. gcc will assume any path leading to a call
+ to them will be unlikely. This means a lot of manual unlikely()s
+ are unnecessary now for any paths leading to the usual suspects
+ like BUG(), printk(), panic() etc. [but let's keep them for now for
+ older compilers]
+
+ Early snapshots of gcc 4.3 don't support this and we can't detect this
+ in the preprocessor, but we can live with this because they're unreleased.
+ Maketime probing would be overkill here.
+
+ gcc also has a __attribute__((__hot__)) to move hot functions into
+ a special section, but I don't see any sense in this right now in
+ the kernel context */
+#define __cold __attribute__((__cold__))
+
+#define __UNIQUE_ID(prefix) __PASTE(__PASTE(__UNIQUE_ID_, prefix), __COUNTER__)
+
+#ifndef __CHECKER__
+# define __compiletime_warning(message) __attribute__((warning(message)))
+# define __compiletime_error(message) __attribute__((error(message)))
+#endif /* __CHECKER__ */
+
+/*
+ * Mark a position in code as unreachable. This can be used to
+ * suppress control flow warnings after asm blocks that transfer
+ * control elsewhere.
+ *
+ * Early snapshots of gcc 4.5 don't support this and we can't detect
+ * this in the preprocessor, but we can live with this because they're
+ * unreleased. Really, we need to have autoconf for the kernel.
+ */
+#define unreachable() __builtin_unreachable()
+
+/* Mark a function definition as prohibited from being cloned. */
+#define __noclone __attribute__((__noclone__))
+
+/*
+ * Tell the optimizer that something else uses this function or variable.
+ */
+#define __visible __attribute__((externally_visible))
+
+/*
+ * GCC 'asm goto' miscompiles certain code sequences:
+ *
+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
+ *
+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
+ *
+ * (asm goto is automatically volatile - the naming reflects this.)
+ */
+#define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
+
+#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
+#define __HAVE_BUILTIN_BSWAP32__
+#define __HAVE_BUILTIN_BSWAP64__
+#define __HAVE_BUILTIN_BSWAP16__
+#endif /* CONFIG_ARCH_USE_BUILTIN_BSWAP */
--
2.7.1

View file

@ -8,7 +8,7 @@ noautobuild=1
pkgname=uboot-odroid-c2
pkgver=2015.01
pkgrel=7
pkgrel=8
pkgdesc="U-Boot for ODROID-C2"
arch=('aarch64')
url="https://github.com/hardkernel/u-boot"
@ -16,27 +16,21 @@ license=('GPL')
install=$pkgname.install
makedepends=('git' 'bc')
backup=('boot/boot.ini')
_commit=01bafa6e1264c034674c2e7090c82bab1484a070
_commit=3edccd18784aef602a50040b24acdf3adbb7781a
source=("https://github.com/hardkernel/u-boot/archive/${_commit}.tar.gz"
'boot.ini'
'0001-remove-cross-compiling.patch'
'0002-sd_fusing-tweaks.patch'
'0003-Add-linux-compiler-gcc5.h-to-fix-builds-with-gcc5.patch'
'0004-arch-linux-arm-modifications.patch')
md5sums=('71044d38d2a1525928962caa2b33630f'
'bfdb80dab4b4a47eb810fa6270483401'
'063ed1211b9ff1f045f2480b02dcc7f0'
'568e66da8b3e339fe653b05c375de4db'
'fddd7cc81ad9e8dc76441376ff8c56f8'
'0f2c6a61e94d48dffd2c17dd22d4e3e6')
'0001-sd_fusing-tweaks.patch'
'0002-arch-linux-arm-modifications.patch')
md5sums=('e112b3e9c77358bda6b14ce5347e995a'
'a0ba81b25ad88f1f436b9f67bd815f35'
'316b458415515edfc18abd54a52d43d4'
'de51b9b3345954238c455214c5947ea3')
prepare() {
cd u-boot-${_commit}
git apply ../0001-remove-cross-compiling.patch
git apply ../0002-sd_fusing-tweaks.patch
git apply ../0003-Add-linux-compiler-gcc5.h-to-fix-builds-with-gcc5.patch
git apply ../0004-arch-linux-arm-modifications.patch
git apply ../0001-sd_fusing-tweaks.patch
git apply ../0002-arch-linux-arm-modifications.patch
}
build() {

View file

@ -53,6 +53,7 @@ setenv m "1080p60hz" # Progressive 60Hz
# setenv m "2560x1080p60hz"
# setenv m "2560x1440p60hz"
# setenv m "2560x1600p60hz"
# setenv m "3440x1440p60hz"
# HDMI BPP Mode
setenv m_bpp "32"
@ -104,7 +105,11 @@ load mmc 0:1 ${dtb_loadaddr} /boot/dtbs/meson64_odroidc2.dtb
fdt addr ${dtb_loadaddr}
if test "${mesontimer}" = "0"; then fdt rm /meson_timer; fdt rm /cpus/cpu@0/timer; fdt rm /cpus/cpu@1/timer; fdt rm /cpus/cpu@2/timer; fdt rm /cpus/cpu@3/timer; fi
if test "${mesontimer}" = "1"; then fdt rm /timer; fi
if test "${nographics}" = "1"; then fdt rm /reserved-memory; fdt rm /aocec; fi
if test "${nographics}" = "1"; then fdt rm /meson-fb; fdt rm /amhdmitx; fdt rm /picdec; fdt rm /ppmgr; fi
if test "${nographics}" = "1"; then fdt rm /meson-vout; fdt rm /mesonstream; fdt rm /meson-fb; fi
if test "${nographics}" = "1"; then fdt rm /deinterlace; fdt rm /codec_mm; fi
load mmc 0:1 ${initrd_loadaddr} /boot/initramfs-linux.img