extra/pyqt5 to 5.7.1-2

This commit is contained in:
Kevin Mihelich 2017-01-24 00:30:41 +00:00
parent e0a8107f1f
commit e0dad392b1
3 changed files with 35 additions and 3 deletions

View file

@ -12,7 +12,7 @@ pkgbase=pyqt5
pkgname=('pyqt5-common' 'python-pyqt5' 'python2-pyqt5')
pkgver=5.7.1
_pkgver=$pkgver
pkgrel=1
pkgrel=2
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
@ -20,10 +20,19 @@ makedepends=('python-sip' 'python2-sip' 'python-opengl' 'python2-opengl'
'python2-dbus' 'python-dbus' 'qt5-connectivity'
'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-svg'
'qt5-webkit' 'qt5-websockets' 'qt5-x11extras')
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz")
md5sums=('b3171b67c74aa63a3cd2f386660c898b')
source=("http://sourceforge.net/projects/pyqt/files/PyQt5/PyQt-$pkgver/PyQt5_gpl-$pkgver.tar.gz" pyqt-qt5.8.patch pyqt5-fix-check-license.patch)
md5sums=('b3171b67c74aa63a3cd2f386660c898b'
'5edc113edf71e42baa37e34cf0d64ec2'
'1f57fb76747c5723dc4747fbbb376145')
prepare() {
pushd PyQt5_gpl-${_pkgver}
# Support Qt 5.8
patch -p1 -i ../pyqt-qt5.8.patch
# Hack to make the license check pass with Qt 5.8
patch -p1 -i ../pyqt5-fix-check-license.patch
popd
# The additional include path was removed due to this line, I don't really know why they are doing this...
sed -i '/target_config.dbus_inc_dirs = \[\]/d' PyQt5_gpl-${_pkgver}/configure.py

View file

@ -0,0 +1,12 @@
--- PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:39:12.725734296 +0000
+++ PyQt5_gpl-5.7/sip/QtCore/QtCoremod.sip 2016-12-24 12:40:17.502273973 +0000
@@ -22,7 +22,7 @@
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1}
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0}
%Platforms {WS_X11 WS_WIN WS_MACX}

View file

@ -0,0 +1,11 @@
--- PyQt5_gpl-5.7.1/configure.py.orig 2017-01-23 20:42:47.791266791 +0100
+++ PyQt5_gpl-5.7.1/configure.py 2017-01-23 20:43:02.754828184 +0100
@@ -723,7 +723,7 @@
lines = f.read().split('\n')
f.close()
- self.qt_licensee = lines[0]
+ self.qt_licensee = 'Open Source'
self.qt_shared = (lines[1] == 'shared')
self.pyqt_disabled_features = lines[2:-1]