mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/qt5-base to 5.15.10+kde+r147-2
This commit is contained in:
parent
97dc43652b
commit
e0f3be6244
2 changed files with 141 additions and 1 deletions
|
@ -11,7 +11,7 @@ pkgbase=qt5-base
|
|||
pkgname=(qt5-base qt5-xcb-private-headers)
|
||||
_basever=5.15.10
|
||||
pkgver=5.15.10+kde+r147
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_commit=e24dc54b2b4054413650904288aa7a363eee23a7
|
||||
arch=('x86_64')
|
||||
url='https://www.qt.io'
|
||||
|
@ -35,9 +35,11 @@ conflicts=('qtchooser')
|
|||
groups=('qt' 'qt5')
|
||||
_pkgfqn=${pkgbase/5-/}
|
||||
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
|
||||
work-around-pyside2-brokenness.patch
|
||||
qmake-cflags.patch
|
||||
qmake-config.patch)
|
||||
sha256sums=('SKIP'
|
||||
'6a4ec2bfcf4e7cff73346762b252cc28be5ca0ed79fde5e69350efe229b43adc'
|
||||
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
|
||||
'4abc22150fa3e06b2fdcec32146abc9be4e316692aa4d5bd5aa53b4b726783fa')
|
||||
|
||||
|
@ -48,6 +50,7 @@ pkgver() {
|
|||
|
||||
prepare() {
|
||||
cd ${_pkgfqn}
|
||||
patch -p1 < ../work-around-pyside2-brokenness.patch
|
||||
patch -p1 < ../qmake-cflags.patch # Use system CFLAGS in qmake
|
||||
patch -p1 < ../qmake-config.patch # Don't strip binaries with qmake and use -ltcg, cf. QTBUG-73834
|
||||
|
||||
|
|
137
extra/qt5-base/work-around-pyside2-brokenness.patch
Normal file
137
extra/qt5-base/work-around-pyside2-brokenness.patch
Normal file
|
@ -0,0 +1,137 @@
|
|||
# Patch from OpenMandriva:
|
||||
# https://github.com/OpenMandrivaAssociation/qt5-qtbase/commit/20f97a4b#diff-c548550538903adec7a57251150fb23c61089ec82748fae900869f550aefc8f6R161
|
||||
|
||||
diff -up qtbase-everywhere-src-5.15.9/src/gui/kernel/qevent.h.5~ qtbase-everywhere-src-5.15.9/src/gui/kernel/qevent.h
|
||||
--- qtbase-everywhere-src-5.15.9/src/gui/kernel/qevent.h.5~ 2023-03-23 20:06:47.000000000 +0100
|
||||
+++ qtbase-everywhere-src-5.15.9/src/gui/kernel/qevent.h 2023-04-15 23:23:40.599956996 +0200
|
||||
@@ -104,15 +104,15 @@ protected:
|
||||
class Q_GUI_EXPORT QMouseEvent : public QInputEvent
|
||||
{
|
||||
public:
|
||||
- QMouseEvent(Type type, const QPointF &localPos, Qt::MouseButton button,
|
||||
+ QMouseEvent(QEvent::Type type, const QPointF &localPos, Qt::MouseButton button,
|
||||
Qt::MouseButtons buttons, Qt::KeyboardModifiers modifiers);
|
||||
- QMouseEvent(Type type, const QPointF &localPos, const QPointF &screenPos,
|
||||
+ QMouseEvent(QEvent::Type type, const QPointF &localPos, const QPointF &screenPos,
|
||||
Qt::MouseButton button, Qt::MouseButtons buttons,
|
||||
Qt::KeyboardModifiers modifiers);
|
||||
- QMouseEvent(Type type, const QPointF &localPos, const QPointF &windowPos, const QPointF &screenPos,
|
||||
+ QMouseEvent(QEvent::Type type, const QPointF &localPos, const QPointF &windowPos, const QPointF &screenPos,
|
||||
Qt::MouseButton button, Qt::MouseButtons buttons,
|
||||
Qt::KeyboardModifiers modifiers);
|
||||
- QMouseEvent(Type type, const QPointF &localPos, const QPointF &windowPos, const QPointF &screenPos,
|
||||
+ QMouseEvent(QEvent::Type type, const QPointF &localPos, const QPointF &windowPos, const QPointF &screenPos,
|
||||
Qt::MouseButton button, Qt::MouseButtons buttons,
|
||||
Qt::KeyboardModifiers modifiers, Qt::MouseEventSource source);
|
||||
~QMouseEvent();
|
||||
@@ -154,7 +154,7 @@ protected:
|
||||
class Q_GUI_EXPORT QHoverEvent : public QInputEvent
|
||||
{
|
||||
public:
|
||||
- QHoverEvent(Type type, const QPointF &pos, const QPointF &oldPos, Qt::KeyboardModifiers modifiers = Qt::NoModifier);
|
||||
+ QHoverEvent(QEvent::Type type, const QPointF &pos, const QPointF &oldPos, Qt::KeyboardModifiers modifiers = Qt::NoModifier);
|
||||
~QHoverEvent();
|
||||
|
||||
#ifndef QT_NO_INTEGER_EVENT_COORDINATES
|
||||
@@ -282,12 +282,12 @@ public:
|
||||
#if QT_DEPRECATED_SINCE(5, 15)
|
||||
// Actually deprecated since 5.4, in docs
|
||||
QT_DEPRECATED_VERSION_X_5_15("Use the other QTabletEvent constructor")
|
||||
- QTabletEvent(Type t, const QPointF &pos, const QPointF &globalPos,
|
||||
+ QTabletEvent(QEvent::Type t, const QPointF &pos, const QPointF &globalPos,
|
||||
int device, int pointerType, qreal pressure, int xTilt, int yTilt,
|
||||
qreal tangentialPressure, qreal rotation, int z,
|
||||
Qt::KeyboardModifiers keyState, qint64 uniqueID); // ### remove in Qt 6
|
||||
#endif
|
||||
- QTabletEvent(Type t, const QPointF &pos, const QPointF &globalPos,
|
||||
+ QTabletEvent(QEvent::Type t, const QPointF &pos, const QPointF &globalPos,
|
||||
int device, int pointerType, qreal pressure, int xTilt, int yTilt,
|
||||
qreal tangentialPressure, qreal rotation, int z,
|
||||
Qt::KeyboardModifiers keyState, qint64 uniqueID,
|
||||
@@ -377,9 +377,9 @@ protected:
|
||||
class Q_GUI_EXPORT QKeyEvent : public QInputEvent
|
||||
{
|
||||
public:
|
||||
- QKeyEvent(Type type, int key, Qt::KeyboardModifiers modifiers, const QString& text = QString(),
|
||||
+ QKeyEvent(QEvent::Type type, int key, Qt::KeyboardModifiers modifiers, const QString& text = QString(),
|
||||
bool autorep = false, ushort count = 1);
|
||||
- QKeyEvent(Type type, int key, Qt::KeyboardModifiers modifiers,
|
||||
+ QKeyEvent(QEvent::Type type, int key, Qt::KeyboardModifiers modifiers,
|
||||
quint32 nativeScanCode, quint32 nativeVirtualKey, quint32 nativeModifiers,
|
||||
const QString &text = QString(), bool autorep = false, ushort count = 1);
|
||||
~QKeyEvent();
|
||||
@@ -399,7 +399,7 @@ public:
|
||||
|
||||
// Functions for the extended key event information
|
||||
#if QT_DEPRECATED_SINCE(5, 0)
|
||||
- static inline QKeyEvent *createExtendedKeyEvent(Type type, int key, Qt::KeyboardModifiers modifiers,
|
||||
+ static inline QKeyEvent *createExtendedKeyEvent(QEvent::Type type, int key, Qt::KeyboardModifiers modifiers,
|
||||
quint32 nativeScanCode, quint32 nativeVirtualKey,
|
||||
quint32 nativeModifiers,
|
||||
const QString& text = QString(), bool autorep = false,
|
||||
@@ -682,7 +682,7 @@ class Q_GUI_EXPORT QDragMoveEvent : publ
|
||||
{
|
||||
public:
|
||||
QDragMoveEvent(const QPoint &pos, Qt::DropActions actions, const QMimeData *data,
|
||||
- Qt::MouseButtons buttons, Qt::KeyboardModifiers modifiers, Type type = DragMove);
|
||||
+ Qt::MouseButtons buttons, Qt::KeyboardModifiers modifiers, QEvent::Type type = QEvent::DragMove);
|
||||
~QDragMoveEvent();
|
||||
|
||||
inline QRect answerRect() const { return rect; }
|
||||
diff -up qtbase-everywhere-src-5.15.9/src/widgets/graphicsview/qgraphicssceneevent.h.5~ qtbase-everywhere-src-5.15.9/src/widgets/graphicsview/qgraphicssceneevent.h
|
||||
--- qtbase-everywhere-src-5.15.9/src/widgets/graphicsview/qgraphicssceneevent.h.5~ 2023-03-23 20:06:47.000000000 +0100
|
||||
+++ qtbase-everywhere-src-5.15.9/src/widgets/graphicsview/qgraphicssceneevent.h 2023-04-15 23:22:38.038387091 +0200
|
||||
@@ -82,7 +82,7 @@ class QGraphicsSceneMouseEventPrivate;
|
||||
class Q_WIDGETS_EXPORT QGraphicsSceneMouseEvent : public QGraphicsSceneEvent
|
||||
{
|
||||
public:
|
||||
- explicit QGraphicsSceneMouseEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneMouseEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneMouseEvent();
|
||||
|
||||
QPointF pos() const;
|
||||
@@ -136,7 +136,7 @@ class QGraphicsSceneWheelEventPrivate;
|
||||
class Q_WIDGETS_EXPORT QGraphicsSceneWheelEvent : public QGraphicsSceneEvent
|
||||
{
|
||||
public:
|
||||
- explicit QGraphicsSceneWheelEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneWheelEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneWheelEvent();
|
||||
|
||||
QPointF pos() const;
|
||||
@@ -171,7 +171,7 @@ class Q_WIDGETS_EXPORT QGraphicsSceneCon
|
||||
public:
|
||||
enum Reason { Mouse, Keyboard, Other };
|
||||
|
||||
- explicit QGraphicsSceneContextMenuEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneContextMenuEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneContextMenuEvent();
|
||||
|
||||
QPointF pos() const;
|
||||
@@ -198,7 +198,7 @@ class QGraphicsSceneHoverEventPrivate;
|
||||
class Q_WIDGETS_EXPORT QGraphicsSceneHoverEvent : public QGraphicsSceneEvent
|
||||
{
|
||||
public:
|
||||
- explicit QGraphicsSceneHoverEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneHoverEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneHoverEvent();
|
||||
|
||||
QPointF pos() const;
|
||||
@@ -231,7 +231,7 @@ class QGraphicsSceneHelpEventPrivate;
|
||||
class Q_WIDGETS_EXPORT QGraphicsSceneHelpEvent : public QGraphicsSceneEvent
|
||||
{
|
||||
public:
|
||||
- explicit QGraphicsSceneHelpEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneHelpEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneHelpEvent();
|
||||
|
||||
QPointF scenePos() const;
|
||||
@@ -249,7 +249,7 @@ class QGraphicsSceneDragDropEventPrivate
|
||||
class Q_WIDGETS_EXPORT QGraphicsSceneDragDropEvent : public QGraphicsSceneEvent
|
||||
{
|
||||
public:
|
||||
- explicit QGraphicsSceneDragDropEvent(Type type = None);
|
||||
+ explicit QGraphicsSceneDragDropEvent(QEvent::Type type = QEvent::None);
|
||||
~QGraphicsSceneDragDropEvent();
|
||||
|
||||
QPointF pos() const;
|
Loading…
Reference in a new issue