extra/blender to 3.6.2-1

This commit is contained in:
Kevin Mihelich 2023-08-26 20:56:28 +00:00
parent bb4e501cf5
commit e1048932eb
2 changed files with 42 additions and 5 deletions

View file

@ -16,8 +16,8 @@ buildarch=8
# fine with them.
pkgname=blender
pkgver=3.6.0
pkgrel=4
pkgver=3.6.2
pkgrel=1
epoch=17
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('x86_64')
@ -35,14 +35,17 @@ optdepends=('libdecor: wayland support')
# We're using !buildflags here as otherwise we get stuff such as FS#77557
# It'd be better to figure out exactly which of the flags is the culprit which I attempted but without any success.
options=('!buildflags')
source=("git+https://projects.blender.org/blender/blender.git#tag=v$pkgver"
_commit=ffe93138751e
source=("git+https://projects.blender.org/blender/blender.git#commit=$_commit"
https://developer.download.nvidia.com/redist/optix/v7.6/OptiX-7.6-Include.zip
force-draco1.patch
force-draco2.patch)
force-draco2.patch
blender-new-sycl.patch)
sha512sums=('SKIP'
'dfe86de395dd298fb9feae73bff06a26742efa06a25bb5a4f78ffb1ba4c78f555d1af927efea98af281715cce01db219aa2adfd6bd323bf0d766c1c70ce03532'
'e239da4f3906f1b54265435181cf770bae3d269c8d915df9a73861e6ee71ec70bf2339426e7c81a91e5a567273b3b3742d7a99feefd3398d821b26e1ff3a56d0'
'c162646eba42ea7112cfb615466c2cbaddac8d254d4a9e91cf887c5bffef1325a983701163223a1fdee091310ac5574a400347aab7f52321825b5fa3d5a9036f')
'c162646eba42ea7112cfb615466c2cbaddac8d254d4a9e91cf887c5bffef1325a983701163223a1fdee091310ac5574a400347aab7f52321825b5fa3d5a9036f'
'b1eb2379b673514da2599c5fc3be7fc597d4d3d23550ff392b364ae53f67e332bbed7612a0d06cbf9cd255ad6833bdb29f7e3fe668471d57e91407092419f4dd')
prepare() {
cd "$pkgname"
@ -52,6 +55,7 @@ prepare() {
# fix draco
patch -p1 -i "$srcdir"/force-draco1.patch
patch -p1 -d scripts/addons -i "$srcdir"/force-draco2.patch
patch -p1 -i "$srcdir"/blender-new-sycl.patch
}
get_pyver() {

View file

@ -0,0 +1,33 @@
From d7794f3540cc9837173ed375ea5db4651c1c24df Mon Sep 17 00:00:00 2001
From: "Werner, Stefan" <stefan.werner@intel.com>
Date: Mon, 5 Jun 2023 11:49:17 +0200
Subject: [PATCH] Cycles: Fixed SYCL build with newer compilers
---
intern/cycles/util/math.h | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/intern/cycles/util/math.h b/intern/cycles/util/math.h
index 99415d2ee9b..289bd5d4baf 100644
--- a/intern/cycles/util/math.h
+++ b/intern/cycles/util/math.h
@@ -101,7 +101,6 @@ using std::isfinite;
using std::isnan;
using std::sqrt;
# else
-using sycl::sqrt;
# define isfinite(x) sycl::isfinite((x))
# define isnan(x) sycl::isnan((x))
# endif
@@ -795,7 +794,10 @@ ccl_device float bits_to_01(uint bits)
#if !defined(__KERNEL_GPU__)
# if defined(__GNUC__)
-# define popcount(x) __builtin_popcount(x)
+ccl_device_inline uint popcount(uint x)
+{
+ return __builtin_popcount(x);
+}
# else
ccl_device_inline uint popcount(uint x)
{