mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/libvirt: armv5 fix
This commit is contained in:
parent
5f483a4717
commit
e16457d87f
2 changed files with 41 additions and 2 deletions
|
@ -4,6 +4,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove numactl from depends, doesn't build on ARM
|
||||
# - patch to use pthread atomics instead of gcc atomics on armv5
|
||||
|
||||
pkgname=libvirt
|
||||
pkgver=1.1.4
|
||||
|
@ -36,11 +37,13 @@ install="libvirt.install"
|
|||
source=("http://libvirt.org/sources/$pkgname-$pkgver.tar.gz"
|
||||
libvirtd.conf.d
|
||||
libvirtd-guests.conf.d
|
||||
libvirt.tmpfiles.d)
|
||||
libvirt.tmpfiles.d
|
||||
arm.patch)
|
||||
md5sums=('0b21e97ad5d3c27d18806896e16ef82b'
|
||||
'3ed0e24f5b5e25bf553f5427d64915e6'
|
||||
'0a96ed876ffb1fcb9dff5a9b3a609c1e'
|
||||
'020971887442ebbf1b6949e031c8dd3f')
|
||||
'020971887442ebbf1b6949e031c8dd3f'
|
||||
'71d70d6408d81331ae2701ec05f9e2f8')
|
||||
|
||||
build() {
|
||||
cd "$srcdir/$pkgname-$pkgver"
|
||||
|
@ -52,6 +55,8 @@ build() {
|
|||
sed -i 's_#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
|
||||
done
|
||||
|
||||
[[ $CARCH == 'arm' ]] && patch -p1 -i ../arm.patch && autoreconf -fi
|
||||
|
||||
export LDFLAGS=-lX11
|
||||
export RADVD=/usr/bin/radvd
|
||||
[ -f Makefile ] || ./configure --prefix=/usr --libexec=/usr/lib/"$pkgname" --sbindir=/usr/bin \
|
||||
|
|
34
community/libvirt/arm.patch
Normal file
34
community/libvirt/arm.patch
Normal file
|
@ -0,0 +1,34 @@
|
|||
Needed for architectures that don't use gcc atomic ops but pthread. This
|
||||
fixes the armel build that otherwise breaks like:
|
||||
|
||||
CCLD virt-login-shell
|
||||
../src/.libs/libvirt-setuid-rpc-client.a(libvirt_setuid_rpc_client_la-virobject.o): In function `virClassNew':
|
||||
/«PKGBUILDDIR»/debian/build/src/../../../src/util/virobject.c:150: undefined reference to `virAtomicLock'
|
||||
../src/.libs/libvirt-setuid-rpc-client.a(libvirt_setuid_rpc_client_la-virobject.o): In function `virObjectNew':
|
||||
/«PKGBUILDDIR»/debian/build/src/../../../src/util/virobject.c:202: undefined reference to `virAtomicLock'
|
||||
../src/.libs/libvirt-setuid-rpc-client.a(libvirt_setuid_rpc_client_la-virobject.o): In function `virObjectUnref':
|
||||
/«PKGBUILDDIR»/debian/build/src/../../../src/util/virobject.c:274: undefined reference to `virAtomicLock'
|
||||
../src/.libs/libvirt-setuid-rpc-client.a(libvirt_setuid_rpc_client_la-virobject.o): In function `virObjectRef':
|
||||
/«PKGBUILDDIR»/debian/build/src/../../../src/util/virobject.c:295: undefined reference to `virAtomicLock'
|
||||
collect2: error: ld returned 1 exit status
|
||||
|
||||
See https://buildd.debian.org/status/fetch.php?pkg=libvirt&arch=armel&ver=1.1.4-1&stamp=1383588268
|
||||
---
|
||||
src/Makefile.am | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 21b9caf..ad39b74 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -1982,6 +1982,8 @@ noinst_LTLIBRARIES += libvirt-setuid-rpc-client.la
|
||||
|
||||
libvirt_setuid_rpc_client_la_SOURCES = \
|
||||
util/viralloc.c \
|
||||
+ util/viratomic.c \
|
||||
+ util/viratomic.h \
|
||||
util/virbitmap.c \
|
||||
util/virbuffer.c \
|
||||
util/vircommand.c \
|
||||
--
|
||||
1.8.4.2
|
Loading…
Reference in a new issue