added extra/doxygen

This commit is contained in:
Kevin Mihelich 2015-12-12 03:33:21 +00:00
parent 46c016e022
commit e171b22ee4
3 changed files with 143 additions and 0 deletions

View file

@ -0,0 +1,33 @@
From 7725d0a48aee2928dc0544ccbb0aa79ddb3a74d4 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <evangelos@foutrelis.com>
Date: Wed, 9 Dec 2015 18:16:09 +0200
Subject: [PATCH] Partial revert of commit 080a465b1321
Fixes generation of libstd++ man pages.
https://bugzilla.gnome.org/show_bug.cgi?id=759241
---
src/util.cpp | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/src/util.cpp b/src/util.cpp
index 3ee7ae5..0bf9940 100644
--- a/src/util.cpp
+++ b/src/util.cpp
@@ -1741,11 +1741,9 @@ nextChar:
}
else if (i>0 &&
(
- (s.at(i-1)==')' && isId(c)) // ")id" -> ") id"
+ (s.at(i-1)==')' && isId(c))
||
- (c=='\'' && s.at(i-1)==' ') // "'id" -> "' id"
- ||
- (i>1 && s.at(i-2)==' ' && s.at(i-1)==' ') // " id" -> " id"
+ (c=='\'' && s.at(i-1)==' ')
)
)
{
--
2.6.3

78
extra/doxygen/PKGBUILD Normal file
View file

@ -0,0 +1,78 @@
# $Id$
# Maintainer: Dan McGee <dan@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - drop docs package for now, hangs build
# - patch for AArch64
pkgname=doxygen
pkgver=1.8.10
pkgrel=4
license=('GPL')
arch=(i686 x86_64)
url="http://www.doxygen.org/"
makedepends=('cmake' 'gcc-libs' 'flex' 'qt4' 'texlive-core' 'ghostscript'
'texlive-latexextra' 'graphviz' 'python2')
source=(http://ftp.stack.nl/pub/users/dimitri/${pkgname}-${pkgver}.src.tar.gz
0001-Partial-revert-of-commit-080a465b1321.patch
flex-2.6.patch::"https://github.com/heirecka/doxygen/commit/5fcb1357.patch"
doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch)
md5sums=('79767ccd986f12a0f949015efb5f058f'
'93cc5bb3f18c73a3e2b53d6276d87a11'
'b282c91bac1888f607a3676a236d2828'
'7039d4a63c3a0e8ead83d1f828d5a271')
sha1sums=('6bad93cbdb1b2efacba14769d39bcc7bc9c0753b'
'aa03a6a51ff691ffef11d96bb25236f2f7655b6b'
'aeeb45547de0f659789588b563210d9511c6a291'
'5aea21a336015675075b3b8744e4444b0dc6c3d5')
prepare() {
mkdir build
cd "${srcdir}/${pkgname}-${pkgver}"
# Install the man pages in the right place
sed -i 's:DESTINATION man/man1:DESTINATION "${CMAKE_INSTALL_PREFIX}/share/man/man1":g' \
doc/CMakeLists.txt
# https://bugzilla.gnome.org/show_bug.cgi?id=759241
patch -Np1 -i ../0001-Partial-revert-of-commit-080a465b1321.patch
# Fix build with flex 2.6
patch -p1 -i ../flex-2.6.patch
# Fix AArch64 build
patch -p1 -i ../doxygen-1.8.10-drop-qt-arch-x86-64-definition.patch
}
build() {
cd build
cmake "../${pkgbase}-${pkgver}" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DDOC_INSTALL_DIR:PATH=share/doc/doxygen \
-DQT_QMAKE_EXECUTABLE:FILE=/usr/lib/qt4/bin/qmake \
-DPYTHON_EXECUTABLE:FILE=/usr/bin/python2 \
-Dbuild_doc:BOOL=OFF \
-Dbuild_wizard:BOOL=ON
make
}
check(){
cd build
make tests
}
package_doxygen() {
pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
depends=('gcc-libs')
optdepends=('graphviz: for caller/callee graph generation'
'qt4: for doxywizard')
cd build
make DESTDIR="$pkgdir" install
# Docs are in 'doxygen-docs'
rm -rf "${pkgdir}/usr/share/doc"
}

View file

@ -0,0 +1,32 @@
From 031780293d2838da2643b46878061598ebb56822 Mon Sep 17 00:00:00 2001
From: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
Date: Thu, 8 Oct 2015 10:24:36 +0200
Subject: [PATCH] DO NOT hardcode x86-64 architecture.
doxygen built on most of architectures by pure luck and order of Qt5
qatomics_arch.h header where check for QT_ARCH_X86_64 was *after* most
of other architectures.
But not after AArch64 where it failed due to attempt of using x86-64
atomics code.
https://github.com/doxygen/doxygen/pull/402
Signed-off-by: Marcin Juszkiewicz <mjuszkiewicz@redhat.com>
---
addon/doxywizard/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: doxygen-1.8.10/addon/doxywizard/CMakeLists.txt
===================================================================
--- doxygen-1.8.10.orig/addon/doxywizard/CMakeLists.txt
+++ doxygen-1.8.10/addon/doxywizard/CMakeLists.txt
@@ -10,7 +10,7 @@ include_directories(
set(GENERATED_SRC_WIZARD ${GENERATED_SRC}/doxywizard)
file(MAKE_DIRECTORY ${GENERATED_SRC_WIZARD})
-add_definitions(-DQT_ARCH_X86_64 -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
+add_definitions(-DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DUNICODE)
set(QT_USE_QTXML TRUE)
find_package(Qt4 REQUIRED)
include(${QT_USE_FILE})