extra/chromium to 75.0.3770.100-1

This commit is contained in:
Kevin Mihelich 2019-06-18 23:18:00 +00:00
parent 09ad4a21d1
commit e1901df617
2 changed files with 29 additions and 3 deletions

View file

@ -15,8 +15,8 @@ buildarch=12
highmem=1
pkgname=chromium
pkgver=75.0.3770.90
pkgrel=3
pkgver=75.0.3770.100
pkgrel=1
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security"
arch=('x86_64')
@ -34,15 +34,17 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-system-icu.patch
chromium-non-const-deltas.patch
libstdc-do-not-assume-unique_ptr-has-ostream-operator.patch
disallow-partial-swaps-for-linux-based-on-gl_version.patch
chromium-fix-window-flash-for-some-WMs.patch
chromium-widevine.patch
chromium-skia-harmony.patch
0001-crashpad-include-limits.patch)
sha256sums=('b1b59abbe19ecb88c17d99fa68f5c1c5585a5d66c100858f944aa3b93b943839'
sha256sums=('9e1360101b6d9f9635e540db77626e3e15b452f413d8750518244ac37b73fca0'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'e2d284311f49c529ea45083438a768db390bde52949995534034d2a814beab89'
'09c5f16b726ef7031d74807b534fbbfa49a7276ee2a239b70602de2704fa197c'
'e309dfd9d790f32cb1d23103726ac25e405b6ae6757a1c957a8395667d753908'
'1e4686de75c019f38a3ed947463e429a777d5387fd29310deef2108c58617b07'
'183d8cc712f0bcf1afcb01ce90c4c104a4c8d8070a06f94974a28b007d9e2ce4'
@ -126,6 +128,9 @@ prepare() {
# https://bugs.gentoo.org/661880#c21
patch -Np1 -i ../chromium-system-icu.patch
# https://bugs.gentoo.org/686982#c5
patch -Np1 -i ../chromium-non-const-deltas.patch
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py

View file

@ -0,0 +1,21 @@
Bug: https://bugs.gentoo.org/686982
TabStripModelChange has a defaulted default constructor and a const data member
without a user-defined default constructor. This leads to a bug:
error: defaulting this default constructor would delete it after
its first declaration
We declare the data member as non-const instead.
--- a/chrome/browser/ui/tabs/tab_strip_model_observer.h
+++ b/chrome/browser/ui/tabs/tab_strip_model_observer.h
@@ -103,7 +103,7 @@ class TabStripModelChange {
private:
const Type type_ = kSelectionOnly;
- const std::vector<Delta> deltas_;
+ std::vector<Delta> deltas_;
DISALLOW_COPY_AND_ASSIGN(TabStripModelChange);
};