community/higan: v8 fix

This commit is contained in:
Kevin Mihelich 2017-01-29 18:25:10 +00:00
parent c41c9ac911
commit e1deee3a05
3 changed files with 44 additions and 18 deletions

View file

@ -0,0 +1,40 @@
From 79fe90b4616ad226f1329c7754fc2745dc5139af Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 29 Jan 2017 11:07:56 -0700
Subject: [PATCH] AArch64 fixes
---
libco/sjlj.c | 2 ++
nall/intrinsics.hpp | 2 +-
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/libco/sjlj.c b/libco/sjlj.c
index dfa0aa45..34e4b3c1 100644
--- a/libco/sjlj.c
+++ b/libco/sjlj.c
@@ -10,7 +10,9 @@
*/
#define LIBCO_C
+#define _XOPEN_SOURCE 700
#include "libco.h"
+#include "settings.h"
#include <stdlib.h>
#include <signal.h>
diff --git a/nall/intrinsics.hpp b/nall/intrinsics.hpp
index e5dcaf64..20ed3460 100644
--- a/nall/intrinsics.hpp
+++ b/nall/intrinsics.hpp
@@ -122,7 +122,7 @@ namespace nall {
#elif defined(__amd64__) || defined(_M_AMD64)
#define PROCESSOR_AMD64
auto Intrinsics::processor() -> Processor { return Processor::amd64; }
-#elif defined(__arm__)
+#elif defined(__arm__) || defined(__aarch64__)
#define PROCESSOR_ARM
auto Intrinsics::processor() -> Processor { return Processor::ARM; }
#elif defined(__ppc64__) || defined(_ARCH_PPC64)
--
2.11.0

View file

@ -21,16 +21,17 @@ replaces=('higan-gtk' 'higan-qt')
install='higan.install'
source=("http://download.byuu.org/higan_v${pkgver}-source.7z"
'higan-flags.patch'
'sjlj-declare-xopen-source.patch')
'0001-AArch64-fixes.patch')
sha256sums=('52dadcf2ec5cfab0952e2948cc8acb4883b3996458bce4ecb3995830bb1699f1'
'6ee3489a3cf3e8d09beaa5c1f809824593aa08b61dc9a8c9ddc12a09c89ae6cb'
'2c5af5006f0438a7d7bfe62aa0c540b9e6ee526d45dfcafd65bb8598d50d83d7')
'2c5af5006f0438a7d7bfe62aa0c540b9e6ee526d45dfcafd65bb8598d50d83d7'
'91739473c602d421533fb79c51311ad8d3a0acbbfb95b1b62d85feb2dd6fcb94')
prepare() {
cd higan_v${pkgver}-source
patch -Np1 -i ../higan-flags.patch
patch -Np1 -i ../sjlj-declare-xopen-source.patch
patch -Np1 -i ../0001-AArch64-fixes.patch
}
build() {

View file

@ -1,15 +0,0 @@
Description: Declare that sjlj.c requires X/Open 7
Things from the X/Open 7 standard are used. This has to
be declared when building with -std=c99.
Author: Tobias Hansen <thansen@debian.org>
--- a/libco/sjlj.c
+++ b/libco/sjlj.c
@@ -12,6 +12,7 @@
*/
#define LIBCO_C
+#define _XOPEN_SOURCE 700
#include "libco.h"
#include <stdlib.h>