mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
community/retroarch to 1.7.4-1
This commit is contained in:
parent
84807f4f86
commit
e20de2e66b
2 changed files with 52 additions and 59 deletions
|
@ -7,7 +7,7 @@
|
|||
# - enable GLES
|
||||
|
||||
pkgname=retroarch
|
||||
pkgver=1.7.3
|
||||
pkgver=1.7.4
|
||||
pkgrel=1
|
||||
pkgdesc='Reference frontend for the libretro API'
|
||||
arch=('x86_64')
|
||||
|
@ -20,25 +20,25 @@ depends=('alsa-lib' 'gcc-libs' 'glibc' 'libdrm' 'libgl' 'libpulse' 'libx11'
|
|||
'libass.so' 'libavcodec.so' 'libavformat.so' 'libavutil.so'
|
||||
'libfreetype.so' 'libswresample.so' 'libswscale.so' 'libudev.so'
|
||||
'libusb-1.0.so')
|
||||
makedepends=('vulkan-icd-loader')
|
||||
makedepends=('git' 'vulkan-icd-loader')
|
||||
optdepends=('libretro-overlays: Collection of overlays'
|
||||
'libretro-shaders: Collection of shaders'
|
||||
'python: retroarch-cg2glsl'
|
||||
'retroarch-assets-xmb: XMB menu assets')
|
||||
backup=('etc/retroarch.cfg')
|
||||
source=("retroarch-${pkgver}.tar.gz::https://github.com/libretro/RetroArch/archive/v${pkgver}.tar.gz"
|
||||
source=("git+https://github.com/libretro/RetroArch.git#tag=v${pkgver}"
|
||||
'retroarch-config.patch')
|
||||
sha256sums=('a60c2244609bb87cdb56dd8e1020c3be757569b5246141328804ebc5574327ea'
|
||||
'14f07b31d6bdb049dad62dd12597c292b8d2df5cb2803d15de00a7597d3081fd')
|
||||
sha256sums=('SKIP'
|
||||
'd79c542c126b74a1b221fcc1acbe053b95f76c6c9a6ccefd10b8f459ceee94dd')
|
||||
|
||||
prepare() {
|
||||
cd RetroArch-${pkgver}
|
||||
cd RetroArch
|
||||
|
||||
patch -Np0 -i ../retroarch-config.patch
|
||||
#patch -Np0 -i ../retroarch-config.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd RetroArch-${pkgver}
|
||||
cd RetroArch
|
||||
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
|
@ -53,7 +53,7 @@ build() {
|
|||
}
|
||||
|
||||
package() {
|
||||
cd RetroArch-${pkgver}
|
||||
cd RetroArch
|
||||
|
||||
make DESTDIR="${pkgdir}" install
|
||||
|
||||
|
|
|
@ -1,53 +1,7 @@
|
|||
--- retroarch.cfg.orig 2017-11-21 16:40:48.000000000 +0100
|
||||
+++ retroarch.cfg 2017-12-22 21:37:14.020611669 +0100
|
||||
@@ -41,10 +41,10 @@
|
||||
# libretro_path = "/path/to/libretro.so"
|
||||
|
||||
# A directory for where to search for libretro core implementations.
|
||||
-# libretro_directory =
|
||||
+libretro_directory = /usr/lib/libretro
|
||||
|
||||
# A directory for where to search for libretro core information.
|
||||
-# libretro_info_path =
|
||||
+libretro_info_path = /usr/share/libretro/info
|
||||
|
||||
# Sets log level for libretro cores (GET_LOG_INTERFACE).
|
||||
# If a log level issued by a libretro core is below libretro_log_level, it is ignored.
|
||||
@@ -104,7 +104,7 @@
|
||||
|
||||
# Assets directory. This location is queried by default when menu interfaces try to look for
|
||||
# loadable assets, etc.
|
||||
-# assets_directory =
|
||||
+assets_directory = /usr/share/retroarch/assets
|
||||
|
||||
# Dynamic wallpapers directory. The place to store the wallpapers dynamically
|
||||
# loaded by the menu depending on context.
|
||||
@@ -235,13 +235,13 @@
|
||||
# video_shader_enable = false
|
||||
|
||||
# Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
|
||||
-# video_shader_dir =
|
||||
+video_shader_dir = /usr/share/libretro/shaders
|
||||
|
||||
# CPU-based video filter. Path to a dynamic library.
|
||||
# video_filter =
|
||||
|
||||
# Defines a directory where CPU-based video filters are kept.
|
||||
-# video_filter_dir =
|
||||
+video_filter_dir = /usr/lib/retroarch/filters/video
|
||||
|
||||
# Path to a font used for rendering messages. This path must be defined to enable fonts.
|
||||
# Do note that the _full_ path of the font is necessary!
|
||||
@@ -311,7 +311,7 @@ video_message_bgcolor_opacity = 1.0
|
||||
# audio_dsp_plugin =
|
||||
|
||||
# Directory where DSP plugins are kept.
|
||||
-# audio_filter_dir =
|
||||
+audio_filter_dir = /usr/lib/retroarch/filters/audio
|
||||
|
||||
# Will sync (block) on audio. Recommended.
|
||||
# audio_sync = true
|
||||
@@ -662,7 +662,7 @@ video_message_bgcolor_opacity = 1.0
|
||||
diff -rupN RetroArch.orig/retroarch.cfg RetroArch/retroarch.cfg
|
||||
--- RetroArch.orig/retroarch.cfg 2018-08-31 11:42:23.948303726 +0200
|
||||
+++ RetroArch/retroarch.cfg 2018-08-31 11:46:13.736652832 +0200
|
||||
@@ -621,7 +621,7 @@
|
||||
# menu_show_online_updater = true
|
||||
|
||||
# If disabled, will hide the ability to update cores (and core info files) inside the menu.
|
||||
|
@ -56,3 +10,42 @@
|
|||
|
||||
# If disabled, the libretro core will keep running in the background when we
|
||||
# are in the menu.
|
||||
@@ -750,7 +750,7 @@
|
||||
|
||||
# Assets directory. This location is queried by default when menu interfaces try to look for
|
||||
# loadable assets, etc.
|
||||
-# assets_directory =
|
||||
+assets_directory = /usr/share/retroarch/assets
|
||||
|
||||
# Dynamic wallpapers directory. The place to store the wallpapers dynamically
|
||||
# loaded by the menu depending on context.
|
||||
@@ -763,10 +763,10 @@
|
||||
# rgui_browser_directory =
|
||||
|
||||
# Core directory for libretro core implementations.
|
||||
-# libretro_directory =
|
||||
+libretro_directory = /usr/lib/libretro
|
||||
|
||||
# Core info directory for libretro core information.
|
||||
-# libretro_info_path =
|
||||
+libretro_info_path = /usr/share/libretro/info
|
||||
|
||||
# Path to content database directory.
|
||||
# content_database_path =
|
||||
@@ -778,13 +778,13 @@
|
||||
# cheat_database_path =
|
||||
|
||||
# Defines a directory where CPU-based video filters are kept.
|
||||
-# video_filter_dir =
|
||||
+video_filter_dir = /usr/lib/retroarch/filters/video
|
||||
|
||||
# Directory where DSP plugins are kept.
|
||||
-# audio_filter_dir =
|
||||
+audio_filter_dir = /usr/lib/retroarch/filters/audio
|
||||
|
||||
# Defines a directory where shaders (Cg, CGP, GLSL) are kept for easy access.
|
||||
-# video_shader_dir =
|
||||
+ video_shader_dir = /usr/share/libretro/shaders
|
||||
|
||||
# Recording output directory. Where recordings are saved.
|
||||
# recording_output_directory =
|
||||
|
|
Loading…
Reference in a new issue