mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
extra/chromium to 93.0.4577.82-2
This commit is contained in:
parent
5088062cea
commit
e242a59235
3 changed files with 129 additions and 1 deletions
|
@ -17,7 +17,7 @@ highmem=1
|
|||
|
||||
pkgname=chromium
|
||||
pkgver=93.0.4577.82
|
||||
pkgrel=1
|
||||
pkgrel=2
|
||||
_launcher_ver=8
|
||||
_gcc_patchset=6
|
||||
pkgdesc="A web browser built for speed, simplicity, and security"
|
||||
|
@ -41,6 +41,8 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$pkgn
|
|||
replace-blacklist-with-ignorelist.patch
|
||||
sql-make-VirtualCursor-standard-layout-type.patch
|
||||
chromium-93-ffmpeg-4.4.patch
|
||||
chromium-harfbuzz-3.0.0.patch
|
||||
skia-harfbuzz-3.0.0.patch
|
||||
use-oauth2-client-switches-as-default.patch
|
||||
0001-widevine-support-for-arm.patch
|
||||
0002-Run-blink-bindings-generation-single-threaded.patch
|
||||
|
@ -53,6 +55,8 @@ sha256sums=('5d66214858fcba11a8f733d7a6fab61ed10e13e7df4ed37e63b66a0370fb2853'
|
|||
'd3344ba39b8c6ed202334ba7f441c70d81ddf8cdb15af1aa8c16e9a3a75fbb35'
|
||||
'dd317f85e5abfdcfc89c6f23f4c8edbcdebdd5e083dcec770e5da49ee647d150'
|
||||
'1a9e074f417f8ffd78bcd6874d8e2e74a239905bf662f76a7755fa40dc476b57'
|
||||
'7ce947944a139e66774dfc7249bf7c3069f07f83a0f1b2c1a1b14287a7e15928'
|
||||
'dae11dec5088eb1b14045d8c9862801a342609c15701d7c371e1caccf46e1ffd'
|
||||
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
|
||||
'88bece386073d5a2e970eefcd910010bdc5be2107bdad57bbfc005a4091112f6'
|
||||
'9b385876b5da4e639a1a016213858a514c016cea657a24825223563683dba27f'
|
||||
|
@ -125,6 +129,10 @@ prepare() {
|
|||
# Fix build with older ffmpeg
|
||||
patch -Np1 -i ../chromium-93-ffmpeg-4.4.patch
|
||||
|
||||
# Fix build with harfbuzz 3.0.0
|
||||
patch -Np1 -i ../chromium-harfbuzz-3.0.0.patch
|
||||
patch -Np1 -d third_party/skia <../skia-harfbuzz-3.0.0.patch
|
||||
|
||||
# Revert transition to -fsanitize-ignorelist (needs newer clang)
|
||||
patch -Rp1 -i ../replace-blacklist-with-ignorelist.patch
|
||||
|
||||
|
|
20
extra/chromium/chromium-harfbuzz-3.0.0.patch
Normal file
20
extra/chromium/chromium-harfbuzz-3.0.0.patch
Normal file
|
@ -0,0 +1,20 @@
|
|||
# https://github.com/chromium/chromium/commit/b289f6f3fcbc
|
||||
|
||||
diff --git a/components/paint_preview/common/subset_font.cc b/components/paint_preview/common/subset_font.cc
|
||||
index 8ff0540d9a..20a7d37474 100644
|
||||
--- a/components/paint_preview/common/subset_font.cc
|
||||
+++ b/components/paint_preview/common/subset_font.cc
|
||||
@@ -72,9 +72,11 @@ sk_sp<SkData> SubsetFont(SkTypeface* typeface, const GlyphUsage& usage) {
|
||||
hb_set_t* glyphs =
|
||||
hb_subset_input_glyph_set(input.get()); // Owned by |input|.
|
||||
usage.ForEach(base::BindRepeating(&AddGlyphs, base::Unretained(glyphs)));
|
||||
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||
+ hb_subset_input_set_flags(input.get(), HB_SUBSET_FLAGS_RETAIN_GIDS);
|
||||
|
||||
- HbScoped<hb_face_t> subset_face(hb_subset(face.get(), input.get()));
|
||||
+ HbScoped<hb_face_t> subset_face(hb_subset_or_fail(face.get(), input.get()));
|
||||
+ if (!subset_face)
|
||||
+ return nullptr;
|
||||
HbScoped<hb_blob_t> subset_blob(hb_face_reference_blob(subset_face.get()));
|
||||
if (!subset_blob)
|
||||
return nullptr;
|
100
extra/chromium/skia-harfbuzz-3.0.0.patch
Normal file
100
extra/chromium/skia-harfbuzz-3.0.0.patch
Normal file
|
@ -0,0 +1,100 @@
|
|||
# Minimal diff for harfbuzz 3.0.0 support; based on:
|
||||
# https://github.com/google/skia/commit/66684b17b382
|
||||
# https://github.com/google/skia/commit/51d83abcd24a
|
||||
|
||||
diff --git a/gn/skia.gni b/gn/skia.gni
|
||||
index d98fdc19ee..199335d5c4 100644
|
||||
--- a/gn/skia.gni
|
||||
+++ b/gn/skia.gni
|
||||
@@ -34,8 +34,6 @@ declare_args() {
|
||||
skia_include_multiframe_procs = false
|
||||
skia_lex = false
|
||||
skia_libgifcodec_path = "third_party/externals/libgifcodec"
|
||||
- skia_pdf_subset_harfbuzz =
|
||||
- false # TODO: set skia_pdf_subset_harfbuzz to skia_use_harfbuzz.
|
||||
skia_qt_path = getenv("QT_PATH")
|
||||
skia_skqp_global_error_tolerance = 0
|
||||
skia_tools_require_resources = false
|
||||
@@ -99,6 +97,10 @@ declare_args() {
|
||||
skia_use_libfuzzer_defaults = true
|
||||
}
|
||||
|
||||
+declare_args() {
|
||||
+ skia_pdf_subset_harfbuzz = skia_use_harfbuzz
|
||||
+}
|
||||
+
|
||||
declare_args() {
|
||||
skia_compile_sksl_tests = skia_compile_processors
|
||||
skia_enable_fontmgr_android = skia_use_expat && skia_use_freetype
|
||||
diff --git a/src/pdf/SkPDFSubsetFont.cpp b/src/pdf/SkPDFSubsetFont.cpp
|
||||
index 81c37eef3a..2340a7937b 100644
|
||||
--- a/src/pdf/SkPDFSubsetFont.cpp
|
||||
+++ b/src/pdf/SkPDFSubsetFont.cpp
|
||||
@@ -49,6 +49,37 @@ static sk_sp<SkData> to_data(HBBlob blob) {
|
||||
blob.release());
|
||||
}
|
||||
|
||||
+template<typename...> using void_t = void;
|
||||
+template<typename T, typename = void>
|
||||
+struct SkPDFHarfBuzzSubset {
|
||||
+ // This is the HarfBuzz 3.0 interface.
|
||||
+ // hb_subset_flags_t does not exist in 2.0. It isn't dependent on T, so inline the value of
|
||||
+ // HB_SUBSET_FLAGS_RETAIN_GIDS until 2.0 is no longer supported.
|
||||
+ static HBFace Make(T input, hb_face_t* face) {
|
||||
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||
+ hb_subset_input_set_flags(input, 2/*HB_SUBSET_FLAGS_RETAIN_GIDS*/);
|
||||
+ return HBFace(hb_subset_or_fail(face, input));
|
||||
+ }
|
||||
+};
|
||||
+template<typename T>
|
||||
+struct SkPDFHarfBuzzSubset<T, void_t<
|
||||
+ decltype(hb_subset_input_set_retain_gids(std::declval<T>(), std::declval<bool>())),
|
||||
+ decltype(hb_subset_input_set_drop_hints(std::declval<T>(), std::declval<bool>())),
|
||||
+ decltype(hb_subset(std::declval<hb_face_t*>(), std::declval<T>()))
|
||||
+ >>
|
||||
+{
|
||||
+ // This is the HarfBuzz 2.0 (non-public) interface, used if it exists.
|
||||
+ // This code should be removed as soon as all users are migrated to the newer API.
|
||||
+ static HBFace Make(T input, hb_face_t* face) {
|
||||
+ hb_subset_input_set_retain_gids(input, true);
|
||||
+ // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
+ // If it isn't known if a font is 'tricky', retain the hints.
|
||||
+ hb_subset_input_set_drop_hints(input, false);
|
||||
+ return HBFace(hb_subset(face, input));
|
||||
+ }
|
||||
+};
|
||||
+
|
||||
static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||
const SkPDFGlyphUse& glyphUsage,
|
||||
int ttcIndex) {
|
||||
@@ -71,11 +102,10 @@ static sk_sp<SkData> subset_harfbuzz(sk_sp<SkData> fontData,
|
||||
hb_set_t* glyphs = hb_subset_input_glyph_set(input.get());
|
||||
glyphUsage.getSetValues([&glyphs](unsigned gid) { hb_set_add(glyphs, gid);});
|
||||
|
||||
- hb_subset_input_set_retain_gids(input.get(), true);
|
||||
- // TODO: When possible, check if a font is 'tricky' with FT_IS_TRICKY.
|
||||
- // If it isn't known if a font is 'tricky', retain the hints.
|
||||
- hb_subset_input_set_drop_hints(input.get(), false);
|
||||
- HBFace subset(hb_subset(face.get(), input.get()));
|
||||
+ HBFace subset = SkPDFHarfBuzzSubset<hb_subset_input_t*>::Make(input.get(), face.get());
|
||||
+ if (!subset) {
|
||||
+ return nullptr;
|
||||
+ }
|
||||
HBBlob result(hb_face_reference_blob(subset.get()));
|
||||
return to_data(std::move(result));
|
||||
}
|
||||
diff --git a/third_party/harfbuzz/BUILD.gn b/third_party/harfbuzz/BUILD.gn
|
||||
index 173830de62..4156607ef9 100644
|
||||
--- a/third_party/harfbuzz/BUILD.gn
|
||||
+++ b/third_party/harfbuzz/BUILD.gn
|
||||
@@ -14,6 +14,9 @@ if (skia_use_system_harfbuzz) {
|
||||
system("harfbuzz") {
|
||||
include_dirs = [ "/usr/include/harfbuzz" ]
|
||||
libs = [ "harfbuzz" ]
|
||||
+ if (skia_pdf_subset_harfbuzz) {
|
||||
+ libs += [ "harfbuzz-subset" ]
|
||||
+ }
|
||||
}
|
||||
} else {
|
||||
third_party("harfbuzz") {
|
Loading…
Reference in a new issue